Details

    • Type: Task
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 3.10.0
    • Fix Version/s: 3.11.0
    • Component/s: PMD
    • Labels:
      None

      Description

      Apparently, the Maven PMD plugin does not work with JDK 11.

      Error message:

      [ERROR] Failed to execute goal org.apache.maven.plugins:maven-pmd-plugin:3.10.0:pmd (pmd) on project jetty-util: Execution pmd of goal org.apache.maven.plugins:maven-pmd-plugin:3.10.0:pmd failed: org.apache.maven.reporting.MavenReportException: Unsupported targetJdk value '11'. -> [Help 1]

      See also: https://github.com/eclipse/jetty.project/issues/2948

      Thanks!

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                olamy Olivier Lamy (*$^¨%`£)
                Reporter:
                sbordet Simone Bordet
              • Votes:
                0 Vote for this issue
                Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: