Maven Plugin Tools
  1. Maven Plugin Tools
  2. MPLUGIN-225

Make MojoExecution available as Component compatible with Maven 2

    Details

      Description

      Just like MavenProject it is possible to define the MojoExecution as:

      @Component
      private MojoExecution mojoExecution ;
      

      but actually generated descriptor works only for Maven 3, not for Maven 2

        Issue Links

          Activity

          Robert Scholte created issue -
          Hervé Boutemy made changes -
          Field Original Value New Value
          Link This issue relates to MPLUGIN-204 [ MPLUGIN-204 ]
          Hervé Boutemy added a comment -

          it's already done in MPLUGIN-204, with ITs (java-basic and java-basic-annotations) which check MojoExecution recognition

          or I'm missing something

          Hervé Boutemy made changes -
          Resolution Cannot Reproduce [ 5 ]
          Status Open [ 1 ] Closed [ 6 ]
          Assignee Herve Boutemy [ hboutemy ]
          Robert Scholte added a comment -

          Actually it was Mark Struberg who hit this first.

          In the FirstMojo.java file of the IT I do see a the @Component annotated MojoExecution but does it work?.
          I'm referring to something like http://mojo.codehaus.org/cobertura-maven-plugin/xref/org/codehaus/mojo/cobertura/AbstractCoberturaMojo.html#71
          MPLUGIN-204 talks about $

          {mojo}

          , not about $

          {mojoExecution}

          . Could that be a problem?

          Hervé Boutemy added a comment -

          fixed in r1405318

          generated default value was $

          {mojo}

          , which is only recognized by Maven 3

          replaced by $

          {mojoExecution}

          , which is recognized by Maven 2 too

          Hervé Boutemy made changes -
          Description Just like {{MavenProject}} it should be possible to define the {{MojoExecution}} as:
          {code}
          @Component
          private MojoExecution mojoExecution ;
          {code}
          Just like {{MavenProject}} it is possible to define the {{MojoExecution}} as:
          {code}
          @Component
          private MojoExecution mojoExecution ;
          {code}

          but actually generated descriptor works only for Maven 3, not for Maven 2
          Summary Make MojoExecution available as Component Make MojoExecution available as Component compatible with Maven 2
          Fix Version/s 3.1.1 [ 18639 ]
          Hervé Boutemy made changes -
          Resolution Cannot Reproduce [ 5 ]
          Status Closed [ 6 ] Reopened [ 4 ]
          Hervé Boutemy made changes -
          Status Reopened [ 4 ] Closed [ 6 ]
          Resolution Fixed [ 1 ]
          Mark Thomas made changes -
          Project Import Sun Apr 05 12:08:28 UTC 2015 [ 1428235708524 ]
          Mark Thomas made changes -
          Workflow jira [ 12723210 ] Default workflow, editable Closed status [ 12756218 ]
          Mark Thomas made changes -
          Project Import Mon Apr 06 00:41:51 UTC 2015 [ 1428280911727 ]
          Mark Thomas made changes -
          Workflow jira [ 12960804 ] Default workflow, editable Closed status [ 12997353 ]
          Transition Time In Source Status Execution Times Last Executer Last Execution Date
          Open Open Closed Closed
          52d 7h 44m 1 Hervé Boutemy 02/Nov/12 21:58
          Closed Closed Reopened Reopened
          7h 59m 1 Hervé Boutemy 03/Nov/12 05:58
          Reopened Reopened Closed Closed
          6s 1 Hervé Boutemy 03/Nov/12 05:58

            People

            • Assignee:
              Hervé Boutemy
              Reporter:
              Robert Scholte
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development