Uploaded image for project: 'Maven Project Info Reports Plugin'
  1. Maven Project Info Reports Plugin
  2. MPIR-300

Reporting plugins are reported with wrong version if version specified via pluginManagement

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 2.7
    • Fix Version/s: 2.8.1
    • Component/s: plugin-management
    • Labels:
      None
    • Environment:

      Description

      My pom.xml specifies all plugin versions including the ones for plugins used in the reporting section via pluginManagement. Accoring to http://maven.apache.org/plugins/maven-site-plugin/maven-3.html#Version_Resolution and the ticket MSITE-443 this is fully supported by the maven-site-plugin.

      Unfortunately the maven-project-info-report-plugin does not seem to adhere this version resolution which results in a wrong version in the report.

      The attached example gives a pom.xml, the log file when generating the site, and the resulting plugins.html. The version to look at is from the maven-surefire-report-plugin, which has 2.16 specified in the pluginManagement section (and this version is actually used for generating the surefire report) but the plugins.html report says 2.17 (the latest version).

        Attachments

        1. mvn.log
          2 kB
          Thomas Reitmayr
        2. plugins.html
          5 kB
          Thomas Reitmayr
        3. pom.xml
          1 kB
          Thomas Reitmayr

          Issue Links

            Activity

              People

              • Assignee:
                hboutemy Herve Boutemy
                Reporter:
                treitmayr Thomas Reitmayr
              • Votes:
                1 Vote for this issue
                Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: