Maven
  1. Maven
  2. MNG-836

plugin dependencies cannot be resolved

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 2.0-beta-1
    • Fix Version/s: 2.0-beta-1
    • Component/s: Plugins and Lifecycle
    • Labels:
      None

      Description

      Try: deleting ~/.m2/repository/org/codehaus and then build maven-model.

      Somehow plugin dependencies are not resolved; weird that this doesn't occur more often.
      This is because in DefaultPluginManager the verifyPlugin method calls checkRequiredMavenVersion
      with just the PluginArtifactRepositories. The checkRequiredMavenVersion resolves the plugin and/or
      its dependencies but does not have access to the normal artifact repositories, so only plugin repositories
      can be searched for the plugin's dependencies.

      Modified the verifyPlugin method to add the RemoteArtifactRepositories to the list.

        Issue Links

          Activity

          Kenney Westerhof created issue -
          Kenney Westerhof added a comment -

          First I thought this was because of a duplicate repository <id>; changing it fixed it. But I couldn't
          reproduce it again, and after fixing it it was something else; so I renamed this issue.

          kenneyw made changes -
          Field Original Value New Value
          Summary plugin dependencies cannot be resolved when repository has same <id>. plugin dependencies cannot be resolved
          Original Estimate 1h [ 3600 ]
          Component/s maven-core [ 11340 ]
          Remaining Estimate 1h [ 3600 ]
          Description Try: deleting ~/.m2/repository/org/codehaus and then build maven-model.

          Since the snapshots id is used on both the normal and the plugin repositories,
          maven-modello-plugin's dependencies cannot be resolved. Maven-modello-plugin
          comes from snapshots..../plugins/ and it's dependencies are in snapshots..../.
          Renaming the pluginRepository with id snapshots to something else fixes this,
          but there seems to be a mixup in plugin repo's and artifact repo's.
          Try: deleting ~/.m2/repository/org/codehaus and then build maven-model.

          Somehow plugin dependencies are not resolved; weird that this doesn't occur more often.
          This is because in DefaultPluginManager the verifyPlugin method calls checkRequiredMavenVersion
          with just the PluginArtifactRepositories. The checkRequiredMavenVersion resolves the plugin and/or
          its dependencies but does not have access to the normal artifact repositories, so only plugin repositories
          can be searched for the plugin's dependencies.

          Modified the verifyPlugin method to add the RemoteArtifactRepositories to the list.
          Fix Version/s 2.0-beta-1 [ 11040 ]
          Brett Porter made changes -
          Assignee Kenney Westerhof [ kenneyw ] Brett Porter [ brettporter ]
          Brett Porter added a comment -

          was a regression caused by MNG-757, rolled back

          Brett Porter made changes -
          Resolution Fixed [ 1 ]
          Status Open [ 1 ] Closed [ 6 ]
          John Casey added a comment -

          Do we have a test to prevent this regression in future, or are we no better off than before??

          Brett Porter added a comment -

          we're presently back to where we were, but the above can be used to form a test case

          Kenney Westerhof added a comment -

          I fixed this in r278736, 2005-09-05...

          Vincent Massol made changes -
          Workflow Maven [ 39246 ] Maven New [ 47490 ]
          Benjamin Bentmann made changes -
          Link This issue relates to MNG-2539 [ MNG-2539 ]
          Benjamin Bentmann made changes -
          Link This issue relates to MNG-4191 [ MNG-4191 ]
          Mark Thomas made changes -
          Project Import Sun Apr 05 08:49:45 UTC 2015 [ 1428223785911 ]
          Mark Thomas made changes -
          Workflow jira [ 12712108 ] Default workflow, editable Closed status [ 12752010 ]
          Mark Thomas made changes -
          Project Import Sun Apr 05 21:45:26 UTC 2015 [ 1428270326204 ]
          Mark Thomas made changes -
          Workflow jira [ 12952660 ] Default workflow, editable Closed status [ 12990002 ]
          Transition Time In Source Status Execution Times Last Executer Last Execution Date
          Open Open Closed Closed
          13h 6m 1 Brett Porter 05/Sep/05 20:36

            People

            • Assignee:
              Brett Porter
              Reporter:
              Kenney Westerhof
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Time Tracking

                Estimated:
                Original Estimate - 1h
                1h
                Remaining:
                Remaining Estimate - 1h
                1h
                Logged:
                Time Spent - Not Specified
                Not Specified

                  Development