Uploaded image for project: 'Maven'
  1. Maven
  2. MNG-6997

Please update super-pom to minimally-supported viable versions

    XMLWordPrintableJSON

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: Critical
    • Resolution: Duplicate
    • Affects Version/s: 3.6.3
    • Fix Version/s: None
    • Component/s: POM
    • Labels:
    • Environment:
      Any

      Description

      The minimal pom does not work for Java, because the minimal pom uses maven-compiler-plugin 3.1, and that uses java 1.5, which ... cannot be targeted by the minimal pom. Please update the super-pom for 3.6.3 to use a more recent maven-compiler plugin, at the very least, so users can follow your own documentation without error - the users who need that documentation are not going to have the experience to fix the problem.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                joeo Joseph Ottinger
              • Votes:
                4 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Time Tracking

                  Estimated:
                  Original Estimate - 5m
                  5m
                  Remaining:
                  Remaining Estimate - 5m
                  5m
                  Logged:
                  Time Spent - Not Specified
                  Not Specified