Uploaded image for project: 'Maven'
  1. Maven
  2. MNG-6240

Duplicate components in plugin extension realm when plugin depends on maven-aether-resolver

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 3.5.0
    • Fix Version/s: 3.5.2
    • Component/s: Class Loading
    • Labels:
      None

      Description

      When a plugin extension has a dependency on maven-aether-resolver, the components of this artifact are added into the plugin realm even though Maven Core already provides them. This is a regression introduced by the rename of this module to maven-resolver-provider in 3.5.0.

      This rename has kept all the classes of maven-aether-resolver for compatibility, therefore the old artifact name also needs to be exported by Maven Core in extension.xml.

      A visible side-effect of this is MDEPLOY-221, where the two MetadataGeneratorFactory components of maven-aether-provider (which are SnapshotMetadataGeneratorFactory and VersionsMetadataGeneratorFactory) are present twice as Guice bindings, and wrong metadata information is deployed as a consequence. This is due to the Flex Mojos plugin extension which depends on maven-aether-resolver used in the build.

        Issue Links

          Activity

          gboue Guillaume Boué added a comment - - edited
          hudson Hudson added a comment -

          SUCCESS: Integrated in Jenkins build maven-3.x #1658 (See https://builds.apache.org/job/maven-3.x/1658/)
          MNG-6240 Duplicate components in plugin extension realm when plugin (gboue: http://git-wip-us.apache.org/repos/asf/?p=maven.git&a=commit&h=a1fe42199565f76007a97f47cd4a848fd9b63482)

          • (edit) maven-core/src/main/resources/META-INF/maven/extension.xml
          davidkarlsen David J. M. Karlsen added a comment -

          That's grand - when do you think 3.5.1 can be cut - would love getting over to 3.5.x but MNG-6240 is a showstopper for the time being.

          MattNelson Matt Nelson added a comment -

          Could the 3.5.1 fix version be updated with a projected release date?
          https://issues.apache.org/jira/projects/MNG/versions/12338964

          vinayshankar Vinay Shankar added a comment -

          Hello - When would maven version 3.5.1 be released? Seems like the two issues pending have been marked closed but have not been reviewed yet (https://issues.apache.org/jira/projects/MNG/versions/12338964). Is there an estimated release date? We upgraded to 3.5.0 and that seemed to solve other issues we were facing in the previous versions but it has become a show stopper due to this issue (side effect MDEPLOY-221). We would like to upgrade to maven 3.5.1 as soon as possible.

          MattNelson Matt Nelson added a comment -

          Bouncing this again...

          Robert Scholte
          When is the 3.5.1 release planned? This is a serious regression with the latest major version which has been fixed for almost 3 months and still not released.

          rfscholte Robert Scholte added a comment -

          Stephen Connolly will be the release manager for 3.5.1, decisions have been made what will be part of this release.

          chamshoff Christoph Amshoff added a comment -

          I'm sorry if this is annoying, but this issue is clearly a blocker since it randomly breaks builds, and going back to Maven 3.3.9 is not always an option. So what exactly is the reason we can't get some kind of release where this is fixed, nearly 3 months after the issue has been marked as closed? 3.5.1-alpha or such would be fine in case some other planned issues still need a review.

          Moreover, I agree with Jay mann's comment on MDEPLOY-221 that the version 3.5.0 should be marked as buggy on the Maven homepage, or perhaps even revoked.

          Please, don't let Maven users run into this without giving a heads-up, and without a chance to get around it!

          ekrylov Eugene Krylov added a comment -

          +1 on the above comments. We just killed a few hours chasing this down. Had to go back to 3.3.9.

          Could we get a date for 3.5.1 or a patch of some kind.

          purple52 David Edwards added a comment -

          I am having deployment issues (see Maven 3.5.0 causes major deployment issues for build logs, etc) using 3.5.0 on Travis CI, which has lead me to this bug report. The symptoms are that when maven-deploy-plugin runs, the downloads and uploads of metadata get repeated many times (upwards of 10 times per module), which eventually results in our repository (Bintray) rejecting requests with a 405. Rolling back to 3.3.9 resolves the problem. I also found a mailing list thread (Excessive download/upload of maven-metadata.xml during maven deploy) with no conclusion that sounds similar, from after the release of 3.5.0.

          Does this sound like it will be resolved by the fix for this issue in 3.5.1, or should I create a new issue?


            People

            • Assignee:
              gboue Guillaume Boué
              Reporter:
              gboue Guillaume Boué
            • Votes:
              4 Vote for this issue
              Watchers:
              22 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development