Uploaded image for project: 'Maven'
  1. Maven
  2. MNG-6148

Can't package and assemble with JDK9/Jigsaw

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 3.5.2
    • Component/s: None
    • Labels:
      None

      Description

      Rootcause is project verona: Here are the related plugins with their fixed versions:

      • maven-assembly-plugin:3.0.0
      • maven-jar-plugin:3.0.0
      • maven-javadoc-plugin:2.10.4

        Issue Links

          Activity

          Hide
          rfscholte Robert Scholte added a comment -

          Maven Assembly Plugin already upgraded to 3.0.0 with MNG-6192 in Maven 3.5.0

          Show
          rfscholte Robert Scholte added a comment - Maven Assembly Plugin already upgraded to 3.0.0 with MNG-6192 in Maven 3.5.0
          Hide
          rfscholte Robert Scholte added a comment -

          For the Maven Javadoc Plugin MJAVADOC-485 needs to be fixed first

          Show
          rfscholte Robert Scholte added a comment - For the Maven Javadoc Plugin MJAVADOC-485 needs to be fixed first
          Hide
          khmarbaise Karl Heinz Marbaise added a comment -

          Do you have more specific information what's not working with maven-jar-plugin ? any test project for this?

          Show
          khmarbaise Karl Heinz Marbaise added a comment - Do you have more specific information what's not working with maven-jar-plugin ? any test project for this?
          Hide
          rfscholte Robert Scholte added a comment -

          I seems like the version used for maven-jar-plugin (2.4) is not suffering. In the meantime the value of java.version has changed (from 9-ea to 9), so maybe that explains it.
          So it is not required, but probably wise to upgrade.

          Show
          rfscholte Robert Scholte added a comment - I seems like the version used for maven-jar-plugin (2.4) is not suffering. In the meantime the value of java.version has changed (from 9-ea to 9), so maybe that explains it. So it is not required, but probably wise to upgrade.
          Hide
          hudson Hudson added a comment -

          SUCCESS: Integrated in Jenkins build maven-3.x #1662 (See https://builds.apache.org/job/maven-3.x/1662/)
          MNG-6148 Can't package and assemble with JDK9/Jigsaw (rfscholte: http://git-wip-us.apache.org/repos/asf/?p=maven.git&a=commit&h=842db371f0fcaf4e930b99395fb6a8bb442684d6)

          • (edit) pom.xml
          Show
          hudson Hudson added a comment - SUCCESS: Integrated in Jenkins build maven-3.x #1662 (See https://builds.apache.org/job/maven-3.x/1662/ ) MNG-6148 Can't package and assemble with JDK9/Jigsaw (rfscholte: http://git-wip-us.apache.org/repos/asf/?p=maven.git&a=commit&h=842db371f0fcaf4e930b99395fb6a8bb442684d6 ) (edit) pom.xml

            People

            • Assignee:
              rfscholte Robert Scholte
              Reporter:
              rfscholte Robert Scholte
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development