Uploaded image for project: 'Maven'
  1. Maven
  2. MNG-6137

Clean up duplicate dependencies caused by incomplete Wagon HTTP Provider exclusions

    Details

    • Type: Task
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 3.3.9
    • Fix Version/s: 3.5.0-alpha-1, 3.5.0
    • Component/s: Deployment
    • Labels:
      None

      Description

      Some dependencies are duplicated in ${maven.home}/lib because not all shaded dependencies of Wagon HTTP Provider are excluded. This can easily be cleaned up when Wagon 2.12 is merged.

        Issue Links

          Activity

          michael-o Michael Osipov added a comment -
          hudson Hudson added a comment -

          SUCCESS: Integrated in Jenkins build maven-3.x #1533 (See https://builds.apache.org/job/maven-3.x/1533/)
          MNG-6137 Clean up duplicate dependencies caused by incomplete Wagon (michaelo: http://git-wip-us.apache.org/repos/asf/?p=maven.git&a=commit&h=23b5fcffa75b89e5c3141be5269840d6cd70fe12)

          • (edit) apache-maven/pom.xml

            People

            • Assignee:
              michael-o Michael Osipov
              Reporter:
              michael-o Michael Osipov
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development