Maven
  1. Maven
  2. MNG-4341

[regression] Plugins are not executed in POM order

    Details

      Description

      The Selenium Maven Plugin declares

      <plugin>
        <groupId>org.codehaus.groovy.maven</groupId>
        <artifactId>gmaven-plugin</artifactId>
        <executions>
          <execution>
            <goals>
              <goal>generateStubs</goal>
              <goal>compile</goal>
              <goal>generateTestStubs</goal>
              <goal>testCompile</goal>
            </goals>
          </execution>
        </executions>
      </plugin>
      <plugin>
        <groupId>org.apache.maven.plugins</groupId>
        <artifactId>maven-plugin-plugin</artifactId>
        <executions>
          <execution>
            <goals>
              <goal>descriptor</goal>
              <goal>helpmojo</goal>
            </goals>
          </execution>
        </executions>
      </plugin>
      

      i.e. with the gmaven-plugin preceeding the maven-plugin-plugin, yet trunk executes maven-plugin-plugin:helpmojo first, causing it to fail due to "No mojo definitions". The mojos get generated during gmaven-plugin:generateStubs.

        Issue Links

          Activity

          Benjamin Bentmann created issue -
          Benjamin Bentmann added a comment -

          Fixed in r812259.

          Benjamin Bentmann made changes -
          Field Original Value New Value
          Resolution Fixed [ 1 ]
          Status Open [ 1 ] Closed [ 6 ]
          Fix Version/s 3.0-alpha-3 [ 14719 ]
          Assignee Benjamin Bentmann [ bentmann ]
          Benjamin Bentmann made changes -
          Link This issue relates to MNG-4345 [ MNG-4345 ]
          Benjamin Bentmann made changes -
          Link This issue relates to MNG-4344 [ MNG-4344 ]
          Benjamin Bentmann made changes -
          Link This issue relates to MNG-2258 [ MNG-2258 ]
          Mark Thomas made changes -
          Project Import Sun Apr 05 08:49:45 UTC 2015 [ 1428223785911 ]
          Mark Thomas made changes -
          Workflow jira [ 12714665 ] Default workflow, editable Closed status [ 12754343 ]
          Mark Thomas made changes -
          Project Import Sun Apr 05 21:45:26 UTC 2015 [ 1428270326204 ]
          Mark Thomas made changes -
          Workflow jira [ 12952397 ] Default workflow, editable Closed status [ 12989742 ]
          Transition Time In Source Status Execution Times Last Executer Last Execution Date
          Open Open Closed Closed
          5h 6m 1 Benjamin Bentmann 07/Sep/09 15:16

            People

            • Assignee:
              Benjamin Bentmann
              Reporter:
              Benjamin Bentmann
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development