Uploaded image for project: 'Maven'
  1. Maven
  2. MNG-3825

Dependencies with classifier should not always require a version.

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: Dependencies
    • Labels:
      None

      Description

      If I have two dependencies one with a classifier and one without, that look something like this:

      <dependency>
        <groupId>com.mycompany</groupId>
        <artifactId>project1</artifact>
        <version>1</version>
      </dependency>
      <dependency>
        <groupId>com.mycompany</groupId>
        <artifactId>project1</artifact>
        <classifier>client</classifier>
        <version>1</version>
      </dependency>
      

      Currently I need to specify versions for both of them. If I specify the versions in dependency management, I should only have to specify the non-classifier version. The dependency with the classifier should default to the same version as the one without the dependency. This would save a lot of extra configuration for some projects.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                pgier Paul Gier
              • Votes:
                1 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: