Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: 2.0.7
    • Fix Version/s: 2.0.9
    • Component/s: Dependencies
    • Labels:
      None

      Description

      I have two sun jars defined as system dependencies ...

      <!-- AMSDK System Dependencies -->
      <dependency>
      <groupId>sun.amsdk</groupId>
      <artifactId>amclientsdk</artifactId>
      <version>2005q4</version>
      <scope>system</scope>
      <systemPath>$

      {pom.basedir}/amsdk/1amclientsdk.jar</systemPath>
      </dependency>
      <dependency>
      <groupId>sun.amsdk</groupId>
      <artifactId>amservices</artifactId>
      <version>2005q4</version>
      <scope>system</scope>
      <systemPath>${pom.basedir}

      /amsdk/am_services.jar</systemPath>
      </dependency>
      <dependency>
      <groupId>sun.amsdk</groupId>
      <artifactId>amconfig</artifactId>
      <version>2005q4</version>
      <scope>system</scope>
      <systemPath>$

      {pom.basedir}/amsdk</systemPath>
      </dependency>
      <!-- / AMSDK System Dependencies -->

      The reason for the last on is that the sun stuff demands a file called 'AMConfig.properties' file which is actually in the ${pom.basedir}

      /amsdk dir.

      It is absolutely crucial that 1amclientsdk.jar is in the classpath before am_services.jar as they define identical classes but the 1amclientsdk.jar versions are the ones I need (the 1 prefix is an attempt to force it to load early).

      9 times out of 10, the 1amclientsdk.jar is not before the am_services.jar. I have confirmed this using the -X option.

        Issue Links

          Activity

          Luke Daley created issue -
          Hervé Boutemy made changes -
          Field Original Value New Value
          Link This issue relates to MANTTASKS-22 [ MANTTASKS-22 ]
          Brett Porter made changes -
          Fix Version/s 2.0.x [ 13141 ]
          Carlos Sanchez made changes -
          Link This issue relates to MNG-1412 [ MNG-1412 ]
          Hervé Boutemy added a comment -

          duplicate of MNG-1412
          BTW, fixed in 2.0.9-SNAPSHOT...

          Hervé Boutemy made changes -
          Fix Version/s 2.0.9 [ 13801 ]
          Resolution Duplicate [ 3 ]
          Status Open [ 1 ] Closed [ 6 ]
          Fix Version/s 2.0.x [ 13141 ]
          Assignee Herve Boutemy [ hboutemy ]
          Wendy Smoak made changes -
          Link This issue relates to MNG-3494 [ MNG-3494 ]
          Mark Thomas made changes -
          Project Import Sun Apr 05 08:49:45 UTC 2015 [ 1428223785911 ]
          Mark Thomas made changes -
          Link This issue relates to MANTTASKS-22 [ MANTTASKS-22 ]
          Mark Thomas made changes -
          Workflow jira [ 12713587 ] Default workflow, editable Closed status [ 12753394 ]
          Mark Thomas made changes -
          Project Import Sun Apr 05 21:45:26 UTC 2015 [ 1428270326204 ]
          Mark Thomas made changes -
          Link This issue relates to MANTTASKS-22 [ MANTTASKS-22 ]
          Mark Thomas made changes -
          Workflow jira [ 12950434 ] Default workflow, editable Closed status [ 12989123 ]
          Transition Time In Source Status Execution Times Last Executer Last Execution Date
          Open Open Closed Closed
          199d 5h 1m 1 Hervé Boutemy 02/Feb/08 09:07

            People

            • Assignee:
              Hervé Boutemy
              Reporter:
              Luke Daley
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development