Uploaded image for project: 'Maven Javadoc Plugin'
  1. Maven Javadoc Plugin
  2. MJAVADOC-528

Invalid 'expires' attribute

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 3.0.1
    • Fix Version/s: 3.1.0
    • Component/s: javadoc
    • Labels:

      Description

      When detectLinks is enabled and the plugin checks if the url is valid, warnings like this

      Invalid cookie header: "Set-Cookie: logged_in=no; domain=.github.com; path=/; expires=Sun, 06 Jun 2038 14:02:43 -0000; secure; HttpOnly". Invalid 'expires' attribute: Sun, 06 Jun 2038 14:02:43 -0000
      

      may appear.

      Previous warning was due to com.google.code.gson:gson:jar:2.5 dependency and is raised by HttpClient which does not expect 'expires' values compliant to RFC 6265.
      The attachment is a patch which makes HttpClient ignore cookies. Maybe a better solution would be upgrading to the latest HttpComponents API which supports RFC 6265.

        Attachments

        1. cookie.patch
          1 kB
          Roberto Benedetti

          Issue Links

            Activity

              People

              • Assignee:
                gboue Guillaume Boué
                Reporter:
                roberto.benedetti Roberto Benedetti
              • Votes:
                0 Vote for this issue
                Watchers:
                6 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: