Uploaded image for project: 'Maven Invoker Plugin'
  1. Maven Invoker Plugin
  2. MINVOKER-209

ITs fail (on Windows 10) when working directory contains space

    Details

    • Type: Test
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 3.0.0
    • Fix Version/s: 3.0.0
    • Labels:
    • Environment:
      Windows 10

      Description

      When working copy contains some space (common situation on W10 with users directories Firstname/Lastname), most of ITs fail.

      Scenario

      Command:

      mvn invoker:run -Dinvoker.test=special-characters-should-work -Dfile.encoding=UTF-8 -Prun-its,dev
      

      working directory with spaces

      build.log result :

      Running pre-build script: C:\Users\Firstname Lastname\git\maven-plugins\maven-invoker-plugin\target\it\special-characters-should-work\setup.groovy
      Finished pre-build script: C:\Users\Firstname Lastname\git\maven-plugins\maven-invoker-plugin\target\it\special-characters-should-work\setup.groovy
      Erreur : impossible de trouver ou charger la classe principale Lastname\git\maven-plugins\maven-invoker-plugin\target
      

      Content of : DefaultInvoker.executeCommandLine(Commandline, InvocationRequest) (line: ~126)

      cmd:

      cmd.exe /X /C ""C:\Program Files\[MavenDirectory]\bin\mvn.cmd" -B -X -D "maven.repo.local=C:\Users\Firstname Lastname\git\maven-plugins\maven-invoker-plugin\target\local-repo" -s "C:\Users\Firstname Lastname\git\maven-plugins\maven-invoker-plugin\target\it\interpolated-settings.xml" -D maven.compiler.source=1.6 -D maven.compiler.target=1.6 clean verify"
      

      workDir:

      C:\Users\Firstname Lastname\git\maven-plugins\maven-invoker-plugin\target\it\special-characters-should-work
      

      working directory without space

      build.log result:

      Running pre-build script: c:\Windows\Temp\maven-invoker-plugin\target\it\special-characters-should-work\setup.groovy
      Finished pre-build script: c:\Windows\Temp\maven-invoker-plugin\target\it\special-characters-should-work\setup.groovy
      Apache Maven 3.4.0-SNAPSHOT (54827e6b0fc02425f701cfcccde46f81edcb7058; 2016-10-01T18:01:52+02:00)
      ... next lines are ok : BUILD SUCCESS
      

      Content of : DefaultInvoker.executeCommandLine(Commandline, InvocationRequest) (line: ~126)

      cmd:

      cmd.exe /X /C ""C:\Program Files\[MavenDirectory]\bin\mvn.cmd" -B -X -D maven.repo.local=C:\Windows\Temp\maven-invoker-plugin\target\local-repo -s C:\Windows\Temp\maven-invoker-plugin\target\it\interpolated-settings.xml -D maven.compiler.source=1.6 -D maven.compiler.target=1.6 clean verify"
      

      workDir:

      C:\Windows\Temp\maven-invoker-plugin\target\it\special-characters-should-work
      

      I'm not sure of the root cause (invoker initialization or plexus-utils problem )

        Issue Links

          Activity

          michael-o Michael Osipov added a comment -

          The issue is actually two-fold:

          1. Some configuration has not been quoted in the pom.xml. It has been fixed with r1767367.
          2. The mvn.cmd is faulty with Maven 3.3.9. Maven 3.4.0-SNAPSHOT from master works as expected.

          Please verify and I will close as fixed.

          hudson Hudson added a comment -

          SUCCESS: Integrated in Jenkins build maven-plugins #7400 (See https://builds.apache.org/job/maven-plugins/7400/)
          MINVOKER-209 ITs fail (on Windows 10) when working directory contains space (michaelo: http://svn.apache.org/viewvc/?view=rev&rev=1767367)

          • (edit) maven-invoker-plugin/pom.xml
          axel3rd Alix Lourme added a comment -

          Hi Michael Osipov,

          I confirm r1767367 fixes the problem (with Maven 3.4.0-SNAPSHOT of 2016-10-01 & 2016-10-31).
          (Very good catch, I didn't thought at java.io.tmpdir relation )

          Not directly linked to this issue, but quick patch usefull to execute multiple time special-characters-should-work without clean : MINVOKER-209-maven-invoker-plugin-IT-double-exec-special-characters-should-work.patch (File.renameTo return false if file already exists).

          Best regards.

          michael-o Michael Osipov added a comment -

          I afraid that I have to revert this patch because it breaks the Bourne shell script now:

          $ export MAVEN_OPTS="\"-Djava.io.tmpdir=/tmp/mo toll\""
          
          $ ~/apache-maven-3.4.0-SNAPSHOT/bin/mvn clean
          + [ -z '' ]
          + [ -f /etc/mavenrc ]
          + [ -f /net/home/osipovmi/.mavenrc ]
          + cygwin=false
          + mingw=false
          + uname
          + PRG=/net/home/osipovmi/apache-maven-3.4.0-SNAPSHOT/bin/mvn
          + [ -h /net/home/osipovmi/apache-maven-3.4.0-SNAPSHOT/bin/mvn ]
          + pwd
          + saveddir=/net/home/osipovmi/blnn719x/Projekte/maven-invoker-plugin
          + dirname /net/home/osipovmi/apache-maven-3.4.0-SNAPSHOT/bin/mvn
          + MAVEN_HOME=/net/home/osipovmi/apache-maven-3.4.0-SNAPSHOT/bin/..
          + cd /net/home/osipovmi/apache-maven-3.4.0-SNAPSHOT/bin/..
          + pwd
          + MAVEN_HOME=/net/home/osipovmi/apache-maven-3.4.0-SNAPSHOT
          + cd /net/home/osipovmi/blnn719x/Projekte/maven-invoker-plugin
          + false
          + false
          + [ -z '' ]
          + which java
          + JAVACMD=/usr/local/bin/java
          + [ ! -x /usr/local/bin/java ]
          + CLASSWORLDS_LAUNCHER=org.codehaus.plexus.classworlds.launcher.Launcher
          + echo /net/home/osipovmi/apache-maven-3.4.0-SNAPSHOT/boot/plexus-classworlds-2.5.2.jar
          + CLASSWORLDS_JAR=/net/home/osipovmi/apache-maven-3.4.0-SNAPSHOT/boot/plexus-classworlds-2.5.2.jar
          + false
          + find_maven_basedir
          + pwd
          + basedir=/net/home/osipovmi/blnn719x/Projekte/maven-invoker-plugin
          + pwd
          + wdir=/net/home/osipovmi/blnn719x/Projekte/maven-invoker-plugin
          + [ /net/home/osipovmi/blnn719x/Projekte/maven-invoker-plugin != / ]
          + [ -d /net/home/osipovmi/blnn719x/Projekte/maven-invoker-plugin/.mvn ]
          + cd /net/home/osipovmi/blnn719x/Projekte/maven-invoker-plugin/..
          + pwd
          + wdir=/net/home/osipovmi/blnn719x/Projekte
          + [ /net/home/osipovmi/blnn719x/Projekte != / ]
          + [ -d /net/home/osipovmi/blnn719x/Projekte/.mvn ]
          + cd /net/home/osipovmi/blnn719x/Projekte/..
          + pwd
          + wdir=/net/home/osipovmi/blnn719x
          + [ /net/home/osipovmi/blnn719x != / ]
          + [ -d /net/home/osipovmi/blnn719x/.mvn ]
          + cd /net/home/osipovmi/blnn719x/..
          + pwd
          + wdir=/net/home/osipovmi
          + [ /net/home/osipovmi != / ]
          + [ -d /net/home/osipovmi/.mvn ]
          + cd /net/home/osipovmi/..
          + pwd
          + wdir=/net/home
          + [ /net/home != / ]
          + [ -d /net/home/.mvn ]
          + cd /net/home/..
          + pwd
          + wdir=/net
          + [ /net != / ]
          + [ -d /net/.mvn ]
          + cd /net/..
          + pwd
          + wdir=/
          + [ / != / ]
          + echo /net/home/osipovmi/blnn719x/Projekte/maven-invoker-plugin
          + MAVEN_PROJECTBASEDIR=/net/home/osipovmi/blnn719x/Projekte/maven-invoker-plugin
          + concat_lines /net/home/osipovmi/blnn719x/Projekte/maven-invoker-plugin/.mvn/jvm.config
          + [ -f /net/home/osipovmi/blnn719x/Projekte/maven-invoker-plugin/.mvn/jvm.config ]
          + MAVEN_OPTS=' "-Djava.io.tmpdir=/tmp/mo toll"'
          + false
          + export MAVEN_PROJECTBASEDIR
          + MAVEN_CMD_LINE_ARGS=' clean'
          + export MAVEN_CMD_LINE_ARGS
          + exec /usr/local/bin/java -classpath /net/home/osipovmi/apache-maven-3.4.0-SNAPSHOT/boot/plexus-classworlds-2.5.2.jar '"-Djava.io.tmpdir=/tmp/mo' 'toll"' -Dclassworlds.conf=/net/home/osipovmi/apache-maven-3.4.0-SNAPSHOT/bin/m2.conf -Dmaven.home=/net/home/osipovmi/apache-maven-3.4.0-SNAPSHOT -Dmaven.multiModuleProjectDirectory=/net/home/osipovmi/blnn719x/Projekte/maven-invoker-plugin org.codehaus.plexus.classworlds.launcher.Launcher clean
          Fehler: Hauptklasse "-Djava.io.tmpdir=.tmp.mo konnte nicht gefunden oder geladen werden
          
          michael-o Michael Osipov added a comment -

          I have reverted my commit in r1767475 due to the aforementioned regression.

          michael-o Michael Osipov added a comment -

          Unless someone has a bright idea for MNG-4559, I see not portable way to solve this issue properly.

          axel3rd Alix Lourme added a comment -

          If this problem is only on maven-invoker-plugin ITs execution and does not hide a maven-invoker-plugin problem at usage, perhaps using OS profile activation in complement of run-its profile could a workaround ?

          michael-o Michael Osipov added a comment -

          This is the same workaround I had in my mind, though I would really like to see a real fix for that. Please create a patch, I will validate and apply it.

          axel3rd Alix Lourme added a comment - - edited

          MINVOKER-209-workaround-maven-invoker-plugin.patch : Workaround as discussed (+ minor ITs fixes for re-execute without clean)

          michael-o Michael Osipov added a comment -

          Thanks, I will have a look at the patch later that day.

          michael-o Michael Osipov added a comment -

          Fixed with r1768121. Passes on Windows 10 and FreeBSD 10.3-RELEASE. I have applied the patch to pom.xml only. Please create a separate issue for the remaining improvements.

          axel3rd Alix Lourme added a comment -

          Please create a separate issue for the remaining improvements.

          Please consider MINVOKER-211

          hudson Hudson added a comment -

          SUCCESS: Integrated in Jenkins build maven-plugins #7432 (See https://builds.apache.org/job/maven-plugins/7432/)
          MINVOKER-209 ITs fail (on Windows 10) when working directory contains space

          Submitted by: Alix Lourme <alix.lourme@gmail.com> (michaelo: http://svn.apache.org/viewvc/?view=rev&rev=1768121)

          • (edit) maven-invoker-plugin/pom.xml
          rfscholte Robert Scholte added a comment -

          Reopening, IT 'special-characters-should-work' is still failing on my system. Traced it back to r1763932 where the test was adjusted with extra spaces.

          Apache Maven 3.3.9 (bb52d8502b132ec0a5a3f4c09453c07478323dc5; 2015-11-10T17:41:47+01:00)
          Maven home: d:\apache-maven-3.3.9\bin\..
          Java version: 1.7.0_55, vendor: Oracle Corporation
          Java home: C:\Program Files\Java\jdk1.7.0_55\jre
          Default locale: nl_NL, platform encoding: Cp1252
          OS name: "windows 8.1", version: "6.3", arch: "amd64", family: "windows"
          
          michael-o Michael Osipov added a comment -

          Did you retest with Maven's pre-reset master branch?

          rfscholte Robert Scholte added a comment -

          No, but if this means that it doesn't work for Windows + M3.3.9 or less, that should be added to IT as criteria.

          michael-o Michael Osipov added a comment -

          Confirmed on:

          D:\Entwicklung\Projekte\maven invoker plugin>mvn -v
          Apache Maven 3.3.9 (bb52d8502b132ec0a5a3f4c09453c07478323dc5; 2015-11-10T17:41:47+01:00)
          Maven home: D:\Entwicklung\Programme\apache-maven-3.3.9\bin\..
          Java version: 1.8.0_112, vendor: Oracle Corporation
          Java home: C:\Program Files\Java\jdk1.8.0_112\jre
          Default locale: de_DE, platform encoding: Cp1252
          OS name: "windows 10", version: "10.0", arch: "amd64", family: "dos"
          

          with

          [INFO] Building: special-characters-should-work\pom.xml
          [INFO] run script setup.groovy
          [INFO] ..FAILED (3.0 s)
          [INFO]   The build exited with code 1. See D:\Entwicklung\Projekte\maven invoker plugin\target\it\special-characters-should-work\build.log for details.
          [INFO] Building: staging-dependencies\pom.xml
          [INFO] run script verify.bsh
          [INFO] ..SUCCESS (5.2 s)
          [INFO] Building: staging-pom\pom.xml
          [INFO] run script verify.bsh
          [INFO] ..SUCCESS (2.0 s)
          [INFO] Building: staging-reactor\pom.xml
          [INFO] run script verify.bsh
          [INFO] ..SUCCESS (3.4 s)
          [INFO] Building: wrongPropertyInterpolation\pom.xml
          [INFO] ..SUCCESS (12.1 s)
          [INFO]
          [INFO] --- maven-checkstyle-plugin:2.15:check (checkstyle-check) @ maven-invoker-plugin ---
          [INFO] There is 1 error reported by Checkstyle 6.1.1 with config/maven_checks.xml ruleset.
          [INFO] Ignored 1 error, 0 violation remaining.
          [INFO]
          [INFO] --- maven-invoker-plugin:2.0.0:verify (integration-test) @ maven-invoker-plugin ---
          [INFO] -------------------------------------------------
          [INFO] Build Summary:
          [INFO]   Passed: 56, Failed: 1, Errors: 0, Skipped: 0
          [INFO] -------------------------------------------------
          [ERROR] The following builds failed:
          [ERROR] *  special-characters-should-work\pom.xml
          [INFO] -------------------------------------------------
          [INFO] ------------------------------------------------------------------------
          [INFO] BUILD FAILURE
          [INFO] ------------------------------------------------------------------------
          [INFO] Total time: 04:33 min
          [INFO] Finished at: 2017-01-16T20:21:19+01:00
          [INFO] Final Memory: 61M/1339M
          [INFO] ------------------------------------------------------------------------
          
          rfscholte Robert Scholte added a comment -

          For now I'd suggest to revert the changes r1763932 which added spaces to the IT (the special characters is already a valuable test). Next create 2 ITs for the spaces: one for non-windows, one for windows + M3.5.0+ and a big fat note saying these can be combined once MINVOKER-214 is available.
          Michael Osipov I can pick this up, just let me know.

          michael-o Michael Osipov added a comment -

          Yes, please go ahead and do so. Thank you!

          hudson Hudson added a comment -

          FAILURE: Integrated in Jenkins build maven-plugins #8552 (See https://builds.apache.org/job/maven-plugins/8552/)
          MINVOKER-209 ITs fail (on Windows 10) when working directory contains space
          Split ITs since there's no multi-criteria support yet (rfscholte: http://svn.apache.org/viewvc/?view=rev&rev=1779169)

          • (add) maven-invoker-plugin/src/it/spaces-should-work_non-windows
          • (add) maven-invoker-plugin/src/it/spaces-should-work_non-windows/invoker.properties
          • (add) maven-invoker-plugin/src/it/spaces-should-work_non-windows/pom.xml
          • (add) maven-invoker-plugin/src/it/spaces-should-work_non-windows/setup.groovy
          • (add) maven-invoker-plugin/src/it/spaces-should-work_non-windows/src
          • (add) maven-invoker-plugin/src/it/spaces-should-work_non-windows/src/it
          • (add) maven-invoker-plugin/src/it/spaces-should-work_non-windows/src/it/minvoker-test
          • (add) maven-invoker-plugin/src/it/spaces-should-work_non-windows/src/it/minvoker-test/invoker.properties
          • (add) maven-invoker-plugin/src/it/spaces-should-work_non-windows/src/it/minvoker-test/pom.xml
          • (add) maven-invoker-plugin/src/it/spaces-should-work_non-windows/src/it/minvoker-test/verify.groovy
          • (add) maven-invoker-plugin/src/it/spaces-should-work_windows
          • (add) maven-invoker-plugin/src/it/spaces-should-work_windows/invoker.properties
          • (add) maven-invoker-plugin/src/it/spaces-should-work_windows/pom.xml
          • (add) maven-invoker-plugin/src/it/spaces-should-work_windows/setup.groovy
          • (add) maven-invoker-plugin/src/it/spaces-should-work_windows/src
          • (add) maven-invoker-plugin/src/it/spaces-should-work_windows/src/it
          • (add) maven-invoker-plugin/src/it/spaces-should-work_windows/src/it/minvoker-test
          • (add) maven-invoker-plugin/src/it/spaces-should-work_windows/src/it/minvoker-test/invoker.properties
          • (add) maven-invoker-plugin/src/it/spaces-should-work_windows/src/it/minvoker-test/pom.xml
          • (add) maven-invoker-plugin/src/it/spaces-should-work_windows/src/it/minvoker-test/verify.groovy
          • (edit) maven-invoker-plugin/src/it/special-characters-should-work/setup.groovy
          rfscholte Robert Scholte added a comment -

          Fixed in r1779169 (Hudson fails due to m-javadoc-p)


            People

            • Assignee:
              michael-o Michael Osipov
              Reporter:
              axel3rd Alix Lourme
            • Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development