Currently, the master actor and the `/roles` endpoint use the following names for different resource subsets:
there is an offer with this resource -> offered
there is a task/executor running on this resource -> allocated
resource is reserved (maybe offered or allocated, maybe not) -> reserved
resource is subject to quota and allocated or reserved ->* quota consumption*
(note that offered and allocated are disjoint: a resource is either allocated or offered, but never both)
However, the word allocated (and related ones) are still used throughout the allocator code for designating all resources which has been offered at some point but have not been recovered yet.
We should make the nomenclature used in the allocator code consistent with the master.