XMLWordPrintableJSON

    Details

    • Type: Dependency upgrade
    • Status: Open
    • Priority: Minor
    • Resolution: Unresolved
    • Affects Version/s: 3.0.0-M3
    • Fix Version/s: 3.0.1
    • Component/s: Plugin

      Description

      Since even Maven switched to JUnit5 [1], it'd be great to move forward and use JUnit5 in Enforcer too. The only problem is that it requires Java 8. [2]

      Even if it won't happen with 3.x version, it's ok to put this task to backlog.

       

      [1] https://github.com/apache/maven/commit/bb916d0784c7631866167928e4d0615df3317567

       

      [2] https://junit.org/junit5/docs/current/user-guide/#overview-java-versions

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                KroArtem Krosheninnikov Artem
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated: