Uploaded image for project: 'Maven Enforcer Plugin'
  1. Maven Enforcer Plugin
  2. MENFORCER-337

Detected JDK Version: 11.0.4 is not in the allowed range 12

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Invalid
    • Affects Version/s: 3.0.0-M2
    • Fix Version/s: None
    • Component/s: Standard Rules
    • Labels:
      None

      Description

      <build>
       <plugins>
       <plugin>
       <groupId>org.apache.maven.plugins</groupId>
       <artifactId>maven-enforcer-plugin</artifactId>
       <version>3.0.0-M2</version>
       <configuration>
       <rules>
       <requireJavaVersion>
       <version>12</version>
       </requireJavaVersion>
       </rules>
       </configuration>
       </plugin>
       </plugins>
      </build>

      [INFO] — maven-enforcer-plugin:3.0.0-M2:enforce (enforce) @ java8-demo ---
      [INFO] Adding ignore: module-info
      [INFO] Adding ignore: META-INF/versions/*/module-info
      [WARNING] Rule 0: org.apache.maven.plugins.enforcer.RequireJavaVersion failed with message:
      Detected JDK Version: 11.0.4 is not in the allowed range 12.
      [INFO] ------------------------------------------------------------------------
      [INFO] BUILD FAILURE
      [INFO] ------------------------------------------------------------------------

        Attachments

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              natros Filipe Sousa
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: