Uploaded image for project: 'Maven Enforcer Plugin'
  1. Maven Enforcer Plugin
  2. MENFORCER-222

RequireSameVersion rule regression between 1.3 and 1.4

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 1.4
    • Fix Version/s: 1.4.1
    • Component/s: Rule API
    • Labels:
      None
    • Environment:

      Description

      I tried a simple example of requiresameversion rule and it's failing fine in 1.3 version but not failing in 1.4

      <requireSameVersions>
      <dependencies>
      <dependency>org.eclipse:*</dependency>
      </dependencies>
      </requireSameVersions>

      Use the attached file to test :
      mvn validate => build success
      mvn validate -P previousversion => build failed

      It is expected to failed in both use case.

        Attachments

        1. parent.zip
          2 kB
          Benoit MAGGI

          Activity

            People

            • Assignee:
              khmarbaise Karl Heinz Marbaise
              Reporter:
              bmaggi Benoit MAGGI
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: