Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 2.6
    • Fix Version/s: 2.7
    • Component/s: AJDT support
    • Labels:
      None

      Description

      MECLIPSE-443 broken ajdt support as *.java files are now specified as "included" where previously this was empty.
      This means that *.aj files are no longer on the classpath and this break ajdt support.

        Issue Links

          Activity

          baerrach Barrie Treloar added a comment -

          Moved inclusion/exclusion patterns out of EclipseClasspathWriter and into EclipsePlugin extract methods where the EclipseSourceDir gets created and defines the includes/excludes.

          If ajdt is enable then all sources directories will include */.aj files.

          The aspect directory will also include */.java files.

          Added toString() to EclipseSourceDir.

          The generated resource directory for manifest handling (target/generated-resources/eclipse) no longer exclude java files.
          Since we create that directory and copy the MANIFEST.MF file into it there isn't much need for exclusion.
          Test cases updated to reflect this.

          Test case for MECLIPSE-538 created.

          werdna Andrew Eisenberg added a comment -

          Will this fix be included in 2.6.1 (if this build occurs)?

          baerrach Barrie Treloar added a comment -

          No 2.6.1 has been renamed to 2.7.
          As the consensus was that even though the issues fixed resolved a regression issue they did so by adding new features.

          Arnaud is working on getting 2.7 out shortly.


            People

            • Assignee:
              baerrach Barrie Treloar
              Reporter:
              baerrach Barrie Treloar
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development