Uploaded image for project: 'Maven Deploy Plugin'
  1. Maven Deploy Plugin
  2. MDEPLOY-229

Error injecting: org.apache.maven.artifact.deployer.DefaultArtifactDeployer in Maven 3.3.9

    XMLWordPrintableJSON

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Critical
    • Resolution: Invalid
    • Affects Version/s: 2.8.2
    • Fix Version/s: None
    • Component/s: deploy:deploy
    • Labels:
      None
    • Environment:
      Maven 3.3.9

      Description

      The stacktrace is huge but I think the gist is:

      java.lang.IllegalArgumentException: Can not set org.eclipse.aether.spi.log.Logger field org.apache.maven.repository.internal.DefaultVersionRangeResolver.logger to org.eclipse.aether.internal.impl.slf4j.Slf4jLoggerFactory

      Tried the same with Maven 3.5.0 and it works fine.

      Full stack trace: https://gist.github.com/jakub-bochenski/08b7e9dce1823ef55c2335eb7e79fb14

        Attachments

          Activity

            People

            • Assignee:
              rfscholte Robert Scholte
              Reporter:
              jbochenski Jakub Bochenski
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: