Maven Compiler Plugin
  1. Maven Compiler Plugin
  2. MCOMPILER-99

Spaces in for external executable are not accepted

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 2.1
    • Fix Version/s: 2.4
    • Labels:
      None
    • Environment:
      Windows XP

      Description

      When the path to the external executable in <executable> contains space(s), the build will fail: the command is misunderstood because it stops at the first space encountered.

      Example:
      <executable>C:\Program Files\java\jdk1.6.0_11\bin\javac.exe</executable>
      The plugin will try to execute "C:\Program" instead.

      On windows the only workaround I know of is:
      <executable>C:\PROGRA~1\java\jdk1.6.0_11\bin\javac.exe</executable>

        Activity

        Jean-Marc Borer created issue -
        Robert Scholte added a comment -

        Could someone verify if this is still a problem? With Windows7 I'm not able to reproduce this issue.
        The problem should be caused by the plexus-compiler. Meanwhile we've already updated its version from 1.6 (used by maven-compiler-plugin-2.1) to 1.8.2. Strange enough Plexus' Jira doesn't refer to such an issue.

        Olivier Lamy (*$^¨%`£) added a comment -

        tested on osx

        Olivier Lamy (*$^¨%`£) made changes -
        Field Original Value New Value
        Status Open [ 1 ] Closed [ 6 ]
        Resolution Fixed [ 1 ]
        Fix Version/s 2.4 [ 16208 ]
        Assignee Olivier Lamy [ olamy ]
        Mark Thomas made changes -
        Project Import Sun Apr 05 09:20:51 UTC 2015 [ 1428225651644 ]
        Mark Thomas made changes -
        Workflow jira [ 12718614 ] Default workflow, editable Closed status [ 12750040 ]
        Mark Thomas made changes -
        Project Import Sun Apr 05 22:48:53 UTC 2015 [ 1428274133206 ]
        Mark Thomas made changes -
        Workflow jira [ 12956038 ] Default workflow, editable Closed status [ 12993103 ]
        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open Closed Closed
        1066d 5h 58m 1 Olivier Lamy (*$^¨%`£) 27/Apr/12 08:42

          People

          • Assignee:
            Olivier Lamy (*$^¨%`£)
            Reporter:
            Jean-Marc Borer
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development