Uploaded image for project: 'Maven Compiler Plugin'
  1. Maven Compiler Plugin
  2. MCOMPILER-289

Comments in module-info.java break test compile due to parser issue

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 3.6.1
    • Fix Version/s: 3.7.0
    • Labels:
      None
    • Environment:
      MacOS

      Description

      When a comment exists within module definition (after opening curly braces of module), the test compile fails with
      [ERROR] With qdox: syntax error @[8,8] in file:/Users/tomas/IdeaProjects/reproducers/maven-module-info-comments/src/main/java/module-info.java

      To reproduce:

      • unpack reproducer
      • go into subdirectory "maven-module-info-comments"
      • run "mvn test"

      To workaround:

      • remove comment on line 5 in src/main/java/module-info.java
      • run "mvn test"

      Full maven output log:

      [INFO] Error stacktraces are turned on.
      [INFO] Scanning for projects...
      [INFO]                                                                         
      [INFO] ------------------------------------------------------------------------
      [INFO] Building module-info-comments 1.0-SNAPSHOT
      [INFO] ------------------------------------------------------------------------
      [INFO] 
      [INFO] --- maven-resources-plugin:2.6:resources (default-resources) @ module-info-comments ---
      [INFO] Using 'UTF-8' encoding to copy filtered resources.
      [INFO] Copying 0 resource
      [INFO] 
      [INFO] --- maven-compiler-plugin:3.6.1:compile (default-compile) @ module-info-comments ---
      [INFO] Changes detected - recompiling the module!
      [INFO] Compiling 2 source files to /Users/tomas/IdeaProjects/reproducers/maven-module-info-comments/target/classes
      [INFO] 
      [INFO] --- maven-resources-plugin:2.6:testResources (default-testResources) @ module-info-comments ---
      [INFO] Using 'UTF-8' encoding to copy filtered resources.
      [INFO] skip non existing resourceDirectory /Users/tomas/IdeaProjects/reproducers/maven-module-info-comments/src/test/resources
      [INFO] 
      [INFO] --- maven-compiler-plugin:3.6.1:testCompile (default-testCompile) @ module-info-comments ---
      [ERROR] Failed to parse module-info:
      [ERROR] With qdox: syntax error @[8,8] in file:/Users/tomas/IdeaProjects/reproducers/maven-module-info-comments/src/main/java/module-info.java
      [INFO] ------------------------------------------------------------------------
      [INFO] BUILD FAILURE
      [INFO] ------------------------------------------------------------------------
      [INFO] Total time: 1.659 s
      [INFO] Finished at: 2017-01-30T12:13:24+01:00
      [INFO] Final Memory: 14M/47M
      [INFO] ------------------------------------------------------------------------
      [ERROR] Failed to execute goal org.apache.maven.plugins:maven-compiler-plugin:3.6.1:testCompile (default-testCompile) on project module-info-comments: Execution default-testCompile of goal org.apache.maven.plugins:maven-compiler-plugin:3.6.1:testCompile failed: Failed to parse module-info -> [Help 1]
      org.apache.maven.lifecycle.LifecycleExecutionException: Failed to execute goal org.apache.maven.plugins:maven-compiler-plugin:3.6.1:testCompile (default-testCompile) on project module-info-comments: Execution default-testCompile of goal org.apache.maven.plugins:maven-compiler-plugin:3.6.1:testCompile failed: Failed to parse module-info
      	at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:212)
      	at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:153)
      	at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:145)
      	at org.apache.maven.lifecycle.internal.LifecycleModuleBuilder.buildProject(LifecycleModuleBuilder.java:116)
      	at org.apache.maven.lifecycle.internal.LifecycleModuleBuilder.buildProject(LifecycleModuleBuilder.java:80)
      	at org.apache.maven.lifecycle.internal.builder.singlethreaded.SingleThreadedBuilder.build(SingleThreadedBuilder.java:51)
      	at org.apache.maven.lifecycle.internal.LifecycleStarter.execute(LifecycleStarter.java:128)
      	at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:307)
      	at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:193)
      	at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:106)
      	at org.apache.maven.cli.MavenCli.execute(MavenCli.java:863)
      	at org.apache.maven.cli.MavenCli.doMain(MavenCli.java:288)
      	at org.apache.maven.cli.MavenCli.main(MavenCli.java:199)
      	at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      	at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
      	at java.base/jdk.internal.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
      	at java.base/java.lang.reflect.Method.invoke(Method.java:543)
      	at org.codehaus.plexus.classworlds.launcher.Launcher.launchEnhanced(Launcher.java:289)
      	at org.codehaus.plexus.classworlds.launcher.Launcher.launch(Launcher.java:229)
      	at org.codehaus.plexus.classworlds.launcher.Launcher.mainWithExitCode(Launcher.java:415)
      	at org.codehaus.plexus.classworlds.launcher.Launcher.main(Launcher.java:356)
      	at org.codehaus.classworlds.Launcher.main(Launcher.java:47)
      	at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      	at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
      	at java.base/jdk.internal.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
      	at java.base/java.lang.reflect.Method.invoke(Method.java:543)
      	at com.intellij.rt.execution.application.AppMain.main(AppMain.java:143)
      Caused by: org.apache.maven.plugin.PluginExecutionException: Execution default-testCompile of goal org.apache.maven.plugins:maven-compiler-plugin:3.6.1:testCompile failed: Failed to parse module-info
      	at org.apache.maven.plugin.DefaultBuildPluginManager.executeMojo(DefaultBuildPluginManager.java:145)
      	at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:207)
      	... 26 more
      Caused by: java.lang.RuntimeException: Failed to parse module-info
      	at org.apache.maven.plugin.compiler.TestCompilerMojo.preparePaths(TestCompilerMojo.java:322)
      	at org.apache.maven.plugin.compiler.AbstractCompilerMojo.execute(AbstractCompilerMojo.java:742)
      	at org.apache.maven.plugin.compiler.TestCompilerMojo.execute(TestCompilerMojo.java:170)
      	at org.apache.maven.plugin.DefaultBuildPluginManager.executeMojo(DefaultBuildPluginManager.java:134)
      	... 27 more
      [ERROR] 
      [ERROR] Re-run Maven using the -X switch to enable full debug logging.
      [ERROR] 
      [ERROR] For more information about the errors and possible solutions, please read the following articles:
      [ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/PluginExecutionException
      

        Issue Links

          Activity

          khmarbaise Karl Heinz Marbaise added a comment -

          QDox version 2.0-M7 contains the fix for issue 22

          khmarbaise Karl Heinz Marbaise added a comment -

          Fixed in r1804871
          The solution might be superseded by MCOMPILER-303 using plexus-languages component..

          hudson Hudson added a comment -

          SUCCESS: Integrated in Jenkins build maven-plugins #9057 (See https://builds.apache.org/job/maven-plugins/9057/)
          MCOMPILER-289 Comments in module-info.java break test compile due to parser issue
          o Upgraded to qdox version 2.0-M7 which contains the fix. (khmarbaise: http://svn.apache.org/viewvc/?view=rev&rev=1804871)

          • (edit) maven-compiler-plugin/pom.xml

            People

            • Assignee:
              khmarbaise Karl Heinz Marbaise
              Reporter:
              tomas.langer Tomas Langer
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development