Uploaded image for project: 'Maven Compiler Plugin'
  1. Maven Compiler Plugin
  2. MCOMPILER-236

Compilation error due to MCOMPILER-157 in deploy phase

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Duplicate
    • Affects Version/s: 3.2
    • Fix Version/s: 3.5.1
    • Labels:
      None
    • Environment:
      Maven 3.2.3, Java 1.8.0_25

      Description

      After upgrading from 3.1 to 3.2 i'm experiencing compilation errors when running deploy phase.

      It's a mult module project where plugin is configured in master pom:

      <plugin>
      				<groupId>org.apache.maven.plugins</groupId>
      				<artifactId>maven-compiler-plugin</artifactId>
      				<version>3.1</version>
      				<configuration>
      					<source>${compiler.version}</source>
      					<target>${compiler.version}</target>
      					<encoding>UTF-8</encoding>
      					<!-- -parameter: used to retrieve parameter names in runtime. i.e get parameter names for api validations -->
      					<compilerArgument>-parameters</compilerArgument>
      				</configuration>
      			</plugin>
      

      And in one of the modules like this:

       				<plugin>
      					<groupId>org.apache.maven.plugins</groupId>
      					<artifactId>maven-compiler-plugin</artifactId>
      					<configuration>
      						<annotationProcessors>
      							<!-- JPAMetaModelEntityProcessor is an annotation processor based on JSR_269 with the task of creating JPA 2 static metamodel classes -->
      							<annotationProcessor>
      								org.hibernate.jpamodelgen.JPAMetaModelEntityProcessor
      							</annotationProcessor>
      						</annotationProcessors>
      					</configuration>
      				</plugin>
      

      Common builds are all ok, but when using deploy phase i got a compiler error

      An exception has occurred in the compiler (1.8.0_25). Please file a bug at the Java Developer Connection (http://java.sun.com/webapps/bugreport)  after checking the Bug Parade for duplicates. Include your program and the following diagnostic in your report.  Thank you.
      java.lang.IllegalStateException: endPosTable already set
      	at com.sun.tools.javac.util.DiagnosticSource.setEndPosTable(DiagnosticSource.java:136)
      	at com.sun.tools.javac.util.Log.setEndPosTable(Log.java:350)
      	at com.sun.tools.javac.main.JavaCompiler.parse(JavaCompiler.java:667)
      	at com.sun.tools.javac.main.JavaCompiler.parseFiles(JavaCompiler.java:950)
      	at com.sun.tools.javac.processing.JavacProcessingEnvironment$Round.<init>(JavacProcessingEnvironment.java:892)
      	at com.sun.tools.javac.processing.JavacProcessingEnvironment$Round.next(JavacProcessingEnvironment.java:921)
      	at com.sun.tools.javac.processing.JavacProcessingEnvironment.doProcessing(JavacProcessingEnvironment.java:1187)
      	at com.sun.tools.javac.main.JavaCompiler.processAnnotations(JavaCompiler.java:1170)
      	at com.sun.tools.javac.main.JavaCompiler.compile(JavaCompiler.java:856)
      	at com.sun.tools.javac.main.Main.compile(Main.java:523)
      	at com.sun.tools.javac.api.JavacTaskImpl.doCall(JavacTaskImpl.java:129)
      	at com.sun.tools.javac.api.JavacTaskImpl.call(JavacTaskImpl.java:138)
      	at org.codehaus.plexus.compiler.javac.JavaxToolsCompiler.compileInProcess(JavaxToolsCompiler.java:125)
      	at org.codehaus.plexus.compiler.javac.JavacCompiler.performCompile(JavacCompiler.java:169)
      	at org.apache.maven.plugin.compiler.AbstractCompilerMojo.execute(AbstractCompilerMojo.java:823)
      	at org.apache.maven.plugin.compiler.CompilerMojo.execute(CompilerMojo.java:129)
      	at org.apache.maven.plugin.DefaultBuildPluginManager.executeMojo(DefaultBuildPluginManager.java:101)
      	at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:209)
      	at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:153)
      	at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:145)
      	at org.apache.maven.lifecycle.internal.LifecycleModuleBuilder.buildProject(LifecycleModuleBuilder.java:84)
      	at org.apache.maven.lifecycle.internal.LifecycleModuleBuilder.buildProject(LifecycleModuleBuilder.java:59)
      	at org.apache.maven.lifecycle.internal.LifecycleStarter.singleThreadedBuild(LifecycleStarter.java:183)
      	at org.apache.maven.lifecycle.internal.LifecycleStarter.execute(LifecycleStarter.java:161)
      	at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:320)
      	at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:156)
      	at org.apache.maven.cli.MavenCli.execute(MavenCli.java:537)
      	at org.apache.maven.cli.MavenCli.doMain(MavenCli.java:196)
      	at org.apache.maven.cli.MavenCli.main(MavenCli.java:141)
      	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
      	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
      	at java.lang.reflect.Method.invoke(Method.java:483)
      	at org.codehaus.plexus.classworlds.launcher.Launcher.launchEnhanced(Launcher.java:290)
      	at org.codehaus.plexus.classworlds.launcher.Launcher.launch(Launcher.java:230)
      	at org.codehaus.plexus.classworlds.launcher.Launcher.mainWithExitCode(Launcher.java:409)
      	at org.codehaus.plexus.classworlds.launcher.Launcher.main(Launcher.java:352)
      
      

      Here's the full maven -X log.
      http://cryptb.in/Vz9#f956618b3adf70be3133d996ece36db9

      In case you need more information, just let me know

      1. example_prj.tar.gz
        1 kB
        Nicholas Stuart

        Issue Links

          Activity

          petterm Petter Måhlén added a comment -

          I'm seeing this as well without explicitly configuring an annotation processor for the compiler plugin. I am using AutoValue, though, meaning that there's at least one annotation processor at work. FWIW, compilation usually works when I do 'clean compile', but not just 'compile'.

          ender_01 Nicholas Stuart added a comment - - edited

          Example project with very simple pom to reproduce. running:
          mvn compile && mvn compile

          This was crashing on OS X with Java 1.8.0_20. Changing the compiler to 3.1 'fixes' the issues and the project will compile fine.

          jamezp James R. Perkins added a comment -

          Setting the useIncrementalCompilation to false seems to be a workaround.

          mirec.z@gmail.com Miroslav Zaťko added a comment -

          Still here with Maven 3.3.3, Java 1.8.0_45 and maven-compiler-plugin 3.3. No mentioned workaround seems to be working

          jmhodges Jeff Hodges added a comment -

          Just to inform folks: setting useIncrementalCompilation will turn on maven's incremental compilation, not turn it off. And the incremental compile code has a history of not being smart enough to do what you want (plus hurts folks who want to use forked builds).

          The documentation is not clear about this boolean and you have to go digging through the code for that information. See this code and the stale sources calculation that seems to be what's in maven 3.3.

          agudian Andreas Gudian added a comment -

          Underlying cause of the issue is the same as in MCOMPILER-235.

          beletsky.andrey Beletsky Andrey added a comment - - edited

          It is reproducible for me with version 3.6.0:
          after mvn clean install is successful mvn test fails with

          [INFO] --- maven-compiler-plugin:3.6.0:compile (default-compile) @ api ---
          [INFO] Changes detected - recompiling the module!
          [INFO] Compiling 350 source files to .../target/classes
          An exception has occurred in the compiler (1.8.0_111). Please file a bug against the Java compiler via the Java bug reporting page (http://bugreport.java.com) after checking the Bug Database (http://bugs.java.com) for duplicates. Include your program and the following diagnostic in your report. Thank you.
          java.lang.IllegalStateException: endPosTable already set
          	at com.sun.tools.javac.util.DiagnosticSource.setEndPosTable(DiagnosticSource.java:136)
          	at com.sun.tools.javac.util.Log.setEndPosTable(Log.java:350)
          	at com.sun.tools.javac.main.JavaCompiler.parse(JavaCompiler.java:667)
          	at com.sun.tools.javac.main.JavaCompiler.parseFiles(JavaCompiler.java:950)
          	at com.sun.tools.javac.processing.JavacProcessingEnvironment$Round.<init>(JavacProcessingEnvironment.java:892)
          	at com.sun.tools.javac.processing.JavacProcessingEnvironment$Round.next(JavacProcessingEnvironment.java:921)
          	at com.sun.tools.javac.processing.JavacProcessingEnv
          ...
          [ERROR] COMPILATION ERROR : 
          [INFO] -------------------------------------------------------------
          [ERROR] An unknown compilation problem occurred
          [INFO] 1 error
          
          

          with 3.5.1 I have the same issue

          BTW,
          I have lombok, query dsl and mapstruct.

          <plugin>
                  <groupId>org.apache.maven.plugins</groupId>
                  <artifactId>maven-compiler-plugin</artifactId>
                  <version>3.5.1</version>
                  <configuration>
                      <source>1.8</source>
                      <target>1.8</target>
                    <annotationProcessors>
                      <annotationProcessor>lombok.launch.AnnotationProcessorHider$AnnotationProcessor</annotationProcessor>
                      <annotationProcessor>org.mapstruct.ap.MappingProcessor</annotationProcessor>
                    </annotationProcessors>
                    <annotationProcessorPaths>
                      <path>
                        <groupId>org.mapstruct</groupId>
                        <artifactId>mapstruct-processor</artifactId>
                        <version>1.2.0.Beta2</version>
                      </path>
                      <path>
                        <groupId>org.projectlombok</groupId>
                        <artifactId>lombok</artifactId>
                        <version>1.16.16</version>
                      </path>
                    </annotationProcessorPaths>
                    <compilerArgs>
                      <compilerArg>-Amapstruct.suppressGeneratorTimestamp=true</compilerArg>
                      <compilerArg>-Amapstruct.defaultComponentModel=spring</compilerArg>
                      <compilerArg>-Amapstruct.unmappedTargetPolicy=ERROR</compilerArg>
                    </compilerArgs>
                  </configuration>
                </plugin>
          
          facboy Christopher Ng added a comment -

          I've seen this error using 3.6.1 too:

          Fatal error compiling
                  at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:212)
                  at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:153)
                  at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:145)
                  at org.apache.maven.lifecycle.internal.MojoExecutor.executeForkedExecutions(MojoExecutor.java:352)
                  at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:197)
                  at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:153)
                  at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:145)
                  at org.apache.maven.lifecycle.internal.LifecycleModuleBuilder.buildProject(LifecycleModuleBuilder.java:116)
                  at org.apache.maven.lifecycle.internal.LifecycleModuleBuilder.buildProject(LifecycleModuleBuilder.java:80)
                  at org.apache.maven.lifecycle.internal.builder.singlethreaded.SingleThreadedBuilder.build(SingleThreadedBuilder.java:51)
                  at org.apache.maven.lifecycle.internal.LifecycleStarter.execute(LifecycleStarter.java:128)
                  at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:307)
                  at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:193)
                  at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:106)
                  at org.apache.maven.cli.MavenCli.execute(MavenCli.java:863)
                  at org.apache.maven.cli.MavenCli.doMain(MavenCli.java:288)
                  at org.apache.maven.cli.MavenCli.main(MavenCli.java:199)
                  at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
                  at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
                  at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
                  at java.lang.reflect.Method.invoke(Method.java:498)
                  at org.codehaus.plexus.classworlds.launcher.Launcher.launchEnhanced(Launcher.java:289)
                  at org.codehaus.plexus.classworlds.launcher.Launcher.launch(Launcher.java:229)
                  at org.codehaus.plexus.classworlds.launcher.Launcher.mainWithExitCode(Launcher.java:415)
                  at org.codehaus.plexus.classworlds.launcher.Launcher.main(Launcher.java:356)
          Caused by: org.apache.maven.plugin.MojoExecutionException: Fatal error compiling
                  at org.apache.maven.plugin.compiler.AbstractCompilerMojo.execute(AbstractCompilerMojo.java:954)
                  at org.apache.maven.plugin.compiler.CompilerMojo.execute(CompilerMojo.java:137)
                  at org.apache.maven.plugin.DefaultBuildPluginManager.executeMojo(DefaultBuildPluginManager.java:134)
                  at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:207)
                  ... 24 more
          Caused by: org.codehaus.plexus.compiler.CompilerException
                  at org.codehaus.plexus.compiler.javac.errorprone.JavacCompilerWithErrorProne.performCompile(JavacCompilerWithErrorProne.java:95)
                  at org.apache.maven.plugin.compiler.AbstractCompilerMojo.execute(AbstractCompilerMojo.java:943)
                  ... 27 more
          Caused by: java.lang.reflect.InvocationTargetException
                  at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
                  at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
                  at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
                  at java.lang.reflect.Method.invoke(Method.java:498)
                  at org.codehaus.plexus.compiler.javac.errorprone.JavacCompilerWithErrorProne.performCompile(JavacCompilerWithErrorProne.java:91)
                  ... 28 more
          Caused by: java.lang.IllegalStateException: endPosTable already set
                  at com.sun.tools.javac.util.DiagnosticSource.setEndPosTable(DiagnosticSource.java:136)
                  at com.sun.tools.javac.util.Log.setEndPosTable(Log.java:352)
                  at com.sun.tools.javac.main.JavaCompiler.parse(JavaCompiler.java:616)
                  at com.sun.tools.javac.main.JavaCompiler.parseFiles(JavaCompiler.java:900)
                  at com.sun.tools.javac.processing.JavacProcessingEnvironment$Round.<init>(JavacProcessingEnvironment.java:911)
                  at com.sun.tools.javac.processing.JavacProcessingEnvironment$Round.next(JavacProcessingEnvironment.java:939)
                  at com.sun.tools.javac.processing.JavacProcessingEnvironment.doProcessing(JavacProcessingEnvironment.java:1164)
                  at com.sun.tools.javac.main.JavaCompiler.processAnnotations(JavaCompiler.java:1120)
                  at com.sun.tools.javac.main.JavaCompiler.compile(JavaCompiler.java:814)
                  at com.sun.tools.javac.api.JavacTaskImpl$1.call(JavacTaskImpl.java:97)
                  at com.sun.tools.javac.api.JavacTaskImpl$1.call(JavacTaskImpl.java:93)
                  at com.sun.tools.javac.api.JavacTaskImpl.handleExceptions(JavacTaskImpl.java:128)
                  at com.sun.tools.javac.api.JavacTaskImpl.doCall(JavacTaskImpl.java:93)
                  at com.sun.tools.javac.api.JavacTaskImpl.call(JavacTaskImpl.java:87)
                  at com.google.errorprone.BaseErrorProneJavaCompiler$1.call(BaseErrorProneJavaCompiler.java:99)
                  at com.google.errorprone.BaseErrorProneCompiler.run(BaseErrorProneCompiler.java:137)
                  at com.google.errorprone.BaseErrorProneCompiler.run(BaseErrorProneCompiler.java:108)
                  at com.google.errorprone.ErrorProneCompiler.run(ErrorProneCompiler.java:119)
                  at com.google.errorprone.ErrorProneCompiler.compile(ErrorProneCompiler.java:66)
                  at org.codehaus.plexus.compiler.javac.errorprone.JavacCompilerWithErrorProne$CompilerInvoker.compile(JavacCompilerWithErrorProne.java:219)
                  ... 33 more
          

            People

            • Assignee:
              agudian Andreas Gudian
              Reporter:
              fgaule Federico Gaule
            • Votes:
              13 Vote for this issue
              Watchers:
              20 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development