Uploaded image for project: 'Maven Clean Plugin'
  1. Maven Clean Plugin
  2. MCLEAN-63

Make naming of properties consistent

    XMLWordPrintableJSON

Details

    • Improvement
    • Status: Closed
    • Major
    • Resolution: Fixed
    • 2.6.1
    • 3.0.0
    • None

    Description

      The list of properties looks like this:

      @Parameter( property = "clean.verbose" )
      @Parameter( property = "clean.followSymLinks", defaultValue = "false" )
      @Parameter( property = "clean.skip", defaultValue = "false" )
      @Parameter( property = "maven.clean.failOnError", defaultValue = "true" )
      @Parameter( property = "maven.clean.retryOnError", defaultValue = "true" )
      @Parameter( property = "clean.excludeDefaultDirectories", defaultValue = "false" )
      

      The property names should follow the naming convention: maven.PLUGIN.WhatEver So clean.verbose should be changed into maven.clean.verbose, clean.followSymLinks should be changed into maven.clean.followSymLinks, clean.skip should be changed into maven.clean.skip, and clean.excludeDefaultDirectories should be changed into maven.clean.excludeDefaultDirectories.

      The old properties clean.* should be marked deprecated and a WARNING should be emitted. With version 3.X they can be replaced completely.

      Attachments

        Activity

          People

            khmarbaise Karl Heinz Marbaise
            khmarbaise Karl Heinz Marbaise
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved: