Uploaded image for project: 'Commons Math'
  1. Commons Math
  2. MATH-890

Interval and IntervalsSet methods naming are inconsisten

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 3.0
    • Fix Version/s: 3.1
    • Labels:
      None

      Description

      The Interval and IntervalSet in the org.apache.commons.math3.geometry.euclidean.oned package share some features but use different names. IntervalsSet inherit some names from its top level interface (Region) which is independent from dimension and are also consisten with sets composed of disjoint intervals or are infinite. Interval only has names which are meaningful for one dimension, finite intervals.

      For consistency, the specific names provided by Interval API should be replaced by the more generic names provided by the IntervalsSet and Region API. The changes are:

      • getLower -> getInf
      • getUpper -> getSup
      • getLength -> getSize
      • getMidPoint -> getBarycenter

        Attachments

          Activity

            People

            • Assignee:
              luc Luc Maisonobe
              Reporter:
              luc Luc Maisonobe
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: