Uploaded image for project: 'Commons Math'
  1. Commons Math
  2. MATH-839

In "RealDistribution" implementations, rename method "cumulativeProbability(double,double)" to "probability(double,double)"

    Details

    • Type: Task
    • Status: Resolved
    • Priority: Trivial
    • Resolution: Fixed
    • Affects Version/s: 3.0
    • Fix Version/s: 4.0
    • Labels:

      Description

      Cf. http://en.wikipedia.org/wiki/Cumulative_distribution_function
      Cf. http://en.wikipedia.org/wiki/Probability_density_function

      The method currently named "cumulativeProbability(double,double)" in fact provides the probability of the variable to be within the given interval. The name "probability" would thus be more accurate (and shorter).

        Attachments

          Activity

            People

            • Assignee:
              erans Gilles
              Reporter:
              erans Gilles
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: