Affects Version/s: None
Fix Version/s: 3.0
Currently, the "GaussianFitter" class contains a "CurveFitter" instance (and delegates most method calls to it) for the sake of being able to return a "GaussianFunction" instance (from the call to the "fit" method).
I think that it would clearer (in the context of the "fitting" package) that "fit" returns an array of doubles (as "CurveFitter" does). The user can then easily create a "Gaussian" function object, if needed.
[Also, note that the "GaussianFitter" actually fits the sum of a constant and a Gaussian function; thus the name is slightly misleading IMO.]
I also think that "ParametricGaussianFunction" and "GaussianParametersGuesser" should become inner classes of "GaussianFitter" (as this makes it clear what their use is).