Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 2.4
    • Fix Version/s: 3.1.0
    • Component/s: None
    • Labels:
      None

      Description

      I configure the plugin with something like this :

            <plugin>
              <groupId>org.apache.maven.plugins</groupId>
              <artifactId>maven-assembly-plugin</artifactId>
              <configuration>
                <descriptors>
                  <descriptor>plf-standalone-enterprise-tomcat-distribution-content.xml</descriptor>
                </descriptors>
      <descriptorSourceDirectory>src/main/assemblies</descriptorSourceDirectory>
              </configuration>
            </plugin>
      

      But it doesn't find the descriptor (using its filename or its ID)

      [DEBUG] Configuring mojo 'org.apache.maven.plugins:maven-assembly-plugin:2.4:single' with basic configurator -->
      ....
      [DEBUG]   (s) descriptorSourceDirectory = /Users/arnaud/Code/eXo/platform-distributions/plf-enterprise-tomcat-standalone/src/main/assemblies
      [DEBUG]   (s) descriptors = [plf-standalone-enterprise-tomcat-distribution-content.xml]
      ....
      [ERROR] Failed to execute goal org.apache.maven.plugins:maven-assembly-plugin:2.4:single (plf-standalone-tomcat-distribution-content) on project plf-enterprise-tomcat-standalone: Error reading assemblies: Error locating assembly descriptor: plf-standalone-enterprise-tomcat-distribution-content.xml
      [ERROR] 
      [ERROR] [1] [INFO] Searching for file location: /Users/arnaud/Code/eXo/platform-distributions/plf-enterprise-tomcat-standalone/plf-standalone-enterprise-tomcat-distribution-content.xml
      [ERROR] 
      [ERROR] [2] [INFO] File: /Users/arnaud/Code/eXo/platform-distributions/plf-enterprise-tomcat-standalone/plf-standalone-enterprise-tomcat-distribution-content.xml does not exist.
      [ERROR] 
      [ERROR] [3] [INFO] File: /Users/arnaud/Code/eXo/platform-distributions/plf-enterprise-tomcat-standalone/plf-standalone-enterprise-tomcat-distribution-content.xml does not exist.
      

      I simplified the config (I'll need to create an it) in my case i was using a 2nd assembly coming from the classpath

        Activity

        aheritier Arnaud HERITIER added a comment -

        A workaround is to use this config

                      <descriptors>
                        <descriptor>src/main/assemblies/plf-standalone-enterprise-tomcat-distribution-content.xml</descriptor>
                      </descriptors>
        
        michael-o Michael Osipov added a comment -

        Confirmed with 3.0-SNAPSHOT but this is not a bug. There is nothing mentioned that both parameters are chained. They are completely standalone. Wrong assumptions were made. I am inclined to close this one.

        michael-o Michael Osipov added a comment -

        Fixed with r1781812. Clarified in documentation that parameters are disjoint.

        hudson Hudson added a comment -

        SUCCESS: Integrated in Jenkins build maven-plugins #8782 (See https://builds.apache.org/job/maven-plugins/8782/)
        MASSEMBLY-643 descriptorSourceDirectory: parameter isn't used (michaelo: http://svn.apache.org/viewvc/?view=rev&rev=1781812)

        • (edit) maven-assembly-plugin/src/main/java/org/apache/maven/plugins/assembly/mojos/SingleAssemblyMojo.java

          People

          • Assignee:
            michael-o Michael Osipov
            Reporter:
            aheritier Arnaud HERITIER
          • Votes:
            1 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development