Maven Assembly Plugin
  1. Maven Assembly Plugin
  2. MASSEMBLY-223

2-nd <exclude> element of <dependencySets>:<excludes> doesn't work

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 2.2-beta-1
    • Fix Version/s: 2.2-beta-2
    • Component/s: None
    • Labels:
      None
    • Flags:
      Patch

      Description

      I suppose that order of dependencySets:excludes:exclude doesn't make sense.
      But it seems that the plugin has a bug – 2-nd <exclude> element of <dependencySets>:<excludes> doesn't work at all!

      Having such a dependencySet
      <dependencySet>
      <unpack>false</unpack>
      <excludes>
      <exclude>org.eclipse.update.*</exclude>
      <exclude>org.eclipse.equinox.http.*</exclude>
      </excludes>
      </dependencySet>

      I receive warning about
      [WARNING] The following patterns were never triggered in this artifact exclusion filter:
      o 'org.eclipse.equinox.http.*'

      When I change the order of exclude elements
      <dependencySet>
      <unpack>false</unpack>
      <excludes>
      <exclude>org.eclipse.equinox.http.*</exclude>
      <exclude>org.eclipse.update.*</exclude>
      </excludes>
      </dependencySet>

      I receive warning about
      [WARNING] The following patterns were never triggered in this artifact exclusion filter:
      o 'org.eclipse.update.*'

      So, as you can see the both exclude patterns are workable, but 2-nd one doesn't work independently of the element order.

        Activity

        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open In Progress In Progress
        51d 4h 29m 1 John Casey 15/Aug/07 17:12
        In Progress In Progress Closed Closed
        1h 15m 1 John Casey 15/Aug/07 18:27
        Mark Thomas made changes -
        Workflow jira [ 12955092 ] Default workflow, editable Closed status [ 12991268 ]
        Mark Thomas made changes -
        Project Import Sun Apr 05 22:33:31 UTC 2015 [ 1428273211083 ]
        Mark Thomas made changes -
        Patch Submitted Yes [ 10763 ]
        Flags Patch [ 10430 ]
        Mark Thomas made changes -
        Workflow jira [ 12717175 ] Default workflow, editable Closed status [ 12760871 ]
        Mark Thomas made changes -
        Project Import Sun Apr 05 09:09:00 UTC 2015 [ 1428224940639 ]
        John Casey made changes -
        Fix Version/s 2.2-beta-3 [ 13507 ]
        Fix Version/s 2.2-beta-2 [ 14027 ]
        John Casey made changes -
        Status In Progress [ 3 ] Closed [ 6 ]
        Resolution Fixed [ 1 ]
        John Casey added a comment -

        Applied, and added unit tests to verify that this is fixed. Thanks!

        John Casey made changes -
        Status Open [ 1 ] In Progress [ 3 ]
        John Casey made changes -
        Assignee John Casey [ jdcasey ]
        John Casey made changes -
        Patch Submitted [Yes]
        John Casey made changes -
        Fix Version/s 2.2-beta-2 [ 13507 ]
        Walt Wang made changes -
        Field Original Value New Value
        Attachment MASSEMBLY-223.patch [ 28355 ]
        Walt Wang added a comment -

        The problem seems caused by maven-common-artifact-filters. It returns from a loop to iterate on excludes. So only first exclude take effect

        Walt Wang added a comment -

        The problem seems caused by maven-common-artifact-filters. It returns from a loop to iterate on excludes. So only first exclude take effect. MASSEMBLY-223.patch attached.

        Eugene Voytitsky created issue -

          People

          • Assignee:
            John Casey
            Reporter:
            Eugene Voytitsky
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development