Details

    • Type: Sub-task Sub-task
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 0.21.0
    • Component/s: jobtracker
    • Labels:
      None
    • Release Note:
      TestNodeRefresh timed out as the code to do with node refresh got removed. This patch removes the testcase.

      Activity

      Transition Time In Source Status Execution Times Last Executer Last Execution Date
      Open Open Resolved Resolved
      6d 2h 26m 1 Devaraj Das 07/Sep/09 07:07
      Resolved Resolved Closed Closed
      351d 15h 8m 1 Tom White 24/Aug/10 22:15
      Tom White made changes -
      Status Resolved [ 5 ] Closed [ 6 ]
      Amar Kamat made changes -
      Release Note TestNodeRefresh timed out as the code to do with node refresh got removed. This patch removes the testcase.
      Hudson added a comment -

      Integrated in Hadoop-Mapreduce-trunk-Commit #18 (See http://hudson.zones.apache.org/hudson/job/Hadoop-Mapreduce-trunk-Commit/18/)
      . Removes a testcase in TestNodeRefresh that doesn't make sense in the new Job recovery model. Contributed by Amar Kamat.

      Devaraj Das added a comment -

      Should have added that I also agree that the testcase which times out is no longer needed.

      Devaraj Das made changes -
      Status Open [ 1 ] Resolved [ 5 ]
      Resolution Fixed [ 1 ]
      Devaraj Das added a comment -

      I just committed this. Thanks, Amar!

      Devaraj Das made changes -
      Parent MAPREDUCE-873 [ 12433075 ]
      Issue Type Bug [ 1 ] Sub-task [ 7 ]
      Konstantin Boudnik added a comment -

      If the cause of timeouts is connected to the MAPREDUCE-873 then this JIRA has to be converted to its sub-task. Otherwise, it seems to be confusing at first.

      Konstantin Boudnik added a comment -

      So, removing the test case seems to be the only way of 'fixing' the problem?

      Amar Kamat added a comment -

      @Konstantin Yes the testcase got stuck because JobClient.startTracker() failed.

      Amar Kamat made changes -
      Attachment MAPRED-943-v1.0.patch [ 12418593 ]
      Amar Kamat added a comment -

      Attaching a patch that removed the testcase.

      Amar Kamat made changes -
      Field Original Value New Value
      Assignee Amar Kamat [ amar_kamat ]
      Amar Kamat added a comment -

      Post MAPREDUCE-873, TestNodeRefresh.testMRExcludeHostsAcrossRestarts() will no longer be required. I dont think we should invest time in debugging this.

      Amar Kamat added a comment -

      Can someone upload the log file?

      Konstantin Boudnik added a comment -

      It seems to be caused the unhandled crash in MiniMRCluster.startTaskTracker

           [exec]     [junit] 2009-08-31 11:59:24,583 INFO  mapred.TaskTracker (TaskTracker.java:initialize(567)) - TaskTracker up at: localhost/127.0.0.1:45234
           [exec]     [junit] 2009-08-31 11:59:24,583 INFO  mapred.TaskTracker (TaskTracker.java:initialize(570)) - Starting tracker tracker_host2.com:localhost/127.0.0.1:45234
           [exec]     [junit] 2009-08-31 11:59:24,584 ERROR mapred.MiniMRCluster (MiniMRCluster.java:<init>(194)) - task tracker 2 crashed
           [exec]     [junit] java.io.IOException: Call to localhost/127.0.0.1:47063 failed on local exception: java.io.EOFException
           [exec]     [junit] 	at org.apache.hadoop.ipc.Client.wrapException(Client.java:801)
           [exec]     [junit] 	at org.apache.hadoop.ipc.Client.call(Client.java:769)
      ...
           [exec]     [junit] 	at org.apache.hadoop.mapred.MiniMRCluster$TaskTrackerRunner.<init>(MiniMRCluster.java:189)
           [exec]     [junit] 	at org.apache.hadoop.mapred.MiniMRCluster.startTaskTracker(MiniMRCluster.java:675)
           [exec]     [junit] 	at org.apache.hadoop.mapred.TestNodeRefresh.testMRExcludeHostsAcrossRestarts(TestNodeRefresh.java:455)
      
      Amareshwari Sriramadasu created issue -

        People

        • Assignee:
          Amar Kamat
          Reporter:
          Amareshwari Sriramadasu
        • Votes:
          0 Vote for this issue
          Watchers:
          2 Start watching this issue

          Dates

          • Created:
            Updated:
            Resolved:

            Development