Details

    • Type: Sub-task Sub-task
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 0.21.0
    • Component/s: None
    • Labels:
      None
    1. patch-898-4.txt
      37 kB
      Amareshwari Sriramadasu
    2. patch-898-3.txt
      30 kB
      Amareshwari Sriramadasu
    3. patch-898-2.txt
      30 kB
      Amareshwari Sriramadasu
    4. patch-898-1.txt
      27 kB
      Amareshwari Sriramadasu
    5. patch-898.txt
      25 kB
      Amareshwari Sriramadasu

      Activity

      Amareshwari Sriramadasu created issue -
      Amareshwari Sriramadasu added a comment -

      Patch moves getters and setter from DistributedCache to JobContext and Job.

      Amareshwari Sriramadasu made changes -
      Field Original Value New Value
      Attachment patch-898.txt [ 12417958 ]
      Amareshwari Sriramadasu made changes -
      Status Open [ 1 ] Patch Available [ 10002 ]
      Assignee Amareshwari Sriramadasu [ amareshwari ]
      Fix Version/s 0.21.0 [ 12314045 ]
      Hadoop QA added a comment -

      -1 overall. Here are the results of testing the latest attachment
      http://issues.apache.org/jira/secure/attachment/12417958/patch-898.txt
      against trunk revision 808730.

      +1 @author. The patch does not contain any @author tags.

      +1 tests included. The patch appears to include 3 new or modified tests.

      +1 javadoc. The javadoc tool did not generate any warning messages.

      -1 javac. The applied patch generated 2230 javac compiler warnings (more than the trunk's current 2226 warnings).

      +1 findbugs. The patch does not introduce any new Findbugs warnings.

      +1 release audit. The applied patch does not increase the total number of release audit warnings.

      -1 core tests. The patch failed core unit tests.

      +1 contrib tests. The patch passed contrib unit tests.

      Test results: http://hudson.zones.apache.org/hudson/job/Mapreduce-Patch-vesta.apache.org/534/testReport/
      Findbugs warnings: http://hudson.zones.apache.org/hudson/job/Mapreduce-Patch-vesta.apache.org/534/artifact/trunk/build/test/findbugs/newPatchFindbugsWarnings.html
      Checkstyle results: http://hudson.zones.apache.org/hudson/job/Mapreduce-Patch-vesta.apache.org/534/artifact/trunk/build/test/checkstyle-errors.html
      Console output: http://hudson.zones.apache.org/hudson/job/Mapreduce-Patch-vesta.apache.org/534/console

      This message is automatically generated.

      Amareshwari Sriramadasu added a comment -

      -1 core tests. Due to MAPREDUCE-880 and MAPREDUCE-924
      -1 javac. Is because of deprecated methods in DistributedCache.

      Giridharan Kesavan made changes -
      Status Patch Available [ 10002 ] Open [ 1 ]
      Giridharan Kesavan made changes -
      Status Open [ 1 ] Patch Available [ 10002 ]
      Hadoop QA added a comment -

      -1 overall. Here are the results of testing the latest attachment
      http://issues.apache.org/jira/secure/attachment/12417958/patch-898.txt
      against trunk revision 808730.

      +1 @author. The patch does not contain any @author tags.

      +1 tests included. The patch appears to include 3 new or modified tests.

      +1 javadoc. The javadoc tool did not generate any warning messages.

      -1 javac. The applied patch generated 2230 javac compiler warnings (more than the trunk's current 2226 warnings).

      +1 findbugs. The patch does not introduce any new Findbugs warnings.

      +1 release audit. The applied patch does not increase the total number of release audit warnings.

      -1 core tests. The patch failed core unit tests.

      +1 contrib tests. The patch passed contrib unit tests.

      Test results: http://hudson.zones.apache.org/hudson/job/Mapreduce-Patch-h6.grid.sp2.yahoo.net/25/testReport/
      Findbugs warnings: http://hudson.zones.apache.org/hudson/job/Mapreduce-Patch-h6.grid.sp2.yahoo.net/25/artifact/trunk/build/test/findbugs/newPatchFindbugsWarnings.html
      Checkstyle results: http://hudson.zones.apache.org/hudson/job/Mapreduce-Patch-h6.grid.sp2.yahoo.net/25/artifact/trunk/build/test/checkstyle-errors.html
      Console output: http://hudson.zones.apache.org/hudson/job/Mapreduce-Patch-h6.grid.sp2.yahoo.net/25/console

      This message is automatically generated.

      Amareshwari Sriramadasu made changes -
      Status Patch Available [ 10002 ] Open [ 1 ]
      Amareshwari Sriramadasu added a comment -

      Moved setters specific to framework into TrackerDistributedCache. Made them package private

      Amareshwari Sriramadasu made changes -
      Attachment patch-898-1.txt [ 12418353 ]
      Amareshwari Sriramadasu made changes -
      Status Open [ 1 ] Patch Available [ 10002 ]
      Vinod Kumar Vavilapalli added a comment -

      Had a quick look at the patch. Few comments:

      • This patch is not the cause, but there are many incorrect references to DistributedCacheManager in javadoc. Would be good if these are changed to TrackerDistributedCacheManager
      • checkURIs() is the only API left in DistributedCache. If this can be moved somewhere too, perhaps to streaming which uses it, then the class DistributedCache itself can be deprecated.
      • There are some unsymmetric APIs. For e.g. getArchiveClassPaths() return Path objects while addCacheArchive() adds a URI. Same is the case with a missing setArchivesToClassPath(). Can be done in a follow up issue though.
      Amareshwari Sriramadasu made changes -
      Status Patch Available [ 10002 ] Open [ 1 ]
      Amareshwari Sriramadasu added a comment -

      Fixed the javadoc that Vinod pointed.

      checkURIs() is the only API left in DistributedCache. If this can be moved somewhere too, perhaps to streaming which uses it, then the class DistributedCache itself can be deprecated.

      Deprecated DistributedCache class itself. If users were using checkURIs() they will get a warning now.

      Amareshwari Sriramadasu made changes -
      Attachment patch-898-2.txt [ 12418362 ]
      Amareshwari Sriramadasu made changes -
      Status Open [ 1 ] Patch Available [ 10002 ]
      Hadoop QA added a comment -

      -1 overall. Here are the results of testing the latest attachment
      http://issues.apache.org/jira/secure/attachment/12418353/patch-898-1.txt
      against trunk revision 810330.

      +1 @author. The patch does not contain any @author tags.

      +1 tests included. The patch appears to include 3 new or modified tests.

      -1 javadoc. The javadoc tool appears to have generated 1 warning messages.

      -1 javac. The applied patch generated 2230 javac compiler warnings (more than the trunk's current 2226 warnings).

      +1 findbugs. The patch does not introduce any new Findbugs warnings.

      +1 release audit. The applied patch does not increase the total number of release audit warnings.

      -1 core tests. The patch failed core unit tests.

      +1 contrib tests. The patch passed contrib unit tests.

      Test results: http://hudson.zones.apache.org/hudson/job/Mapreduce-Patch-h3.grid.sp2.yahoo.net/2/testReport/
      Findbugs warnings: http://hudson.zones.apache.org/hudson/job/Mapreduce-Patch-h3.grid.sp2.yahoo.net/2/artifact/trunk/build/test/findbugs/newPatchFindbugsWarnings.html
      Checkstyle results: http://hudson.zones.apache.org/hudson/job/Mapreduce-Patch-h3.grid.sp2.yahoo.net/2/artifact/trunk/build/test/checkstyle-errors.html
      Console output: http://hudson.zones.apache.org/hudson/job/Mapreduce-Patch-h3.grid.sp2.yahoo.net/2/console

      This message is automatically generated.

      Hadoop QA added a comment -

      -1 overall. Here are the results of testing the latest attachment
      http://issues.apache.org/jira/secure/attachment/12418362/patch-898-2.txt
      against trunk revision 810330.

      +1 @author. The patch does not contain any @author tags.

      +1 tests included. The patch appears to include 3 new or modified tests.

      -1 javadoc. The javadoc tool appears to have generated 1 warning messages.

      -1 javac. The applied patch generated 2236 javac compiler warnings (more than the trunk's current 2226 warnings).

      +1 findbugs. The patch does not introduce any new Findbugs warnings.

      +1 release audit. The applied patch does not increase the total number of release audit warnings.

      -1 core tests. The patch failed core unit tests.

      +1 contrib tests. The patch passed contrib unit tests.

      Test results: http://hudson.zones.apache.org/hudson/job/Mapreduce-Patch-h3.grid.sp2.yahoo.net/3/testReport/
      Findbugs warnings: http://hudson.zones.apache.org/hudson/job/Mapreduce-Patch-h3.grid.sp2.yahoo.net/3/artifact/trunk/build/test/findbugs/newPatchFindbugsWarnings.html
      Checkstyle results: http://hudson.zones.apache.org/hudson/job/Mapreduce-Patch-h3.grid.sp2.yahoo.net/3/artifact/trunk/build/test/checkstyle-errors.html
      Console output: http://hudson.zones.apache.org/hudson/job/Mapreduce-Patch-h3.grid.sp2.yahoo.net/3/console

      This message is automatically generated.

      Amareshwari Sriramadasu made changes -
      Status Patch Available [ 10002 ] Open [ 1 ]
      Amareshwari Sriramadasu added a comment -

      Fixed javadoc warning

      Amareshwari Sriramadasu made changes -
      Attachment patch-898-3.txt [ 12418467 ]
      Amareshwari Sriramadasu made changes -
      Status Open [ 1 ] Patch Available [ 10002 ]
      Devaraj Das added a comment -

      Some comments:
      1) Move DistributedCache.checkURIs to TrackerDistributedCacheManager
      2) Update the tutorial (forrest doc) with the new API related changes

      Devaraj Das made changes -
      Status Patch Available [ 10002 ] Open [ 1 ]
      Hadoop QA added a comment -

      -1 overall. Here are the results of testing the latest attachment
      http://issues.apache.org/jira/secure/attachment/12418467/patch-898-3.txt
      against trunk revision 810505.

      +1 @author. The patch does not contain any @author tags.

      +1 tests included. The patch appears to include 3 new or modified tests.

      +1 javadoc. The javadoc tool did not generate any warning messages.

      -1 javac. The applied patch generated 2236 javac compiler warnings (more than the trunk's current 2226 warnings).

      +1 findbugs. The patch does not introduce any new Findbugs warnings.

      +1 release audit. The applied patch does not increase the total number of release audit warnings.

      +1 core tests. The patch passed core unit tests.

      +1 contrib tests. The patch passed contrib unit tests.

      Test results: http://hudson.zones.apache.org/hudson/job/Mapreduce-Patch-h3.grid.sp2.yahoo.net/4/testReport/
      Findbugs warnings: http://hudson.zones.apache.org/hudson/job/Mapreduce-Patch-h3.grid.sp2.yahoo.net/4/artifact/trunk/build/test/findbugs/newPatchFindbugsWarnings.html
      Checkstyle results: http://hudson.zones.apache.org/hudson/job/Mapreduce-Patch-h3.grid.sp2.yahoo.net/4/artifact/trunk/build/test/checkstyle-errors.html
      Console output: http://hudson.zones.apache.org/hudson/job/Mapreduce-Patch-h3.grid.sp2.yahoo.net/4/console

      This message is automatically generated.

      Amareshwari Sriramadasu added a comment -

      Patch with review comments incorporated.
      I ran ant docs manually and verified document in mapred tutorial is fine.

      Amareshwari Sriramadasu made changes -
      Attachment patch-898-4.txt [ 12418580 ]
      Amareshwari Sriramadasu made changes -
      Status Open [ 1 ] Patch Available [ 10002 ]
      Vinod Kumar Vavilapalli added a comment -

      There are some unsymmetric APIs. For e.g. getArchiveClassPaths() return Path objects while addCacheArchive() adds a URI. Same is the case with a missing setArchivesToClassPath(). Can be done in a follow up issue though.

      Created MAPREDUCE-950

      Hadoop QA added a comment -

      -1 overall. Here are the results of testing the latest attachment
      http://issues.apache.org/jira/secure/attachment/12418580/patch-898-4.txt
      against trunk revision 811134.

      +1 @author. The patch does not contain any @author tags.

      +1 tests included. The patch appears to include 3 new or modified tests.

      +1 javadoc. The javadoc tool did not generate any warning messages.

      -1 javac. The applied patch generated 2236 javac compiler warnings (more than the trunk's current 2226 warnings).

      +1 findbugs. The patch does not introduce any new Findbugs warnings.

      +1 release audit. The applied patch does not increase the total number of release audit warnings.

      -1 core tests. The patch failed core unit tests.

      +1 contrib tests. The patch passed contrib unit tests.

      Test results: http://hudson.zones.apache.org/hudson/job/Mapreduce-Patch-h6.grid.sp2.yahoo.net/37/testReport/
      Findbugs warnings: http://hudson.zones.apache.org/hudson/job/Mapreduce-Patch-h6.grid.sp2.yahoo.net/37/artifact/trunk/build/test/findbugs/newPatchFindbugsWarnings.html
      Checkstyle results: http://hudson.zones.apache.org/hudson/job/Mapreduce-Patch-h6.grid.sp2.yahoo.net/37/artifact/trunk/build/test/checkstyle-errors.html
      Console output: http://hudson.zones.apache.org/hudson/job/Mapreduce-Patch-h6.grid.sp2.yahoo.net/37/console

      This message is automatically generated.

      Amareshwari Sriramadasu added a comment -

      -1 core tests. Is due to MAPREDUCE-943.
      -1 javac. Is because of deprecation warnings.

      Vinod Kumar Vavilapalli added a comment -

      The changes look fine to me. +1 from my side.

      Devaraj Das added a comment -

      I just committed this. Thanks, Amareshwari!

      Devaraj Das made changes -
      Status Patch Available [ 10002 ] Resolved [ 5 ]
      Resolution Fixed [ 1 ]
      Hudson added a comment -

      Integrated in Hadoop-Mapreduce-trunk-Commit #19 (See http://hudson.zones.apache.org/hudson/job/Hadoop-Mapreduce-trunk-Commit/19/)
      . Changes DistributedCache to use the new API. Contributed by Amareshwari Sriramadasu.

      Philip Zeyliger added a comment -

      Amareshwari,

      Sorry I slept through the first pass of this. A few questions about the new API:

      • Do most of the getters that return arrays return null or an empty array if there's nothing there? This would be good to document in JavaDoc, since it's always confusing.
      • Are the get*Timestamps functions public because they're used within the framework? It might be great for them to return int[] instead of String, and at least document what a "timestamp" indicates?

      – Philip

      Amareshwari Sriramadasu added a comment -

      * Do most of the getters that return arrays return null or an empty array if there's nothing there? This would be good to document in JavaDoc, since it's always confusing.

      bq * Are the get*Timestamps functions public because they're used within the framework? It might be great for them to return int[] instead of String, and at least document what a "timestamp" indicates?

      Please raise jira the suggested documentation changes

      Philip Zeyliger added a comment -

      Fair enough. Opened up MAPREDUCE-990. Thanks. – Philip

      Tom White made changes -
      Status Resolved [ 5 ] Closed [ 6 ]
      Transition Time In Source Status Execution Times Last Executer Last Execution Date
      Patch Available Patch Available Open Open
      6d 32m 5 Devaraj Das 03/Sep/09 06:58
      Open Open Patch Available Patch Available
      7d 21h 15m 6 Amareshwari Sriramadasu 04/Sep/09 05:11
      Patch Available Patch Available Resolved Resolved
      3d 6h 59m 1 Devaraj Das 07/Sep/09 12:10
      Resolved Resolved Closed Closed
      351d 10h 5m 1 Tom White 24/Aug/10 22:15

        People

        • Assignee:
          Amareshwari Sriramadasu
          Reporter:
          Amareshwari Sriramadasu
        • Votes:
          0 Vote for this issue
          Watchers:
          2 Start watching this issue

          Dates

          • Created:
            Updated:
            Resolved:

            Development