In our testing framework, we use SleepJobs for test scheduling and to check different resource types are assigned properly to containers. Sometimes we start multiple jobs in parallel, and if one fails, we have to track which one was that. It is not too hard to find out that information, but would have been much more convenient if it was written in the name of the job.
Proposal: additional parameter to SleepJob, so that its name can be changed from default "Sleep job." to something like "Sleep job - additional info".