Details

    • Type: Improvement
    • Status: Resolved
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 2.8.0
    • Fix Version/s: 3.0.0-alpha4
    • Component/s: client
    • Labels:
    • Hadoop Flags:
      Reviewed

      Description

      The AuditLogger and TestAuditLogger classes appear to be dead code. I can't find anything that uses or references AuditLogger. No one has touched the code 2011. I think it's safe to remove.

      1. MAPREDUCE-6883.001.patch
        12 kB
        Vrushali C
      2. MAPREDUCE-6883.002.patch
        12 kB
        Vrushali C
      3. MAPREDUCE-6883.003.patch
        14 kB
        Chris Douglas

        Activity

        vrushalic Vrushali C added a comment -

        Attaching patch v1.

        hadoopqa Hadoop QA added a comment -
        -1 overall



        Vote Subsystem Runtime Comment
        0 reexec 0m 0s Docker mode activated.
        -1 patch 0m 5s MAPREDUCE-6883 does not apply to trunk. Rebase required? Wrong Branch? See https://wiki.apache.org/hadoop/HowToContribute for help.



        Subsystem Report/Notes
        JIRA Patch URL https://issues.apache.org/jira/secure/attachment/12866306/MAPREDUCE-6883.001.patch
        JIRA Issue MAPREDUCE-6883
        Console output https://builds.apache.org/job/PreCommit-MAPREDUCE-Build/6972/console
        Powered by Apache Yetus 0.3.0 http://yetus.apache.org

        This message was automatically generated.

        vrushalic Vrushali C added a comment - - edited

        Attaching rebased patch 002

        hadoopqa Hadoop QA added a comment -
        -1 overall



        Vote Subsystem Runtime Comment
        0 reexec 0m 15s Docker mode activated.
        +1 @author 0m 0s The patch does not contain any @author tags.
        +1 test4tests 0m 0s The patch appears to include 1 new or modified test files.
        0 mvndep 0m 45s Maven dependency ordering for branch
        +1 mvninstall 13m 7s trunk passed
        +1 compile 1m 33s trunk passed
        +1 checkstyle 0m 28s trunk passed
        +1 mvnsite 0m 54s trunk passed
        +1 mvneclipse 0m 35s trunk passed
        +1 findbugs 1m 9s trunk passed
        +1 javadoc 0m 35s trunk passed
        0 mvndep 0m 8s Maven dependency ordering for patch
        +1 mvninstall 0m 44s the patch passed
        +1 compile 1m 29s the patch passed
        +1 javac 1m 29s the patch passed
        +1 checkstyle 0m 24s the patch passed
        +1 mvnsite 0m 48s the patch passed
        +1 mvneclipse 0m 29s the patch passed
        +1 whitespace 0m 0s The patch has no whitespace issues.
        +1 findbugs 1m 18s the patch passed
        +1 javadoc 0m 28s the patch passed
        +1 unit 2m 42s hadoop-mapreduce-client-core in the patch passed.
        -1 unit 115m 32s hadoop-mapreduce-client-jobclient in the patch failed.
        +1 asflicense 0m 28s The patch does not generate ASF License warnings.
        144m 41s



        Reason Tests
        Failed junit tests hadoop.mapred.TestClusterMapReduceTestCase
        Timed out junit tests org.apache.hadoop.mapred.TestMRIntermediateDataEncryption



        Subsystem Report/Notes
        Docker Image:yetus/hadoop:14b5c93
        JIRA Patch URL https://issues.apache.org/jira/secure/attachment/12866323/MAPREDUCE-6883.002.patch
        JIRA Issue MAPREDUCE-6883
        Optional Tests asflicense compile javac javadoc mvninstall mvnsite unit findbugs checkstyle
        uname Linux d2b5674e6f64 4.4.0-43-generic #63-Ubuntu SMP Wed Oct 12 13:48:03 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux
        Build tool maven
        Personality /testptch/hadoop/patchprocess/precommit/personality/provided.sh
        git revision trunk / 81092b1
        Default Java 1.8.0_121
        findbugs v3.1.0-RC1
        unit https://builds.apache.org/job/PreCommit-MAPREDUCE-Build/6973/artifact/patchprocess/patch-unit-hadoop-mapreduce-project_hadoop-mapreduce-client_hadoop-mapreduce-client-jobclient.txt
        unit test logs https://builds.apache.org/job/PreCommit-MAPREDUCE-Build/6973/artifact/patchprocess/patch-unit-hadoop-mapreduce-project_hadoop-mapreduce-client_hadoop-mapreduce-client-jobclient.txt
        Test Results https://builds.apache.org/job/PreCommit-MAPREDUCE-Build/6973/testReport/
        modules C: hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-core hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-jobclient U: hadoop-mapreduce-project/hadoop-mapreduce-client
        Console output https://builds.apache.org/job/PreCommit-MAPREDUCE-Build/6973/console
        Powered by Apache Yetus 0.3.0 http://yetus.apache.org

        This message was automatically generated.

        vrushalic Vrushali C added a comment -

        I believe the unit test failure is unrelated.

        haibochen Haibo Chen added a comment - - edited

        I could not reproduce the test failure locally either. Looks like AuditLogger is also referenced in hadoop-common/src/main/log4j.properties,
        > log4j.logger.org.apache.hadoop.mapred.AuditLogger=$

        {mapred.audit.logger}

        > log4j.additivity.org.apache.hadoop.mapred.AuditLogger=false
        can you update the patch to remove those, Vrushali C?

        chris.douglas Chris Douglas added a comment -

        +1

        I committed this. Thanks Vrushali


          People

          • Assignee:
            vrushalic Vrushali C
            Reporter:
            templedf Daniel Templeton
          • Votes:
            0 Vote for this issue
            Watchers:
            5 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development