Details

    • Type: Bug
    • Status: Resolved
    • Priority: Blocker
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 2.8.0, 3.0.0-alpha2
    • Component/s: webapps
    • Labels:
      None

      Description

      YARN web UI always shows progress bars at 100% (see screenshot, progress of the reduce step is roughly at 40.00%). I opened the HTML source code to check (also see screenshot), and it seems the problem is that it uses "%%" ,which cannot be recognized. This is due to the output of StringUtils.format() contains '%', while in *Block.java use join() add an extra '%'.

      1. MAPREDUCE-6816.01.patch
        5 kB
        Shen Yinjie
      2. MAPREDUCE-6816.02.patch
        2 kB
        Shen Yinjie
      3. MAPREDUCE-6816.03.patch
        3 kB
        Shen Yinjie
      4. MAPREDUCE-6816.patch
        5 kB
        Shen Yinjie
      5. pre.png
        55 kB
        Shen Yinjie

        Issue Links

          Activity

          shenyinjie Shen Yinjie added a comment -

          fix for review

          hadoopqa Hadoop QA added a comment -
          -1 overall



          Vote Subsystem Runtime Comment
          0 reexec 0m 16s Docker mode activated.
          +1 @author 0m 0s The patch does not contain any @author tags.
          -1 test4tests 0m 0s The patch doesn't appear to include any new or modified tests. Please justify why no new tests are needed for this patch. Also please list what manual steps were performed to verify this patch.
          +1 mvninstall 7m 10s trunk passed
          +1 compile 0m 26s trunk passed
          +1 checkstyle 0m 17s trunk passed
          +1 mvnsite 0m 33s trunk passed
          +1 mvneclipse 0m 17s trunk passed
          +1 findbugs 0m 44s trunk passed
          +1 javadoc 0m 16s trunk passed
          +1 mvninstall 0m 25s the patch passed
          +1 compile 0m 22s the patch passed
          +1 javac 0m 22s the patch passed
          -1 checkstyle 0m 14s hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-app: The patch generated 7 new + 35 unchanged - 8 fixed = 42 total (was 43)
          +1 mvnsite 0m 29s the patch passed
          +1 mvneclipse 0m 14s the patch passed
          +1 whitespace 0m 0s The patch has no whitespace issues.
          +1 findbugs 0m 46s the patch passed
          +1 javadoc 0m 15s the patch passed
          +1 unit 9m 11s hadoop-mapreduce-client-app in the patch passed.
          +1 asflicense 0m 15s The patch does not generate ASF License warnings.
          22m 52s



          Subsystem Report/Notes
          Docker Image:yetus/hadoop:a9ad5d6
          JIRA Patch URL https://issues.apache.org/jira/secure/attachment/12841596/MAPREDUCE-6816.01.patch
          JIRA Issue MAPREDUCE-6816
          Optional Tests asflicense compile javac javadoc mvninstall mvnsite unit findbugs checkstyle
          uname Linux 200ef28430b0 3.13.0-95-generic #142-Ubuntu SMP Fri Aug 12 17:00:09 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux
          Build tool maven
          Personality /testptch/hadoop/patchprocess/precommit/personality/provided.sh
          git revision trunk / f885160
          Default Java 1.8.0_111
          findbugs v3.0.0
          checkstyle https://builds.apache.org/job/PreCommit-MAPREDUCE-Build/6827/artifact/patchprocess/diff-checkstyle-hadoop-mapreduce-project_hadoop-mapreduce-client_hadoop-mapreduce-client-app.txt
          Test Results https://builds.apache.org/job/PreCommit-MAPREDUCE-Build/6827/testReport/
          modules C: hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-app U: hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-app
          Console output https://builds.apache.org/job/PreCommit-MAPREDUCE-Build/6827/console
          Powered by Apache Yetus 0.3.0 http://yetus.apache.org

          This message was automatically generated.

          shenyinjie Shen Yinjie added a comment -

          Akira Ajisaka ,Xuan Gong . I found this bug in hadoop-3.0+ .and need your advice and review

          ajisakaa Akira Ajisaka added a comment -

          Thanks Shen Yinjie for reporting this! This issue was broken by YARN-2123 and it is a regression from Hadoop 2.7. Raising the priority to blocker.

          ajisakaa Akira Ajisaka added a comment -

          Thanks Shen Yinjie for providing a patch! YARN-2123 replaced StringHelper.percent(arg) with StringUtils.formatPercent(arg, 2), which is the cause of the regression. The former does not output '%' but the latter outputs '%', so we should have used StringUtils.format("%.2f", arg * 100) instead. Therefore, would you replace StringUtils.formatPercent(arg, 2) with StringUtils.format("%.2f", arg * 100) instead of the removal of joining '%'?
          Sorry for my mistake in YARN-2123.

          shenyinjie Shen Yinjie added a comment -

          Yep attach new patch soon!

          shenyinjie Shen Yinjie added a comment -

          patch tested

          hadoopqa Hadoop QA added a comment -
          -1 overall



          Vote Subsystem Runtime Comment
          0 reexec 0m 19s Docker mode activated.
          +1 @author 0m 0s The patch does not contain any @author tags.
          -1 test4tests 0m 0s The patch doesn't appear to include any new or modified tests. Please justify why no new tests are needed for this patch. Also please list what manual steps were performed to verify this patch.
          +1 mvninstall 8m 6s trunk passed
          +1 compile 0m 28s trunk passed
          +1 checkstyle 0m 17s trunk passed
          +1 mvnsite 0m 30s trunk passed
          +1 mvneclipse 0m 17s trunk passed
          +1 findbugs 0m 37s trunk passed
          +1 javadoc 0m 15s trunk passed
          +1 mvninstall 0m 23s the patch passed
          +1 compile 0m 20s the patch passed
          +1 javac 0m 20s the patch passed
          +1 checkstyle 0m 14s the patch passed
          +1 mvnsite 0m 27s the patch passed
          +1 mvneclipse 0m 14s the patch passed
          +1 whitespace 0m 0s The patch has no whitespace issues.
          +1 findbugs 0m 52s the patch passed
          +1 javadoc 0m 16s the patch passed
          +1 unit 9m 29s hadoop-mapreduce-client-app in the patch passed.
          +1 asflicense 0m 16s The patch does not generate ASF License warnings.
          24m 0s



          Subsystem Report/Notes
          Docker Image:yetus/hadoop:a9ad5d6
          JIRA Patch URL https://issues.apache.org/jira/secure/attachment/12841901/MAPREDUCE-6816.02.patch
          JIRA Issue MAPREDUCE-6816
          Optional Tests asflicense compile javac javadoc mvninstall mvnsite unit findbugs checkstyle
          uname Linux c099fb339bb6 3.13.0-95-generic #142-Ubuntu SMP Fri Aug 12 17:00:09 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux
          Build tool maven
          Personality /testptch/hadoop/patchprocess/precommit/personality/provided.sh
          git revision trunk / 7b988e8
          Default Java 1.8.0_111
          findbugs v3.0.0
          Test Results https://builds.apache.org/job/PreCommit-MAPREDUCE-Build/6832/testReport/
          modules C: hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-app U: hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-app
          Console output https://builds.apache.org/job/PreCommit-MAPREDUCE-Build/6832/console
          Powered by Apache Yetus 0.3.0 http://yetus.apache.org

          This message was automatically generated.

          ajisakaa Akira Ajisaka added a comment -

          Thanks Shen Yinjie for the quick update. Would you fix TaskPage.java as well?

          TaskPage.java
                  String progress = StringUtils.formatPercent(ta.getProgress() / 100, 2);
          

          should be

                  String progress = StringUtils.format("%.2f", ta.getProgress());
          

          I'm +1 if that is addressed.

          shenyinjie Shen Yinjie added a comment - - edited

          fix TaskPage.java

          hadoopqa Hadoop QA added a comment -
          -1 overall



          Vote Subsystem Runtime Comment
          0 reexec 0m 20s Docker mode activated.
          +1 @author 0m 0s The patch does not contain any @author tags.
          -1 test4tests 0m 0s The patch doesn't appear to include any new or modified tests. Please justify why no new tests are needed for this patch. Also please list what manual steps were performed to verify this patch.
          +1 mvninstall 8m 55s trunk passed
          +1 compile 0m 27s trunk passed
          +1 checkstyle 0m 20s trunk passed
          +1 mvnsite 0m 33s trunk passed
          +1 mvneclipse 0m 21s trunk passed
          +1 findbugs 0m 45s trunk passed
          +1 javadoc 0m 22s trunk passed
          +1 mvninstall 0m 29s the patch passed
          +1 compile 0m 25s the patch passed
          +1 javac 0m 25s the patch passed
          +1 checkstyle 0m 16s the patch passed
          +1 mvnsite 0m 33s the patch passed
          +1 mvneclipse 0m 16s the patch passed
          +1 whitespace 0m 0s The patch has no whitespace issues.
          +1 findbugs 0m 51s the patch passed
          +1 javadoc 0m 16s the patch passed
          +1 unit 9m 48s hadoop-mapreduce-client-app in the patch passed.
          +1 asflicense 0m 15s The patch does not generate ASF License warnings.
          26m 1s



          Subsystem Report/Notes
          Docker Image:yetus/hadoop:a9ad5d6
          JIRA Patch URL https://issues.apache.org/jira/secure/attachment/12841922/MAPREDUCE-6816.03.patch
          JIRA Issue MAPREDUCE-6816
          Optional Tests asflicense compile javac javadoc mvninstall mvnsite unit findbugs checkstyle
          uname Linux 422a88bbb4a0 3.13.0-95-generic #142-Ubuntu SMP Fri Aug 12 17:00:09 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux
          Build tool maven
          Personality /testptch/hadoop/patchprocess/precommit/personality/provided.sh
          git revision trunk / 7b988e8
          Default Java 1.8.0_111
          findbugs v3.0.0
          Test Results https://builds.apache.org/job/PreCommit-MAPREDUCE-Build/6833/testReport/
          modules C: hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-app U: hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-app
          Console output https://builds.apache.org/job/PreCommit-MAPREDUCE-Build/6833/console
          Powered by Apache Yetus 0.3.0 http://yetus.apache.org

          This message was automatically generated.

          ajisakaa Akira Ajisaka added a comment -

          +1, I verified the Web UI is fixed on trunk.

          ajisakaa Akira Ajisaka added a comment -

          Committed this to trunk. Thanks Shen Yinjie for the contribution! I really appreciate that.

          hudson Hudson added a comment -

          SUCCESS: Integrated in Jenkins build Hadoop-trunk-Commit #10955 (See https://builds.apache.org/job/Hadoop-trunk-Commit/10955/)
          MAPREDUCE-6816. Progress bars in Web UI always at 100%. Contributed by (aajisaka: rev da4ecc9f8223ac82bff8483594fb29be2f8d4d34)

          • (edit) hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-app/src/main/java/org/apache/hadoop/mapreduce/v2/app/webapp/TaskPage.java
          • (edit) hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-app/src/main/java/org/apache/hadoop/mapreduce/v2/app/webapp/TasksBlock.java
          • (edit) hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-app/src/main/java/org/apache/hadoop/mapreduce/v2/app/webapp/dao/JobInfo.java

            People

            • Assignee:
              shenyinjie Shen Yinjie
              Reporter:
              shenyinjie Shen Yinjie
            • Votes:
              0 Vote for this issue
              Watchers:
              6 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development