Details

    • Type: Bug
    • Status: Resolved
    • Priority: Trivial
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 2.9.0, 3.0.0-alpha2
    • Component/s: None
    • Labels:
    • Hadoop Flags:
      Reviewed

      Description

      I am conducting research on log related bugs. I tried to make a tool to fix repetitive yet simple patterns of bugs that are related to logs. Typos in log messages are one of the reoccurring bugs. Therefore, I made a tool find typos in log statements. During my experiments, I managed to find the following typos in Hadoop MapReduce:

      In file /hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-app/src/main/java/org/apache/hadoop/mapred/TaskAttemptListenerImpl.java, LOG.info("Done acknowledgement from " + taskAttemptID.toString()),
      acknowledgement should be acknowledgment

      In file /hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-app/src/main/java/org/apache/hadoop/mapreduce/jobhistory/JobHistoryEventHandler.java, LOG.info("Exception while cancelling delayed flush timer. "+ "Likely caused by a failed flush " + e.getMessage()),
      cancelling should be canceling

      In file /hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-core/src/main/java/org/apache/hadoop/mapred/Task.java, LOG.info("Runnning cleanup for the task"),
      Runnning should be Running

      In file /hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-shuffle/src/main/java/org/apache/hadoop/mapred/ShuffleHandler.java, LOG.info("Storing state DB schedma version info " + getCurrentVersion()),
      schedma should be schema

        Activity

        Naganarasimha Naganarasimha G R added a comment -

        Mehran Hassani,
        Thanks for raising these issues, thought not critical but definitely makes sense in fixing them.
        Wondering whether this tool of yours can be integrated in the jenkins build process, so wanted to know whether your tool works on the code or the log file ?

        MehranHassani Mehran Hassani added a comment -

        Our tool is a static code analysis tool so it works on source code and it can be built into Jenkins. We also detect other bug patterns in logs, such as wrong log level, missing logs in exception handling block and others. We will report those bugs as well if you are interested we can provide more detailed information.

        busbey Sean Busbey added a comment -

        is the static analysis tool available for us to use directly? what license is it under?

        MehranHassani Mehran Hassani added a comment -

        We will release it as open source soon.

        hadoopqa Hadoop QA added a comment -
        -1 overall



        Vote Subsystem Runtime Comment
        0 reexec 0m 25s Docker mode activated.
        +1 @author 0m 0s The patch does not contain any @author tags.
        -1 test4tests 0m 0s The patch doesn't appear to include any new or modified tests. Please justify why no new tests are needed for this patch. Also please list what manual steps were performed to verify this patch.
        0 mvndep 0m 46s Maven dependency ordering for branch
        +1 mvninstall 7m 3s trunk passed
        +1 compile 1m 35s trunk passed
        +1 checkstyle 0m 33s trunk passed
        +1 mvnsite 1m 15s trunk passed
        +1 mvneclipse 0m 43s trunk passed
        +1 findbugs 1m 43s trunk passed
        +1 javadoc 0m 51s trunk passed
        0 mvndep 0m 8s Maven dependency ordering for patch
        +1 mvninstall 0m 57s the patch passed
        +1 compile 1m 31s the patch passed
        +1 javac 1m 31s the patch passed
        +1 checkstyle 0m 32s the patch passed
        +1 mvnsite 1m 8s the patch passed
        +1 mvneclipse 0m 34s the patch passed
        +1 whitespace 0m 0s The patch has no whitespace issues.
        +1 findbugs 2m 0s the patch passed
        +1 javadoc 0m 43s the patch passed
        +1 unit 2m 5s hadoop-mapreduce-client-core in the patch passed.
        +1 unit 0m 19s hadoop-mapreduce-client-shuffle in the patch passed.
        +1 unit 8m 47s hadoop-mapreduce-client-app in the patch passed.
        +1 asflicense 0m 16s The patch does not generate ASF License warnings.
        34m 45s



        Subsystem Report/Notes
        Docker Image:yetus/hadoop:9560f25
        JIRA Patch URL https://issues.apache.org/jira/secure/attachment/12828779/MAPREDUCE-6777.001.patch
        JIRA Issue MAPREDUCE-6777
        Optional Tests asflicense compile javac javadoc mvninstall mvnsite unit findbugs checkstyle
        uname Linux 4b2f789954a7 3.13.0-36-lowlatency #63-Ubuntu SMP PREEMPT Wed Sep 3 21:56:12 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
        Build tool maven
        Personality /testptch/hadoop/patchprocess/precommit/personality/provided.sh
        git revision trunk / ec3ea18
        Default Java 1.8.0_101
        findbugs v3.0.0
        Test Results https://builds.apache.org/job/PreCommit-MAPREDUCE-Build/6721/testReport/
        modules C: hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-core hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-shuffle hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-app U: hadoop-mapreduce-project/hadoop-mapreduce-client
        Console output https://builds.apache.org/job/PreCommit-MAPREDUCE-Build/6721/console
        Powered by Apache Yetus 0.3.0 http://yetus.apache.org

        This message was automatically generated.

        Naganarasimha Naganarasimha G R added a comment -

        Have added your name to the contributor list and assigned the jira to you Mehran Hassani,
        acknowledgement => acknowledgment & cancelling =>canceling seems to be not completely necessary, but any anyway patch seems to be fine and will commit it shortly

        Naganarasimha Naganarasimha G R added a comment -

        Thanks for the contribution Mehran Hassani

        hudson Hudson added a comment -

        SUCCESS: Integrated in Jenkins build Hadoop-trunk-Commit #10454 (See https://builds.apache.org/job/Hadoop-trunk-Commit/10454/)
        MAPREDUCE-6777. Typos in 4 log messages. Contributed by Mehran Hassani (naganarasimha_gr: rev 7d21c280a82b2f02675bf0048f0e965d99a05ae7)

        • (edit) hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-app/src/main/java/org/apache/hadoop/mapreduce/jobhistory/JobHistoryEventHandler.java
        • (edit) hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-core/src/main/java/org/apache/hadoop/mapred/Task.java
        • (edit) hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-shuffle/src/main/java/org/apache/hadoop/mapred/ShuffleHandler.java
        • (edit) hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-app/src/main/java/org/apache/hadoop/mapred/TaskAttemptListenerImpl.java

          People

          • Assignee:
            MehranHassani Mehran Hassani
            Reporter:
            MehranHassani Mehran Hassani
          • Votes:
            0 Vote for this issue
            Watchers:
            7 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development