Uploaded image for project: 'Hadoop Map/Reduce'
  1. Hadoop Map/Reduce
  2. MAPREDUCE-6525

Fix test failure of TestMiniMRClientCluster.testRestart

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 3.0.0-alpha1
    • Component/s: test
    • Labels:
      None
    • Hadoop Flags:
      Reviewed

      Description

      MiniMRYarnClusterAdapter#restart creates new MiniMRYarnCluster with configuration of existing MiniMRYarnCluster but the address of HistoryServer is properly set.

        Issue Links

          Activity

          iwasakims Masatake Iwasaki added a comment -
          Running org.apache.hadoop.mapred.TestMiniMRClientCluster
          Tests run: 2, Failures: 1, Errors: 0, Skipped: 0, Time elapsed: 71.73 sec <<< FAILURE! - in org.apache.hadoop.mapred.TestMiniMRClientCluster
          testRestart(org.apache.hadoop.mapred.TestMiniMRClientCluster)  Time elapsed: 28.472 sec  <<< FAILURE!
          org.junit.ComparisonFailure: Address before restart: centos7:0 is different from new address: localhost:37880 expected:<[centos7:]0> but was:<[localhost:3788]0>
          	at org.junit.Assert.assertEquals(Assert.java:115)
          	at org.apache.hadoop.mapred.TestMiniMRClientCluster.testRestart(TestMiniMRClientCluster.java:146)
          
          iwasakims Masatake Iwasaki added a comment -

          MiniMRYarnClusterAdapter#restart creates new MiniMRYarnCluster with configuration of existing MiniMRYarnCluster. MiniMRYarnCluster tries to copy the value of JHAdminConfig.MR_HISTORY_ADDRESS in the configuration of JobHistoryServer (updated by using Configuration#updateConnectAddr) in startup.

                //need to do this because historyServer.init creates a new Configuration
                getConfig().set(JHAdminConfig.MR_HISTORY_ADDRESS,
                                historyServer.getConfig().get(JHAdminConfig.MR_HISTORY_ADDRESS));
                MRWebAppUtil.setJHSWebappURLWithoutScheme(getConfig(),
                    MRWebAppUtil.getJHSWebappURLWithoutScheme(historyServer.getConfig()));
          

          According to the log of minicluster, the updated value seems not yet to be visible at above point.

          before restart:

          2015-10-27 17:27:52,825 INFO  [main] v2.MiniMRYarnCluster (MiniMRYarnCluster.java:serviceStart(248)) - MiniMRYARN ResourceManager address: centos7:0
          2015-10-27 17:27:52,825 INFO  [main] v2.MiniMRYarnCluster (MiniMRYarnCluster.java:serviceStart(250)) - MiniMRYARN ResourceManager web address: centos7:0
          2015-10-27 17:27:52,825 INFO  [main] v2.MiniMRYarnCluster (MiniMRYarnCluster.java:serviceStart(252)) - MiniMRYARN HistoryServer address: centos7:0
          2015-10-27 17:27:52,826 INFO  [main] v2.MiniMRYarnCluster (MiniMRYarnCluster.java:serviceStart(254)) - MiniMRYARN HistoryServer web address: localhost:0
          

          after restart:

          2015-10-27 17:27:55,330 INFO  [main] v2.MiniMRYarnCluster (MiniMRYarnCluster.java:serviceStart(198)) - MiniMRYARN ResourceManager address: localhost:45359
          2015-10-27 17:27:55,330 INFO  [main] v2.MiniMRYarnCluster (MiniMRYarnCluster.java:serviceStart(200)) - MiniMRYARN ResourceManager web address: centos7:34289
          2015-10-27 17:27:55,331 INFO  [main] v2.MiniMRYarnCluster (MiniMRYarnCluster.java:serviceStart(202)) - MiniMRYARN HistoryServer address: localhost:52822
          2015-10-27 17:27:55,331 INFO  [main] v2.MiniMRYarnCluster (MiniMRYarnCluster.java:serviceStart(204)) - MiniMRYARN HistoryServer web address: localhost:57028
          
          iwasakims Masatake Iwasaki added a comment -

          I attached the 001. The copy and logging of configuration should be done after all services are started.

          hadoopqa Hadoop QA added a comment -



          -1 overall



          Vote Subsystem Runtime Comment
          0 pre-patch 6m 22s Pre-patch trunk compilation is healthy.
          +1 @author 0m 0s The patch does not contain any @author tags.
          +1 tests included 0m 0s The patch appears to include 1 new or modified test files.
          +1 javac 8m 1s There were no new javac warning messages.
          +1 release audit 0m 21s The applied patch does not increase the total number of release audit warnings.
          +1 checkstyle 0m 34s There were no new checkstyle issues.
          +1 whitespace 0m 0s The patch has no lines that end in whitespace.
          +1 install 1m 34s mvn install still works.
          +1 eclipse:eclipse 0m 32s The patch built with eclipse:eclipse.
          +1 findbugs 0m 52s The patch does not introduce any new Findbugs (version 3.0.0) warnings.
          -1 mapreduce tests 122m 38s Tests failed in hadoop-mapreduce-client-jobclient.
              140m 57s  



          Reason Tests
          Failed unit tests hadoop.mapreduce.v2.TestNonExistentJob
          Timed out tests org.apache.hadoop.mapred.TestJobName



          Subsystem Report/Notes
          Patch URL http://issues.apache.org/jira/secure/attachment/12768937/MAPREDUCE-6525.001.patch
          Optional Tests javac unit findbugs checkstyle
          git revision trunk / 96677be
          hadoop-mapreduce-client-jobclient test log https://builds.apache.org/job/PreCommit-MAPREDUCE-Build/6090/artifact/patchprocess/testrun_hadoop-mapreduce-client-jobclient.txt
          Test Results https://builds.apache.org/job/PreCommit-MAPREDUCE-Build/6090/testReport/
          Java 1.7.0_55
          uname Linux asf902.gq1.ygridcore.net 3.13.0-36-lowlatency #63-Ubuntu SMP PREEMPT Wed Sep 3 21:56:12 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
          Console output https://builds.apache.org/job/PreCommit-MAPREDUCE-Build/6090/console

          This message was automatically generated.

          iwasakims Masatake Iwasaki added a comment -

          The failure of TestJobName is not related because it does not use mini cluster. The error message of TestNonExistentJob is similar to MAPREDUCE-6525 and it implies that the fix is not enough.

          iwasakims Masatake Iwasaki added a comment -

          s/similar to MAPREDUCE-6525/similar to MAPREDUCE-6524/

          ajisakaa Akira Ajisaka added a comment -

          The copy and logging of configuration should be done after all services are started.

          Make sense to me. +1 for the patch.

          The error message of TestNonExistentJob is similar to MAPREDUCE-6524 and it implies that the fix is not enough.

          I could not reproduce the error locally.

          ajisakaa Akira Ajisaka added a comment -
          ozawa Tsuyoshi Ozawa added a comment -

          This is not related to this issue directly, but we should use Configuration to enable timeline server instead of using enableAHS.

            public MiniMRYarnCluster(String testName, int noOfNMs, boolean enableAHS) {
              super(testName, 1, noOfNMs, 4, 4, enableAHS);
            }
          
          iwasakims Masatake Iwasaki added a comment -

          .. we should use Configuration to enable timeline server instead of using enableAHS

          I agree but the constructer has already marked as deprecated by YARN-3573. I think there is nothing we can do more. We should not remove public constructor of mini cluster because it is possible to be used by downstream projects.

          This jira is addressing the issue about not AHS but JHS in MiniMRYarnCluster Though JHAdminConfig does not have on/off switch like YarnConfiguration.TIMELINE_SERVICE_ENABLED, I don't think we need to add it.

          ajisakaa Akira Ajisaka added a comment -

          Attaching the output of Jenkins build: https://builds.apache.org/job/PreCommit-MAPREDUCE-Build/6095/artifact/patchprocess/jiracommentfile

          -1 overall



          Vote Subsystem Runtime Comment
          0 reexec 0m 7s docker + precommit patch detected.
          +1 @author 0m 0s The patch does not contain any @author tags.
          +1 test4tests 0m 0s The patch appears to include 1 new or modified test files.
          +1 mvninstall 3m 14s trunk passed
          +1 compile 0m 21s trunk passed with JDK v1.8.0_60
          +1 compile 0m 21s trunk passed with JDK v1.7.0_79
          +1 checkstyle 0m 9s trunk passed
          +1 mvneclipse 0m 14s trunk passed
          +1 findbugs 0m 33s trunk passed
          +1 javadoc 0m 15s trunk passed with JDK v1.8.0_60
          +1 javadoc 0m 15s trunk passed with JDK v1.7.0_79
          +1 mvninstall 0m 25s the patch passed
          +1 compile 0m 22s the patch passed with JDK v1.8.0_60
          +1 javac 0m 22s the patch passed
          +1 compile 0m 21s the patch passed with JDK v1.7.0_79
          +1 javac 0m 21s the patch passed
          +1 checkstyle 0m 10s the patch passed
          +1 mvneclipse 0m 14s the patch passed
          +1 whitespace 0m 0s Patch has no whitespace issues.
          +1 findbugs 0m 42s the patch passed
          +1 javadoc 0m 15s the patch passed with JDK v1.8.0_60
          +1 javadoc 0m 14s the patch passed with JDK v1.7.0_79
          -1 unit 119m 33s hadoop-mapreduce-client-jobclient in the patch failed with JDK v1.8.0_60.
          -1 unit 115m 43s hadoop-mapreduce-client-jobclient in the patch failed with JDK v1.7.0_79.
          -1 asflicense 0m 36s Patch generated 17 ASF License warnings.
          245m 10s



          Reason Tests
          JDK v1.7.0_79 Failed junit tests hadoop.mapreduce.v2.TestMRJobsWithProfiler
            hadoop.mapred.TestLocalMRNotification



          Subsystem Report/Notes
          Docker Client=1.7.1 Server=1.7.1 Image:test-patch-base-hadoop-date2015-10-28
          JIRA Patch URL https://issues.apache.org/jira/secure/attachment/12768937/MAPREDUCE-6525.001.patch
          JIRA Issue MAPREDUCE-6525
          Optional Tests asflicense javac javadoc mvninstall unit findbugs checkstyle compile
          uname Linux b12e2813a57c 3.13.0-36-lowlatency #63-Ubuntu SMP PREEMPT Wed Sep 3 21:56:12 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
          Build tool maven
          Personality /home/jenkins/jenkins-slave/workspace/PreCommit-MAPREDUCE-Build/patchprocess/apache-yetus-06655ab/dev-support/personality/hadoop.sh
          git revision trunk / 9f4dfdf
          Default Java 1.7.0_79
          Multi-JDK versions /usr/lib/jvm/java-8-oracle:1.8.0_60 /usr/lib/jvm/java-7-openjdk-amd64:1.7.0_79
          findbugs v3.0.0
          unit https://builds.apache.org/job/PreCommit-MAPREDUCE-Build/6095/artifact/patchprocess/patch-unit-hadoop-mapreduce-project_hadoop-mapreduce-client_hadoop-mapreduce-client-jobclient-jdk1.8.0_60.txt
          unit https://builds.apache.org/job/PreCommit-MAPREDUCE-Build/6095/artifact/patchprocess/patch-unit-hadoop-mapreduce-project_hadoop-mapreduce-client_hadoop-mapreduce-client-jobclient-jdk1.7.0_79.txt
          unit test logs https://builds.apache.org/job/PreCommit-MAPREDUCE-Build/6095/artifact/patchprocess/patch-unit-hadoop-mapreduce-project_hadoop-mapreduce-client_hadoop-mapreduce-client-jobclient-jdk1.8.0_60.txt https://builds.apache.org/job/PreCommit-MAPREDUCE-Build/6095/artifact/patchprocess/patch-unit-hadoop-mapreduce-project_hadoop-mapreduce-client_hadoop-mapreduce-client-jobclient-jdk1.7.0_79.txt
          JDK v1.7.0_79 Test Results https://builds.apache.org/job/PreCommit-MAPREDUCE-Build/6095/testReport/
          asflicense https://builds.apache.org/job/PreCommit-MAPREDUCE-Build/6095/artifact/patchprocess/patch-asflicense-problems.txt
          modules C: hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-jobclient U: hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-jobclient
          Max memory used 226MB
          Powered by Apache Yetus http://yetus.apache.org
          Console output https://builds.apache.org/job/PreCommit-MAPREDUCE-Build/6095/console

          This message was automatically generated.

          ajisakaa Akira Ajisaka added a comment -

          The test failure looks unrelated.

          This jira is addressing the issue about not AHS but JHS in MiniMRYarnCluster

          Agree. Committing this.

          ajisakaa Akira Ajisaka added a comment -

          Committed this to trunk. Thanks Masatake Iwasaki for the patch and thanks Tsuyoshi Ozawa for the comment.

          hudson Hudson added a comment -

          FAILURE: Integrated in Hadoop-trunk-Commit #8743 (See https://builds.apache.org/job/Hadoop-trunk-Commit/8743/)
          MAPREDUCE-6525. Fix test failure of TestMiniMRClientCluster.testRestart. (aajisaka: rev 04d97f8abb7fcc7b635b9499a48ddaa1fe0ac7e3)

          • hadoop-mapreduce-project/CHANGES.txt
          • hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-jobclient/src/test/java/org/apache/hadoop/mapreduce/v2/MiniMRYarnCluster.java
          hudson Hudson added a comment -

          FAILURE: Integrated in Hadoop-Mapreduce-trunk-Java8 #617 (See https://builds.apache.org/job/Hadoop-Mapreduce-trunk-Java8/617/)
          MAPREDUCE-6525. Fix test failure of TestMiniMRClientCluster.testRestart. (aajisaka: rev 04d97f8abb7fcc7b635b9499a48ddaa1fe0ac7e3)

          • hadoop-mapreduce-project/CHANGES.txt
          • hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-jobclient/src/test/java/org/apache/hadoop/mapreduce/v2/MiniMRYarnCluster.java
          hudson Hudson added a comment -

          FAILURE: Integrated in Hadoop-Yarn-trunk-Java8 #628 (See https://builds.apache.org/job/Hadoop-Yarn-trunk-Java8/628/)
          MAPREDUCE-6525. Fix test failure of TestMiniMRClientCluster.testRestart. (aajisaka: rev 04d97f8abb7fcc7b635b9499a48ddaa1fe0ac7e3)

          • hadoop-mapreduce-project/CHANGES.txt
          • hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-jobclient/src/test/java/org/apache/hadoop/mapreduce/v2/MiniMRYarnCluster.java
          hudson Hudson added a comment -

          FAILURE: Integrated in Hadoop-Mapreduce-trunk #2558 (See https://builds.apache.org/job/Hadoop-Mapreduce-trunk/2558/)
          MAPREDUCE-6525. Fix test failure of TestMiniMRClientCluster.testRestart. (aajisaka: rev 04d97f8abb7fcc7b635b9499a48ddaa1fe0ac7e3)

          • hadoop-mapreduce-project/CHANGES.txt
          • hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-jobclient/src/test/java/org/apache/hadoop/mapreduce/v2/MiniMRYarnCluster.java
          hudson Hudson added a comment -

          FAILURE: Integrated in Hadoop-Yarn-trunk #1351 (See https://builds.apache.org/job/Hadoop-Yarn-trunk/1351/)
          MAPREDUCE-6525. Fix test failure of TestMiniMRClientCluster.testRestart. (aajisaka: rev 04d97f8abb7fcc7b635b9499a48ddaa1fe0ac7e3)

          • hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-jobclient/src/test/java/org/apache/hadoop/mapreduce/v2/MiniMRYarnCluster.java
          • hadoop-mapreduce-project/CHANGES.txt
          hudson Hudson added a comment -

          FAILURE: Integrated in Hadoop-Hdfs-trunk-Java8 #564 (See https://builds.apache.org/job/Hadoop-Hdfs-trunk-Java8/564/)
          MAPREDUCE-6525. Fix test failure of TestMiniMRClientCluster.testRestart. (aajisaka: rev 04d97f8abb7fcc7b635b9499a48ddaa1fe0ac7e3)

          • hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-jobclient/src/test/java/org/apache/hadoop/mapreduce/v2/MiniMRYarnCluster.java
          • hadoop-mapreduce-project/CHANGES.txt
          hudson Hudson added a comment -

          FAILURE: Integrated in Hadoop-Hdfs-trunk #2501 (See https://builds.apache.org/job/Hadoop-Hdfs-trunk/2501/)
          MAPREDUCE-6525. Fix test failure of TestMiniMRClientCluster.testRestart. (aajisaka: rev 04d97f8abb7fcc7b635b9499a48ddaa1fe0ac7e3)

          • hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-jobclient/src/test/java/org/apache/hadoop/mapreduce/v2/MiniMRYarnCluster.java
          • hadoop-mapreduce-project/CHANGES.txt

            People

            • Assignee:
              iwasakims Masatake Iwasaki
              Reporter:
              iwasakims Masatake Iwasaki
            • Votes:
              0 Vote for this issue
              Watchers:
              5 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development