Uploaded image for project: 'Hadoop Map/Reduce'
  1. Hadoop Map/Reduce
  2. MAPREDUCE-6293

Set job classloader on uber-job's LocalContainerLauncher event thread

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 2.6.0
    • Fix Version/s: 2.8.0, 3.0.0-alpha1
    • Component/s: mr-am
    • Labels:
      None
    • Hadoop Flags:
      Reviewed

      Description

      An uberized job fails if the job classloader is enabled and the job needs to use the thread context classloader to load a class. Some example error in the log:

      2015-03-23 23:28:34,675 INFO [main] org.apache.hadoop.mapreduce.v2.util.MRApps: Creating job classloader
      ...
      2015-03-23 23:28:42,096 ERROR [uber-SubtaskRunner] cascading.provider.ServiceLoader: unable to find service class: cascading.tuple.hadoop.collect.HadoopTupleMapFactory, with exception: java.lang.ClassNotFoundException: cascading.tuple.hadoop.collect.HadoopTupleMapFactory

      1. MAPREDUCE-6293.001.patch
        5 kB
        Sangjin Lee
      2. MAPREDUCE-6293.002.patch
        5 kB
        Sangjin Lee
      3. MAPREDUCE-6293.003.patch
        6 kB
        Sangjin Lee

        Activity

        sjlee0 Sangjin Lee added a comment -

        The root cause is this.

        Cascading loads HadoopTupleMapFactory using the thread context classloader. The thread on which the task runs us "uber-SubtaskRunner". This thread is created (directly or indirectly) through LocalContainerLauncher's service start. At that point, the job classloader exists but is not yet set as the TCCL. Thus, these threads do not inherit the job classloader as the TCCL (TCCLs are inherited from the "parent thread" that created the thread).

        It should be fixed in the same manner as what we did with the committer event handler. I'll post a patch shortly.

        hadoopqa Hadoop QA added a comment -

        -1 overall. Here are the results of testing the latest attachment
        http://issues.apache.org/jira/secure/attachment/12707416/MAPREDUCE-6293.001.patch
        against trunk revision 44809b8.

        +1 @author. The patch does not contain any @author tags.

        +1 tests included. The patch appears to include 1 new or modified test files.

        +1 javac. The applied patch does not increase the total number of javac compiler warnings.

        +1 javadoc. There were no new javadoc warning messages.

        +1 eclipse:eclipse. The patch built with eclipse:eclipse.

        +1 findbugs. The patch does not introduce any new Findbugs (version 2.0.3) warnings.

        +1 release audit. The applied patch does not increase the total number of release audit warnings.

        -1 core tests. The patch failed these unit tests in hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-app hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-jobclient:

        org.apache.hadoop.mapreduce.jobhistory.TestJobHistoryEventHandler
        org.apache.hadoop.mapred.TestReduceFetch
        org.apache.hadoop.mapred.TestMerge
        org.apache.hadoop.mapreduce.TestMapReduceLazyOutput
        org.apache.hadoop.mapred.TestMRIntermediateDataEncryption
        org.apache.hadoop.mapred.TestLazyOutput
        org.apache.hadoop.mapreduce.TestLargeSort
        org.apache.hadoop.mapred.TestReduceFetchFromPartialMem
        org.apache.hadoop.mapreduce.v2.TestMRJobsWithProfiler
        org.apache.hadoop.mapreduce.v2.TestRMNMInfo
        org.apache.hadoop.mapreduce.lib.output.TestJobOutputCommitter
        org.apache.hadoop.mapreduce.security.ssl.TestEncryptedShuffle
        org.apache.hadoop.mapred.TestJobSysDirWithDFS
        org.apache.hadoop.ipc.TestMRCJCSocketFactory
        org.apache.hadoop.mapred.TestSpecialCharactersInOutputPath
        org.apache.hadoop.mapreduce.v2.TestMROldApiJobs
        org.apache.hadoop.mapred.TestJobCleanup
        org.apache.hadoop.mapreduce.v2.TestSpeculativeExecution
        org.apache.hadoop.conf.TestNoDefaultsJobConf
        org.apache.hadoop.mapred.TestClusterMRNotification
        org.apache.hadoop.mapreduce.v2.TestMRAMWithNonNormalizedCapabilities
        org.apache.hadoop.mapreduce.v2.TestNonExistentJob
        org.apache.hadoop.mapreduce.v2.TestMRJobs
        org.apache.hadoop.mapred.TestMiniMRWithDFSWithDistinctUsers
        org.apache.hadoop.mapreduce.v2.TestMRAppWithCombiner
        org.apache.hadoop.mapreduce.v2.TestUberAM
        org.apache.hadoop.mapred.TestJobName
        org.apache.hadoop.mapreduce.TestMRJobClient
        org.apache.hadoop.mapred.TestMiniMRBringup
        org.apache.hadoop.mapred.TestClusterMapReduceTestCase
        org.apache.hadoop.mapreduce.security.TestMRCredentials
        org.apache.hadoop.mapred.TestMRTimelineEventHandling
        org.apache.hadoop.mapreduce.v2.TestMiniMRProxyUser
        org.apache.hadoop.mapreduce.v2.TestMRJobsWithHistoryService
        org.apache.hadoop.mapred.TestMiniMRClasspath
        org.apache.hadoop.mapred.TestMiniMRClientCluster
        org.apache.hadoop.mapred.TestNetworkedJob
        org.apache.hadoop.mapred.TestMiniMRChildTask
        org.apache.hadoop.mapreduce.TestChild
        org.apache.hadoop.mapreduce.security.TestBinaryTokenFile
        org.apache.hadoop.mapred.TestJobCounters

        Test results: https://builds.apache.org/job/PreCommit-MAPREDUCE-Build/5337//testReport/
        Console output: https://builds.apache.org/job/PreCommit-MAPREDUCE-Build/5337//console

        This message is automatically generated.

        sjlee0 Sangjin Lee added a comment -

        The test failures are highly likely to be existing issues on the trunk (HADOOP-10670). Basically the RM in a mini YARN cluster fails to start. I see these failures with a clean trunk build.

        sjlee0 Sangjin Lee added a comment -

        The test failures are caused by HADOOP-11754.

        I would greatly appreciate your review on the patch. Thanks!

        sjlee0 Sangjin Lee added a comment -

        Restarted the jenkins build after the fix for HADOOP-11754: https://builds.apache.org/job/PreCommit-MAPREDUCE-Build/5355/

        hadoopqa Hadoop QA added a comment -

        -1 overall. Here are the results of testing the latest attachment
        http://issues.apache.org/jira/secure/attachment/12707416/MAPREDUCE-6293.001.patch
        against trunk revision 90e07d5.

        +1 @author. The patch does not contain any @author tags.

        +1 tests included. The patch appears to include 1 new or modified test files.

        +1 javac. The applied patch does not increase the total number of javac compiler warnings.

        +1 javadoc. There were no new javadoc warning messages.

        +1 eclipse:eclipse. The patch built with eclipse:eclipse.

        +1 findbugs. The patch does not introduce any new Findbugs (version 2.0.3) warnings.

        +1 release audit. The applied patch does not increase the total number of release audit warnings.

        -1 core tests. The patch failed these unit tests in hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-app hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-jobclient:

        org.apache.hadoop.mapred.TestClusterMRNotification
        org.apache.hadoop.mapred.TestMRTimelineEventHandling
        org.apache.hadoop.mapreduce.v2.TestMRJobsWithProfiler
        org.apache.hadoop.mapred.pipes.TestPipeApplication
        org.apache.hadoop.mapreduce.v2.TestMRJobsWithHistoryService

        The following test timeouts occurred in hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-app hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-jobclient:

        org.apache.hadoop.mapreduce.TestMapReduceLazyOutput
        org.apache.hadoop.mapreduce.lib.output.TestJobOutputCommitter
        org.apache.hadoop.mapreduce.TestLargeSort
        org.apache.hadoop.mapreduce.TestMRJobClient
        org.apache.hadoop.mapreduce.v2.TestSpeculativeExecution
        org.apache.hadoop.mapreduce.v2.TestMRJobs
        org.apache.hadoop.mapreduce.v2.TestUberAM
        org.apache.hadoop.mapred.TestLazyOutput
        org.apache.hadoop.mapred.TestJobCleanup
        org.apache.hadoop.mapred.TestMiniMRWithDFSWithDistinctUsers
        org.apache.hadoop.mapred.TestMiniMRChildTask

        Test results: https://builds.apache.org/job/PreCommit-MAPREDUCE-Build/5355//testReport/
        Console output: https://builds.apache.org/job/PreCommit-MAPREDUCE-Build/5355//console

        This message is automatically generated.

        sjlee0 Sangjin Lee added a comment -

        Kicking off the jenkins build one more time. I suspect these test failures are spurious, as there are no failures related with classloading issues (they're mostly timeouts and other varierty). The patch is a no-op if the job classloader is not set.

        hadoopqa Hadoop QA added a comment -

        -1 overall. Here are the results of testing the latest attachment
        http://issues.apache.org/jira/secure/attachment/12707416/MAPREDUCE-6293.001.patch
        against trunk revision 85dc3c1.

        +1 @author. The patch does not contain any @author tags.

        +1 tests included. The patch appears to include 1 new or modified test files.

        +1 javac. The applied patch does not increase the total number of javac compiler warnings.

        +1 javadoc. There were no new javadoc warning messages.

        +1 eclipse:eclipse. The patch built with eclipse:eclipse.

        +1 findbugs. The patch does not introduce any new Findbugs (version 2.0.3) warnings.

        +1 release audit. The applied patch does not increase the total number of release audit warnings.

        -1 core tests. The patch failed these unit tests in hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-app hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-jobclient:

        org.apache.hadoop.mapred.TestClusterMRNotification
        org.apache.hadoop.mapred.TestMRTimelineEventHandling
        org.apache.hadoop.mapreduce.v2.TestMRJobsWithHistoryService
        org.apache.hadoop.mapreduce.v2.TestMRJobsWithProfiler
        org.apache.hadoop.mapred.pipes.TestPipeApplication

        Test results: https://builds.apache.org/job/PreCommit-MAPREDUCE-Build/5356//testReport/
        Console output: https://builds.apache.org/job/PreCommit-MAPREDUCE-Build/5356//console

        This message is automatically generated.

        sjlee0 Sangjin Lee added a comment -

        The failures seem to be existing failures on trunk. I can reproduce each of these failures locally on trunk. Let me see if there are any open JIRAs against these tests.

        In the meantime, I would appreciate your reviews. Thanks!

        djp Junping Du added a comment -

        Thanks Sangjin Lee for reporting the issue and delivering a patch to fix it. I will help to review here.
        I just found MAPREDUCE-6189 track the failure for TestMRTimelineEventHandling. Do we have other JIRAs to track other test failures? If not, I think we should file a separated JIRA to fix them.

        sjlee0 Sangjin Lee added a comment -

        Junping Du, I haven't tracked them all down yet. I'll report what I find later.

        Meanwhile, I would greatly appreciate your review on this. Thanks!

        jira.shegalov Gera Shegalov added a comment -

        Thanks for the patch, Sangjin Lee! It looks good.

        minor comment for LocalContainerLauncher#serviceStart. No null check is needed when calling eventHandler.setContextClassLoader because null is handled appropriately within that method.

        sjlee0 Sangjin Lee added a comment -

        Thanks Gera Shegalov for the review!

        I checked for null there in the abundance of caution because if jobClassLoader was null setContextClassLoader() would also set the thread's context classloader to null. If the inherited context classloader was not null initially, then it would have an effect of nulling out that TCCL. So to be safe, we should not be calling setContextClassLoader() unless we're truly overriding it, no?

        jira.shegalov Gera Shegalov added a comment -

        In such a case It would be good to be able to reason what classloader is used when job classloader is not set. Since we are already using the same approach in other places where setCCL is called, I am +1. However, I think it will be be helpful for debugging to add a LOG.info with thread and getCCL for jobclassloader == nul cases as well. In CommitterEventHandler we don't log at all.

        sjlee0 Sangjin Lee added a comment -

        JVM normally sets the default classloader (sun.misc.Launcher$AppClassLoader) as the TCCL on the main thread (from which other threads inherit it), so in most cases the TCCL is just the default classloader. But I think it's a good idea to add a logging statement to print out the TCCL here. I'll update the patch shortly.

        sjlee0 Sangjin Lee added a comment -

        Patch v.2

        hadoopqa Hadoop QA added a comment -

        +1 overall. Here are the results of testing the latest attachment
        http://issues.apache.org/jira/secure/attachment/12725778/MAPREDUCE-6293.002.patch
        against trunk revision 1b89a3e.

        +1 @author. The patch does not contain any @author tags.

        +1 tests included. The patch appears to include 1 new or modified test files.

        +1 javac. The applied patch does not increase the total number of javac compiler warnings.

        +1 javadoc. There were no new javadoc warning messages.

        +1 eclipse:eclipse. The patch built with eclipse:eclipse.

        +1 findbugs. The patch does not introduce any new Findbugs (version 2.0.3) warnings.

        +1 release audit. The applied patch does not increase the total number of release audit warnings.

        +1 core tests. The patch passed unit tests in hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-app hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-jobclient.

        Test results: https://builds.apache.org/job/PreCommit-MAPREDUCE-Build/5407//testReport/
        Console output: https://builds.apache.org/job/PreCommit-MAPREDUCE-Build/5407//console

        This message is automatically generated.

        jira.shegalov Gera Shegalov added a comment -

        Thanks for v2, Sangjin Lee!

        Can we just use implicit toString ?

        152	      // note the current TCCL
        153	      LOG.info("Context classloader of thread " + eventHandler +
        154	          ": " + eventHandler.getContextClassLoader());
        

        Then we would not need to worry whether eventHandler.setContextClassLoader(null) was ever called.

        sjlee0 Sangjin Lee added a comment -

        One reason I went with classLoader.getClass().getName() is classLoader.toString() would just use Object.toString() and print out the hashCode which I thought was unnecessary detail. I used this pattern elsewhere (e.g. MRApps).

        I'm OK with switching to the implicit toString(). I acknowledge the point about TCCL ever being null, although it would be very unlikely. But if we do, I think it'd be better to switch to it in all places where I log the classloader. Thoughts?

        jira.shegalov Gera Shegalov added a comment -

        I don't mind switching to implicit toString for classloader at other places for consistency even though they are guarded from NPE's.

        sjlee0 Sangjin Lee added a comment -

        Patch v.3

        hadoopqa Hadoop QA added a comment -

        -1 overall. Here are the results of testing the latest attachment
        http://issues.apache.org/jira/secure/attachment/12726717/MAPREDUCE-6293.003.patch
        against trunk revision 44872b7.

        +1 @author. The patch does not contain any @author tags.

        +1 tests included. The patch appears to include 1 new or modified test files.

        +1 javac. The applied patch does not increase the total number of javac compiler warnings.

        +1 javadoc. There were no new javadoc warning messages.

        +1 eclipse:eclipse. The patch built with eclipse:eclipse.

        +1 findbugs. The patch does not introduce any new Findbugs (version 2.0.3) warnings.

        +1 release audit. The applied patch does not increase the total number of release audit warnings.

        -1 core tests. The patch failed these unit tests in hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-app hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-common hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-jobclient:

        org.apache.hadoop.mapreduce.TestLargeSort
        org.apache.hadoop.mapreduce.v2.TestMRJobsWithProfiler

        Test results: https://builds.apache.org/job/PreCommit-MAPREDUCE-Build/5421//testReport/
        Console output: https://builds.apache.org/job/PreCommit-MAPREDUCE-Build/5421//console

        This message is automatically generated.

        sjlee0 Sangjin Lee added a comment -

        The test failures appear unrelated. Locally I'm unable to reproduce them with the patch or on the trunk. Just kicked off another build to see if it is transient.

        hadoopqa Hadoop QA added a comment -

        +1 overall. Here are the results of testing the latest attachment
        http://issues.apache.org/jira/secure/attachment/12726717/MAPREDUCE-6293.003.patch
        against trunk revision d52de61.

        +1 @author. The patch does not contain any @author tags.

        +1 tests included. The patch appears to include 1 new or modified test files.

        +1 javac. The applied patch does not increase the total number of javac compiler warnings.

        +1 javadoc. There were no new javadoc warning messages.

        +1 eclipse:eclipse. The patch built with eclipse:eclipse.

        +1 findbugs. The patch does not introduce any new Findbugs (version 2.0.3) warnings.

        +1 release audit. The applied patch does not increase the total number of release audit warnings.

        +1 core tests. The patch passed unit tests in hadoop-yarn-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-nodemanager.

        Test results: https://builds.apache.org/job/PreCommit-MAPREDUCE-Build/5424//testReport/
        Console output: https://builds.apache.org/job/PreCommit-MAPREDUCE-Build/5424//console

        This message is automatically generated.

        jira.shegalov Gera Shegalov added a comment -

        +1 for 003.patch

        jira.shegalov Gera Shegalov added a comment -

        Thanks Sangjin Lee for contribution! Committed to trunk and branch-2.

        hudson Hudson added a comment -

        SUCCESS: Integrated in Hadoop-trunk-Commit #7628 (See https://builds.apache.org/job/Hadoop-trunk-Commit/7628/)
        MAPREDUCE-6293. Set job classloader on uber-job's LocalContainerLauncher event thread. (Sangjin Lee via gera) (gera: rev 725eb52ddc647074f0bf1cc73c3029f1352f51d5)

        • hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-common/src/main/java/org/apache/hadoop/mapreduce/v2/util/MRApps.java
        • hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-jobclient/src/test/java/org/apache/hadoop/mapreduce/v2/TestMRJobs.java
        • hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-app/src/main/java/org/apache/hadoop/mapred/LocalContainerLauncher.java
        • hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-app/src/main/java/org/apache/hadoop/mapreduce/v2/app/MRAppMaster.java
        • hadoop-mapreduce-project/CHANGES.txt
        sjlee0 Sangjin Lee added a comment -

        Thanks Gera Shegalov for reviewing and committing it!

        hudson Hudson added a comment -

        FAILURE: Integrated in Hadoop-Hdfs-trunk #2103 (See https://builds.apache.org/job/Hadoop-Hdfs-trunk/2103/)
        MAPREDUCE-6293. Set job classloader on uber-job's LocalContainerLauncher event thread. (Sangjin Lee via gera) (gera: rev 725eb52ddc647074f0bf1cc73c3029f1352f51d5)

        • hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-jobclient/src/test/java/org/apache/hadoop/mapreduce/v2/TestMRJobs.java
        • hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-common/src/main/java/org/apache/hadoop/mapreduce/v2/util/MRApps.java
        • hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-app/src/main/java/org/apache/hadoop/mapred/LocalContainerLauncher.java
        • hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-app/src/main/java/org/apache/hadoop/mapreduce/v2/app/MRAppMaster.java
        • hadoop-mapreduce-project/CHANGES.txt
        hudson Hudson added a comment -

        FAILURE: Integrated in Hadoop-Hdfs-trunk-Java8 #162 (See https://builds.apache.org/job/Hadoop-Hdfs-trunk-Java8/162/)
        MAPREDUCE-6293. Set job classloader on uber-job's LocalContainerLauncher event thread. (Sangjin Lee via gera) (gera: rev 725eb52ddc647074f0bf1cc73c3029f1352f51d5)

        • hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-app/src/main/java/org/apache/hadoop/mapreduce/v2/app/MRAppMaster.java
        • hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-common/src/main/java/org/apache/hadoop/mapreduce/v2/util/MRApps.java
        • hadoop-mapreduce-project/CHANGES.txt
        • hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-jobclient/src/test/java/org/apache/hadoop/mapreduce/v2/TestMRJobs.java
        • hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-app/src/main/java/org/apache/hadoop/mapred/LocalContainerLauncher.java
        hudson Hudson added a comment -

        FAILURE: Integrated in Hadoop-Yarn-trunk-Java8 #171 (See https://builds.apache.org/job/Hadoop-Yarn-trunk-Java8/171/)
        MAPREDUCE-6293. Set job classloader on uber-job's LocalContainerLauncher event thread. (Sangjin Lee via gera) (gera: rev 725eb52ddc647074f0bf1cc73c3029f1352f51d5)

        • hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-app/src/main/java/org/apache/hadoop/mapreduce/v2/app/MRAppMaster.java
        • hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-app/src/main/java/org/apache/hadoop/mapred/LocalContainerLauncher.java
        • hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-jobclient/src/test/java/org/apache/hadoop/mapreduce/v2/TestMRJobs.java
        • hadoop-mapreduce-project/CHANGES.txt
        • hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-common/src/main/java/org/apache/hadoop/mapreduce/v2/util/MRApps.java
        hudson Hudson added a comment -

        SUCCESS: Integrated in Hadoop-Yarn-trunk #905 (See https://builds.apache.org/job/Hadoop-Yarn-trunk/905/)
        MAPREDUCE-6293. Set job classloader on uber-job's LocalContainerLauncher event thread. (Sangjin Lee via gera) (gera: rev 725eb52ddc647074f0bf1cc73c3029f1352f51d5)

        • hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-jobclient/src/test/java/org/apache/hadoop/mapreduce/v2/TestMRJobs.java
        • hadoop-mapreduce-project/CHANGES.txt
        • hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-app/src/main/java/org/apache/hadoop/mapreduce/v2/app/MRAppMaster.java
        • hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-common/src/main/java/org/apache/hadoop/mapreduce/v2/util/MRApps.java
        • hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-app/src/main/java/org/apache/hadoop/mapred/LocalContainerLauncher.java
        hudson Hudson added a comment -

        FAILURE: Integrated in Hadoop-Mapreduce-trunk-Java8 #172 (See https://builds.apache.org/job/Hadoop-Mapreduce-trunk-Java8/172/)
        MAPREDUCE-6293. Set job classloader on uber-job's LocalContainerLauncher event thread. (Sangjin Lee via gera) (gera: rev 725eb52ddc647074f0bf1cc73c3029f1352f51d5)

        • hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-app/src/main/java/org/apache/hadoop/mapreduce/v2/app/MRAppMaster.java
        • hadoop-mapreduce-project/CHANGES.txt
        • hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-common/src/main/java/org/apache/hadoop/mapreduce/v2/util/MRApps.java
        • hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-jobclient/src/test/java/org/apache/hadoop/mapreduce/v2/TestMRJobs.java
        • hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-app/src/main/java/org/apache/hadoop/mapred/LocalContainerLauncher.java
        hudson Hudson added a comment -

        FAILURE: Integrated in Hadoop-Mapreduce-trunk #2121 (See https://builds.apache.org/job/Hadoop-Mapreduce-trunk/2121/)
        MAPREDUCE-6293. Set job classloader on uber-job's LocalContainerLauncher event thread. (Sangjin Lee via gera) (gera: rev 725eb52ddc647074f0bf1cc73c3029f1352f51d5)

        • hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-app/src/main/java/org/apache/hadoop/mapred/LocalContainerLauncher.java
        • hadoop-mapreduce-project/CHANGES.txt
        • hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-jobclient/src/test/java/org/apache/hadoop/mapreduce/v2/TestMRJobs.java
        • hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-app/src/main/java/org/apache/hadoop/mapreduce/v2/app/MRAppMaster.java
        • hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-common/src/main/java/org/apache/hadoop/mapreduce/v2/util/MRApps.java

          People

          • Assignee:
            sjlee0 Sangjin Lee
            Reporter:
            sjlee0 Sangjin Lee
          • Votes:
            0 Vote for this issue
            Watchers:
            8 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development