Details

    • Type: Test Test
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 2.6.0
    • Component/s: None
    • Labels:
      None
    • Hadoop Flags:
      Reviewed

      Description

      This happened in builds #1871 and #1872

      testMapReduceJob(org.apache.hadoop.mapred.TestJavaSerialization)  Time elapsed: 2.784 sec  <<< FAILURE!
      junit.framework.ComparisonFailure: expected:<[a	]1> but was:<[0	1]1>
      	at junit.framework.Assert.assertEquals(Assert.java:100)
      	at junit.framework.Assert.assertEquals(Assert.java:107)
      	at junit.framework.TestCase.assertEquals(TestCase.java:269)
      	at org.apache.hadoop.mapred.TestJavaSerialization.testMapReduceJob(TestJavaSerialization.java:127)
      

        Activity

        Bruno P. Kinoshita added a comment -

        Hi, I think the builds were removed from Jenkins, but I could *not* reproduce with the following settings:

        Apache Maven 3.2.1 (ea8b2b07643dbb1b84b6d16e1f08391b666bc1e9; 2014-02-14T15:37:52-03:00)
        Maven home: /home/kinow/java/tupilabs/hadoop/hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-jobclient/EMBEDDED
        Java version: 1.7.0_65, vendor: Oracle Corporation
        Java home: /usr/lib/jvm/java-7-openjdk-amd64/jre
        Default locale: en_US, platform encoding: UTF-8
        OS name: "linux", version: "3.13.0-35-generic", arch: "amd64", family: "unix"

        Varun Vasudev added a comment -

        Modified the test to see if we can find out why this test is failing on trunk consistently.

        Hadoop QA added a comment -

        +1 overall. Here are the results of testing the latest attachment
        http://issues.apache.org/jira/secure/attachment/12678891/apache-mapreduce-6048.0.patch
        against trunk revision 27715ec.

        +1 @author. The patch does not contain any @author tags.

        +1 tests included. The patch appears to include 1 new or modified test files.

        +1 javac. The applied patch does not increase the total number of javac compiler warnings.

        +1 javadoc. There were no new javadoc warning messages.

        +1 eclipse:eclipse. The patch built with eclipse:eclipse.

        +1 findbugs. The patch does not introduce any new Findbugs (version 2.0.3) warnings.

        +1 release audit. The applied patch does not increase the total number of release audit warnings.

        +1 core tests. The patch passed unit tests in hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-jobclient.

        +1 contrib tests. The patch passed contrib unit tests.

        Test results: https://builds.apache.org/job/PreCommit-MAPREDUCE-Build/4992//testReport/
        Console output: https://builds.apache.org/job/PreCommit-MAPREDUCE-Build/4992//console

        This message is automatically generated.

        Jian He added a comment -

        looks good.
        Committed to trunk, branch-2, branch-2.6, thanks Varun!

        Hudson added a comment -

        FAILURE: Integrated in Hadoop-trunk-Commit #6448 (See https://builds.apache.org/job/Hadoop-trunk-Commit/6448/)
        MAPREDUCE-6048. Fixed TestJavaSerialization failure. Contributed by Varun Vasudev (jianhe: rev 73068f677bc45029743ba2e0b3c0256a8069c13e)

        • hadoop-mapreduce-project/CHANGES.txt
        • hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-jobclient/src/test/java/org/apache/hadoop/mapred/TestJavaSerialization.java
        Hudson added a comment -

        SUCCESS: Integrated in Hadoop-Yarn-trunk #734 (See https://builds.apache.org/job/Hadoop-Yarn-trunk/734/)
        MAPREDUCE-6048. Fixed TestJavaSerialization failure. Contributed by Varun Vasudev (jianhe: rev 73068f677bc45029743ba2e0b3c0256a8069c13e)

        • hadoop-mapreduce-project/CHANGES.txt
        • hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-jobclient/src/test/java/org/apache/hadoop/mapred/TestJavaSerialization.java
        Hudson added a comment -

        FAILURE: Integrated in Hadoop-Hdfs-trunk #1923 (See https://builds.apache.org/job/Hadoop-Hdfs-trunk/1923/)
        MAPREDUCE-6048. Fixed TestJavaSerialization failure. Contributed by Varun Vasudev (jianhe: rev 73068f677bc45029743ba2e0b3c0256a8069c13e)

        • hadoop-mapreduce-project/CHANGES.txt
        • hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-jobclient/src/test/java/org/apache/hadoop/mapred/TestJavaSerialization.java
        Hudson added a comment -

        FAILURE: Integrated in Hadoop-Mapreduce-trunk #1948 (See https://builds.apache.org/job/Hadoop-Mapreduce-trunk/1948/)
        MAPREDUCE-6048. Fixed TestJavaSerialization failure. Contributed by Varun Vasudev (jianhe: rev 73068f677bc45029743ba2e0b3c0256a8069c13e)

        • hadoop-mapreduce-project/CHANGES.txt
        • hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-jobclient/src/test/java/org/apache/hadoop/mapred/TestJavaSerialization.java
        Ted Yu added a comment -

        Looks like TestJavaSerialization failed again.

        Varun Vasudev added a comment -

        I wonder if it's a machine issue. H7 has been running all the mapreduce builds - maybe we can run it on another host and see if the failures persists.


          People

          • Assignee:
            Varun Vasudev
            Reporter:
            Ted Yu
          • Votes:
            0 Vote for this issue
            Watchers:
            8 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development