Hadoop Map/Reduce
  1. Hadoop Map/Reduce
  2. MAPREDUCE-6022

map_input_file is missing from streaming job environment

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 2.3.0
    • Fix Version/s: 2.6.0
    • Component/s: None
    • Labels:
      None
    • Target Version/s:
    • Hadoop Flags:
      Reviewed

      Description

      When running a streaming job the 'map_input_file' environment variable is not being set. This property is deprecated, but in the past deprecated properties still appeared in a stream job's environment.

      1. MAPREDUCE-6022.patch
        2 kB
        Jason Lowe
      2. MAPREDUCE-6022v2.patch
        3 kB
        Jason Lowe

        Issue Links

          Activity

          Hudson added a comment -

          FAILURE: Integrated in Hadoop-Mapreduce-trunk #1942 (See https://builds.apache.org/job/Hadoop-Mapreduce-trunk/1942/)
          MAPREDUCE-6022. map_input_file is missing from streaming job (kihwal: rev b056048114bf4701ef9dd22486db937cb589e81b)

          • hadoop-tools/hadoop-streaming/src/main/java/org/apache/hadoop/streaming/PipeMapRed.java
          • hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/conf/Configuration.java
          • hadoop-mapreduce-project/CHANGES.txt
          • hadoop-tools/hadoop-streaming/src/test/java/org/apache/hadoop/streaming/TrApp.java
          Hudson added a comment -

          FAILURE: Integrated in Hadoop-Hdfs-trunk #1917 (See https://builds.apache.org/job/Hadoop-Hdfs-trunk/1917/)
          MAPREDUCE-6022. map_input_file is missing from streaming job (kihwal: rev b056048114bf4701ef9dd22486db937cb589e81b)

          • hadoop-tools/hadoop-streaming/src/test/java/org/apache/hadoop/streaming/TrApp.java
          • hadoop-mapreduce-project/CHANGES.txt
          • hadoop-tools/hadoop-streaming/src/main/java/org/apache/hadoop/streaming/PipeMapRed.java
          • hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/conf/Configuration.java
          Hudson added a comment -

          SUCCESS: Integrated in Hadoop-Yarn-trunk #728 (See https://builds.apache.org/job/Hadoop-Yarn-trunk/728/)
          MAPREDUCE-6022. map_input_file is missing from streaming job (kihwal: rev b056048114bf4701ef9dd22486db937cb589e81b)

          • hadoop-mapreduce-project/CHANGES.txt
          • hadoop-tools/hadoop-streaming/src/main/java/org/apache/hadoop/streaming/PipeMapRed.java
          • hadoop-tools/hadoop-streaming/src/test/java/org/apache/hadoop/streaming/TrApp.java
          • hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/conf/Configuration.java
          Hudson added a comment -

          FAILURE: Integrated in Hadoop-trunk-Commit #6382 (See https://builds.apache.org/job/Hadoop-trunk-Commit/6382/)
          MAPREDUCE-6022. map_input_file is missing from streaming job (kihwal: rev b056048114bf4701ef9dd22486db937cb589e81b)

          • hadoop-tools/hadoop-streaming/src/main/java/org/apache/hadoop/streaming/PipeMapRed.java
          • hadoop-tools/hadoop-streaming/src/test/java/org/apache/hadoop/streaming/TrApp.java
          • hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/conf/Configuration.java
          • hadoop-mapreduce-project/CHANGES.txt
          Kihwal Lee added a comment -

          I've just committed this. Thanks for fixing the bug, Jason.

          Kihwal Lee added a comment -

          +1 looks good to me.

          Jason Lowe added a comment -

          The findbug warnings are unrelated, and I believe the unit test failure is as well. It passes for me locally.

          Hadoop QA added a comment -

          -1 overall. Here are the results of testing the latest attachment
          http://issues.apache.org/jira/secure/attachment/12675547/MAPREDUCE-6022v2.patch
          against trunk revision a6aa6e4.

          +1 @author. The patch does not contain any @author tags.

          +1 tests included. The patch appears to include 1 new or modified test files.

          +1 javac. The applied patch does not increase the total number of javac compiler warnings.

          +1 javadoc. There were no new javadoc warning messages.

          +1 eclipse:eclipse. The patch built with eclipse:eclipse.

          -1 findbugs. The patch appears to introduce 2 new Findbugs (version 2.0.3) warnings.

          +1 release audit. The applied patch does not increase the total number of release audit warnings.

          -1 core tests. The patch failed these unit tests in hadoop-common-project/hadoop-common hadoop-tools/hadoop-streaming:

          org.apache.hadoop.streaming.TestMultipleArchiveFiles

          +1 contrib tests. The patch passed contrib unit tests.

          Test results: https://builds.apache.org/job/PreCommit-MAPREDUCE-Build/4970//testReport/
          Findbugs warnings: https://builds.apache.org/job/PreCommit-MAPREDUCE-Build/4970//artifact/patchprocess/newPatchFindbugsWarningshadoop-common.html
          Console output: https://builds.apache.org/job/PreCommit-MAPREDUCE-Build/4970//console

          This message is automatically generated.

          Jason Lowe added a comment -

          Adding tests.

          Jason Lowe added a comment -

          Configuration is a touchy thing, so here's a prototype patch that tries to fix this in a streaming-specific way by explicitly asking the configuration object to expand the deprecated properties so it can expect them when iterating even if they weren't explicitly referenced in get/set. This allows them to show up in the streaming environment.

          Jason Lowe added a comment -

          I believe this was caused by HADOOP-10178. If I revert that change then the property re-appears in the streaming job environment.


            People

            • Assignee:
              Jason Lowe
              Reporter:
              Jason Lowe
            • Votes:
              0 Vote for this issue
              Watchers:
              5 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development