Hadoop Map/Reduce
  1. Hadoop Map/Reduce
  2. MAPREDUCE-5960

JobSubmitter's check whether job.jar is local is incorrect with no authority in job jar path.

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 2.4.0, 2.4.1
    • Fix Version/s: 2.6.0
    • Component/s: client
    • Labels:
      None
    • Target Version/s:
    • Hadoop Flags:
      Reviewed

      Description

      $ mapred job -submit myjob.xml 
      2014-07-06 15:06:34.731 java[12120:1903] Unable to load realm info from SCDynamicStore
      14/07/06 15:06:34 WARN util.NativeCodeLoader: Unable to load native-hadoop library for your platform... using builtin-java classes where applicable
      14/07/06 15:06:34 INFO client.RMProxy: Connecting to ResourceManager at /0.0.0.0:8032
      14/07/06 15:06:37 WARN conf.Configuration: bad conf file: element not <property>
      14/07/06 15:06:37 WARN conf.Configuration: bad conf file: element not <property>
      14/07/06 15:06:37 INFO client.RMProxy: Connecting to ResourceManager at /0.0.0.0:8032
      14/07/06 15:11:11 INFO mapreduce.JobSubmitter: Cleaning up the staging area /tmp/hadoop-yarn/staging/gshegalov/.staging/job_1404679996131_0004
      Exception in thread "main" java.lang.IllegalArgumentException: Wrong FS: viewfs:/user/gshegalov/hadoop-mapreduce-examples-3.0.0-SNAPSHOT.jar, expected: file:///
      	at org.apache.hadoop.fs.FileSystem.checkPath(FileSystem.java:643)
      	at org.apache.hadoop.fs.RawLocalFileSystem.pathToFile(RawLocalFileSystem.java:80)
      	at org.apache.hadoop.fs.RawLocalFileSystem.deprecatedGetFileStatus(RawLocalFileSystem.java:525)
      	at org.apache.hadoop.fs.RawLocalFileSystem.getFileLinkStatusInternal(RawLocalFileSystem.java:739)
      	at org.apache.hadoop.fs.RawLocalFileSystem.getFileStatus(RawLocalFileSystem.java:520)
      	at org.apache.hadoop.fs.FilterFileSystem.getFileStatus(FilterFileSystem.java:397)
      	at org.apache.hadoop.fs.FileUtil.copy(FileUtil.java:337)
      	at org.apache.hadoop.fs.FileSystem.copyFromLocalFile(FileSystem.java:1902)
      	at org.apache.hadoop.fs.FileSystem.copyFromLocalFile(FileSystem.java:1870)
      	at org.apache.hadoop.fs.FileSystem.copyFromLocalFile(FileSystem.java:1835)
      	at org.apache.hadoop.mapreduce.JobSubmitter.copyJar(JobSubmitter.java:286)
      	at org.apache.hadoop.mapreduce.JobSubmitter.copyAndConfigureFiles(JobSubmitter.java:254)
      	at org.apache.hadoop.mapreduce.JobSubmitter.copyAndConfigureFiles(JobSubmitter.java:301)
      	at org.apache.hadoop.mapreduce.JobSubmitter.submitJobInternal(JobSubmitter.java:389)
      	at org.apache.hadoop.mapreduce.Job$10.run(Job.java:1285)
      	at org.apache.hadoop.mapreduce.Job$10.run(Job.java:1282)
      	at java.security.AccessController.doPrivileged(Native Method)
      	at javax.security.auth.Subject.doAs(Subject.java:415)
      	at org.apache.hadoop.security.UserGroupInformation.doAs(UserGroupInformation.java:1626)
      	at org.apache.hadoop.mapreduce.Job.submit(Job.java:1282)
      	at org.apache.hadoop.mapreduce.tools.CLI.run(CLI.java:260)
      	at org.apache.hadoop.util.ToolRunner.run(ToolRunner.java:70)
      	at org.apache.hadoop.util.ToolRunner.run(ToolRunner.java:84)
      	at org.apache.hadoop.mapred.JobClient.main(JobClient.java:1239)
      
      1. MAPREDUCE-5960.v04.patch
        13 kB
        Gera Shegalov
      2. MAPREDUCE-5960.v03.patch
        9 kB
        Gera Shegalov
      3. MAPREDUCE-5960.v02.patch
        10 kB
        Gera Shegalov
      4. MAPREDUCE-5960.v01.patch
        2 kB
        Gera Shegalov

        Issue Links

          Activity

          Gera Shegalov added a comment -

          v01 patch for review

          Hadoop QA added a comment -

          -1 overall. Here are the results of testing the latest attachment
          http://issues.apache.org/jira/secure/attachment/12654237/MAPREDUCE-5960.v01.patch
          against trunk revision .

          +1 @author. The patch does not contain any @author tags.

          -1 tests included. The patch doesn't appear to include any new or modified tests.
          Please justify why no new tests are needed for this patch.
          Also please list what manual steps were performed to verify this patch.

          +1 javac. The applied patch does not increase the total number of javac compiler warnings.

          +1 javadoc. There were no new javadoc warning messages.

          +1 eclipse:eclipse. The patch built with eclipse:eclipse.

          +1 findbugs. The patch does not introduce any new Findbugs (version 1.3.9) warnings.

          +1 release audit. The applied patch does not increase the total number of release audit warnings.

          +1 core tests. The patch passed unit tests in hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-core.

          +1 contrib tests. The patch passed contrib unit tests.

          Test results: https://builds.apache.org/job/PreCommit-MAPREDUCE-Build/4717//testReport/
          Console output: https://builds.apache.org/job/PreCommit-MAPREDUCE-Build/4717//console

          This message is automatically generated.

          Jason Lowe added a comment -

          Part of the issue is that Hadoop only assumes that the cluster nodes can get to the default filesystem, hence why it's checking if the file is on the same filesystem as the default filesystem. If not, it copies to that filesystem to ensure the nodes can access it. I'm not sure it's always safe to assume that if the client can access a non-"file:" filesystem that the nodes will be able to as well.

          Hadoop QA added a comment -

          -1 overall. Here are the results of testing the latest attachment
          http://issues.apache.org/jira/secure/attachment/12654237/MAPREDUCE-5960.v01.patch
          against trunk revision 3affad9.

          +1 @author. The patch does not contain any @author tags.

          -1 tests included. The patch doesn't appear to include any new or modified tests.
          Please justify why no new tests are needed for this patch.
          Also please list what manual steps were performed to verify this patch.

          +1 javac. The applied patch does not increase the total number of javac compiler warnings.

          +1 javadoc. There were no new javadoc warning messages.

          +1 eclipse:eclipse. The patch built with eclipse:eclipse.

          +1 findbugs. The patch does not introduce any new Findbugs (version 2.0.3) warnings.

          +1 release audit. The applied patch does not increase the total number of release audit warnings.

          +1 core tests. The patch passed unit tests in hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-core.

          +1 contrib tests. The patch passed contrib unit tests.

          Test results: https://builds.apache.org/job/PreCommit-MAPREDUCE-Build/4936//testReport/
          Console output: https://builds.apache.org/job/PreCommit-MAPREDUCE-Build/4936//console

          This message is automatically generated.

          Gera Shegalov added a comment -

          Jason Lowe, thanks for looking into this JIRA.

          I agree that it might not be safe to assume that the remote source be accessible from the server side. However, the user will find this out soon enough because the job will fail. It's equally wrong to assume the job jar won't be accessible, and deprive users from the option to store job bits at some other place central, such as s3. We can argue that it would be more efficient to first automatically copy the source jar to staging dir, and have NM localize from there as opposed to the original source.

          Setting this discussion aside, it does not look good that the submission simply fails. I added a unit test for the scenario I believe just has to work functionally.

          Hadoop QA added a comment -

          -1 overall. Here are the results of testing the latest attachment
          http://issues.apache.org/jira/secure/attachment/12674646/MAPREDUCE-5960.v02.patch
          against trunk revision cc93e7e.

          +1 @author. The patch does not contain any @author tags.

          +1 tests included. The patch appears to include 2 new or modified test files.

          +1 javac. The applied patch does not increase the total number of javac compiler warnings.

          +1 javadoc. There were no new javadoc warning messages.

          +1 eclipse:eclipse. The patch built with eclipse:eclipse.

          -1 findbugs. The patch appears to introduce 2 new Findbugs (version 2.0.3) warnings.

          +1 release audit. The applied patch does not increase the total number of release audit warnings.

          -1 core tests. The patch failed these unit tests in hadoop-common-project/hadoop-common hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-app hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-core hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-jobclient:

          org.apache.hadoop.security.token.delegation.web.TestWebDelegationToken

          The test build failed in hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-jobclient

          +1 contrib tests. The patch passed contrib unit tests.

          Test results: https://builds.apache.org/job/PreCommit-MAPREDUCE-Build/4960//testReport/
          Findbugs warnings: https://builds.apache.org/job/PreCommit-MAPREDUCE-Build/4960//artifact/patchprocess/newPatchFindbugsWarningshadoop-common.html
          Console output: https://builds.apache.org/job/PreCommit-MAPREDUCE-Build/4960//console

          This message is automatically generated.

          Daryn Sharp added a comment -

          The current code is completely broken. One of the conditions is copying the file if the path has scheme+authority but is on a different fs. Notice in the stack trace that FileSystem#copyFromLocalFile is always called, hence "file" is really the only supported authority.

          I'd simply the path mangling into something simpler like !"file".equals(path.getFileSystem(conf).getUri().getScheme()).

          Jason Lowe added a comment -

          Ah, sorry I totally missed the fact that copyJar is hardcoded to only support copying from the local filesystem. We might as well just check for file:// since anything else that wasn't the default fs will immediately fail in copyJar anyway.

          Only other comment is the "Copiyng" typo in the unit test method. It may be better to call the method something like testSleepJobWithRemoteJar.

          Gera Shegalov added a comment -

          Thanks for chiming in Daryn Sharp and Jason Lowe. I renamed the test to testSleepJobWithRemoteJar

          Hadoop QA added a comment -

          -1 overall. Here are the results of testing the latest attachment
          http://issues.apache.org/jira/secure/attachment/12679429/MAPREDUCE-5960.v03.patch
          against trunk revision 0762b4a.

          +1 @author. The patch does not contain any @author tags.

          +1 tests included. The patch appears to include 2 new or modified test files.

          +1 javac. The applied patch does not increase the total number of javac compiler warnings.

          +1 javadoc. There were no new javadoc warning messages.

          +1 eclipse:eclipse. The patch built with eclipse:eclipse.

          +1 findbugs. The patch does not introduce any new Findbugs (version 2.0.3) warnings.

          +1 release audit. The applied patch does not increase the total number of release audit warnings.

          -1 core tests. The patch failed these unit tests in hadoop-common-project/hadoop-common hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-app hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-core hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-jobclient:

          org.apache.hadoop.security.ssl.TestReloadingX509TrustManager
          org.apache.hadoop.mapreduce.v2.TestUberAM

          +1 contrib tests. The patch passed contrib unit tests.

          Test results: https://builds.apache.org/job/PreCommit-MAPREDUCE-Build/4995//testReport/
          Console output: https://builds.apache.org/job/PreCommit-MAPREDUCE-Build/4995//console

          This message is automatically generated.

          Jason Lowe added a comment -

          Thanks for updating the patch, Gera. Could you look into the TestUberAM failure? It seems related to the patch since it's failing in testSleepJobWitRemoteJar (typo in the code, should be testSleepJobWithRemoteJar).

          Gera Shegalov added a comment -

          Jason, v04 cleans up the tests to be more robust, and fixes the typo.

          Hadoop QA added a comment -

          -1 overall. Here are the results of testing the latest attachment
          http://issues.apache.org/jira/secure/attachment/12679705/MAPREDUCE-5960.v04.patch
          against trunk revision 8549fa5.

          +1 @author. The patch does not contain any @author tags.

          +1 tests included. The patch appears to include 2 new or modified test files.

          +1 javac. The applied patch does not increase the total number of javac compiler warnings.

          +1 javadoc. There were no new javadoc warning messages.

          +1 eclipse:eclipse. The patch built with eclipse:eclipse.

          +1 findbugs. The patch does not introduce any new Findbugs (version 2.0.3) warnings.

          +1 release audit. The applied patch does not increase the total number of release audit warnings.

          -1 core tests. The patch failed these unit tests in hadoop-common-project/hadoop-common hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-app hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-core hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-jobclient:

          org.apache.hadoop.security.ssl.TestReloadingX509TrustManager

          +1 contrib tests. The patch passed contrib unit tests.

          Test results: https://builds.apache.org/job/PreCommit-MAPREDUCE-Build/4998//testReport/
          Console output: https://builds.apache.org/job/PreCommit-MAPREDUCE-Build/4998//console

          This message is automatically generated.

          Jason Lowe added a comment -

          +1 committing this

          Jason Lowe added a comment -

          Forgot to mention in the previous comment that the TestReloadingX509TrustManager failure is unrelated, see HADOOP-11272.

          Thanks to Gera for the contribution and to Daryn for additional review! I committed this to trunk, branch-2, and branch-2.6.

          Hudson added a comment -

          FAILURE: Integrated in Hadoop-trunk-Commit #6467 (See https://builds.apache.org/job/Hadoop-trunk-Commit/6467/)
          MAPREDUCE-5960. JobSubmitter's check whether job.jar is local is incorrect with no authority in job jar path. Contributed by Gera Shegalov (jlowe: rev 10f9f5101c44be7c675a44ded4aad212627ecdee)

          • hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-jobclient/src/test/java/org/apache/hadoop/mapreduce/v2/TestMRJobs.java
          • hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-jobclient/src/test/java/org/apache/hadoop/mapreduce/v2/TestUberAM.java
          • hadoop-mapreduce-project/CHANGES.txt
          • hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-app/src/main/java/org/apache/hadoop/mapreduce/v2/app/job/impl/TaskAttemptImpl.java
          • hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-core/src/main/java/org/apache/hadoop/mapreduce/JobSubmitter.java
          • hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-jobclient/src/main/java/org/apache/hadoop/mapred/YARNRunner.java
          • hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/fs/FileContext.java
          Hudson added a comment -

          FAILURE: Integrated in Hadoop-Yarn-trunk #736 (See https://builds.apache.org/job/Hadoop-Yarn-trunk/736/)
          MAPREDUCE-5960. JobSubmitter's check whether job.jar is local is incorrect with no authority in job jar path. Contributed by Gera Shegalov (jlowe: rev 10f9f5101c44be7c675a44ded4aad212627ecdee)

          • hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-app/src/main/java/org/apache/hadoop/mapreduce/v2/app/job/impl/TaskAttemptImpl.java
          • hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/fs/FileContext.java
          • hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-jobclient/src/test/java/org/apache/hadoop/mapreduce/v2/TestUberAM.java
          • hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-jobclient/src/test/java/org/apache/hadoop/mapreduce/v2/TestMRJobs.java
          • hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-core/src/main/java/org/apache/hadoop/mapreduce/JobSubmitter.java
          • hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-jobclient/src/main/java/org/apache/hadoop/mapred/YARNRunner.java
          • hadoop-mapreduce-project/CHANGES.txt
          Hudson added a comment -

          SUCCESS: Integrated in Hadoop-Hdfs-trunk #1926 (See https://builds.apache.org/job/Hadoop-Hdfs-trunk/1926/)
          MAPREDUCE-5960. JobSubmitter's check whether job.jar is local is incorrect with no authority in job jar path. Contributed by Gera Shegalov (jlowe: rev 10f9f5101c44be7c675a44ded4aad212627ecdee)

          • hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-jobclient/src/test/java/org/apache/hadoop/mapreduce/v2/TestMRJobs.java
          • hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-jobclient/src/main/java/org/apache/hadoop/mapred/YARNRunner.java
          • hadoop-mapreduce-project/CHANGES.txt
          • hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-app/src/main/java/org/apache/hadoop/mapreduce/v2/app/job/impl/TaskAttemptImpl.java
          • hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/fs/FileContext.java
          • hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-jobclient/src/test/java/org/apache/hadoop/mapreduce/v2/TestUberAM.java
          • hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-core/src/main/java/org/apache/hadoop/mapreduce/JobSubmitter.java
          Hudson added a comment -

          FAILURE: Integrated in Hadoop-Mapreduce-trunk #1950 (See https://builds.apache.org/job/Hadoop-Mapreduce-trunk/1950/)
          MAPREDUCE-5960. JobSubmitter's check whether job.jar is local is incorrect with no authority in job jar path. Contributed by Gera Shegalov (jlowe: rev 10f9f5101c44be7c675a44ded4aad212627ecdee)

          • hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-jobclient/src/test/java/org/apache/hadoop/mapreduce/v2/TestUberAM.java
          • hadoop-mapreduce-project/CHANGES.txt
          • hadoop-common-project/hadoop-common/src/main/java/org/apache/hadoop/fs/FileContext.java
          • hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-core/src/main/java/org/apache/hadoop/mapreduce/JobSubmitter.java
          • hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-jobclient/src/test/java/org/apache/hadoop/mapreduce/v2/TestMRJobs.java
          • hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-jobclient/src/main/java/org/apache/hadoop/mapred/YARNRunner.java
          • hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-app/src/main/java/org/apache/hadoop/mapreduce/v2/app/job/impl/TaskAttemptImpl.java

            People

            • Assignee:
              Gera Shegalov
              Reporter:
              Gera Shegalov
            • Votes:
              0 Vote for this issue
              Watchers:
              7 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development