Uploaded image for project: 'Hadoop Map/Reduce'
  1. Hadoop Map/Reduce
  2. MAPREDUCE-5640

Rename TestLineRecordReader in jobclient module

    XMLWordPrintableJSON

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: Trivial
    • Resolution: Fixed
    • Affects Version/s: 0.23.9, 2.2.0
    • Fix Version/s: 0.23.10, 2.3.0
    • Component/s: test
    • Labels:
      None

      Description

      HADOOP-9622 proposes to add new unit tests for LineRecordReader in the mapreduce-client-core module alongside the code. The existing LineRecordReader tests in the mapreduce-client-jobclient module should be renamed to something like TestLineRecordReaderJobs to avoid a name conflict and to better indicate these are integration tests using full jobs rather than unit tests.

        Attachments

        1. MAPREDUCE-5640.patch
          20 kB
          Jason Darrell Lowe

          Activity

            People

            • Assignee:
              jlowe Jason Darrell Lowe
              Reporter:
              jlowe Jason Darrell Lowe
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: