JobTrackerMetricsSource and QueueMetrics provides users with some metrics, but its naming rules( "jobs_running", "running_maps", "running_reduces") sometimes confuses users. It should be standardized.
One concern is backward compatibility, so one idea is to share MetricMutableGaugeInt object from old and new property name.
e.g. to share runningMaps from "running_maps" and "maps_running".