Hadoop Map/Reduce
  1. Hadoop Map/Reduce
  2. MAPREDUCE-5206

JT can show the same job multiple times in Retired Jobs section

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 1.2.1
    • Component/s: None
    • Labels:
      None

      Description

      JT can show the same job multiple times in Retired Jobs section since the RetireJobs thread has a bug which adds the same job multiple times to collection of retired jobs.

        Activity

        Arun C Murthy added a comment -

        Thanks for checking on this Arpit Gupta!

        I just committed this.

        Arpit Gupta added a comment -

        +1

        Deployed a cluster with this patch and i no longer saw same job repeated in retired jobs.

        Arun C Murthy added a comment -

        The fix ensures that a job isn't added twice to retiredJobs - the issue is that there is code to not do it, but that code is not triggered due to a wrong check which I've separated from the path which retires a job see iff a user has too many completed jobs.

        Arun C Murthy added a comment -

        Trivial fix. This one is not worth adding an elaborate unit test w.r.t the fix.


          People

          • Assignee:
            Arun C Murthy
            Reporter:
            Arun C Murthy
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development