Hadoop Map/Reduce
  1. Hadoop Map/Reduce
  2. MAPREDUCE-4805

History files are not move to where the history server sees them

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Blocker Blocker
    • Resolution: Not a Problem
    • Affects Version/s: 3.0.0, 2.0.3-alpha
    • Fix Version/s: None
    • Component/s: applicationmaster
    • Labels:
      None

      Description

      It looks like MAPREDUCE-4723 added in a default case to the JobHistoryEventHandler that is causing it to have lots of issues for events that should just be ignored.

      1. MR-4805.txt
        1.0 kB
        Robert Joseph Evans

        Issue Links

          Activity

          Robert Joseph Evans created issue -
          Robert Joseph Evans made changes -
          Field Original Value New Value
          Link This issue is broken by MAPREDUCE-4723 [ MAPREDUCE-4723 ]
          Robert Joseph Evans added a comment -

          I confirmed that changing the YarnException to a comment/Log message

          Robert Joseph Evans added a comment -

          This patch should fix the issue, and return to the previous behavior.

          Robert Joseph Evans made changes -
          Attachment MR-4805.txt [ 12554185 ]
          Robert Joseph Evans made changes -
          Status Open [ 1 ] Patch Available [ 10002 ]
          Robert Joseph Evans made changes -
          Assignee Robert Joseph Evans [ revans2 ]
          Hadoop QA added a comment -

          -1 overall. Here are the results of testing the latest attachment
          http://issues.apache.org/jira/secure/attachment/12554185/MR-4805.txt
          against trunk revision .

          +1 @author. The patch does not contain any @author tags.

          -1 tests included. The patch doesn't appear to include any new or modified tests.
          Please justify why no new tests are needed for this patch.
          Also please list what manual steps were performed to verify this patch.

          +1 javac. The applied patch does not increase the total number of javac compiler warnings.

          +1 javadoc. The javadoc tool did not generate any warning messages.

          +1 eclipse:eclipse. The patch built with eclipse:eclipse.

          +1 findbugs. The patch does not introduce any new Findbugs (version 1.3.9) warnings.

          +1 release audit. The applied patch does not increase the total number of release audit warnings.

          +1 core tests. The patch passed unit tests in hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-app.

          +1 contrib tests. The patch passed contrib unit tests.

          Test results: https://builds.apache.org/job/PreCommit-MAPREDUCE-Build/3041//testReport/
          Console output: https://builds.apache.org/job/PreCommit-MAPREDUCE-Build/3041//console

          This message is automatically generated.

          Robert Joseph Evans added a comment -

          It looks like MAPREDUCE-4723 already checked in an update to fix this.

          Robert Joseph Evans made changes -
          Status Patch Available [ 10002 ] Resolved [ 5 ]
          Resolution Not A Problem [ 8 ]

            People

            • Assignee:
              Robert Joseph Evans
              Reporter:
              Robert Joseph Evans
            • Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development