Hadoop Map/Reduce
  1. Hadoop Map/Reduce
  2. MAPREDUCE-4494

TestFifoScheduler failing with Metrics source QueueMetrics,q0=default already exists!

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 2.0.0-alpha
    • Fix Version/s: 2.0.2-alpha
    • Component/s: mrv2, test
    • Labels:
      None
    • Hadoop Flags:
      Reviewed

      Description

      TestFifoScheduler is failing:

      Running org.apache.hadoop.yarn.server.resourcemanager.TestFifoScheduler
      Tests run: 5, Failures: 0, Errors: 1, Skipped: 0, Time elapsed: 14.614 sec <<< FAILURE!
      
      Results :
      
      Tests in error: 
        test(org.apache.hadoop.yarn.server.resourcemanager.TestFifoScheduler): Metrics source QueueMetrics,q0=default already exists!
      

        Activity

        Transition Time In Source Status Execution Times Last Executer Last Execution Date
        Open Open Patch Available Patch Available
        7m 2s 1 Ahmed Radwan 28/Jul/12 22:13
        Patch Available Patch Available Resolved Resolved
        9d 7h 59m 1 Alejandro Abdelnur 07/Aug/12 06:13
        Resolved Resolved Closed Closed
        65d 12h 35m 1 Arun C Murthy 11/Oct/12 18:48
        Arun C Murthy made changes -
        Status Resolved [ 5 ] Closed [ 6 ]
        Hudson added a comment -

        Integrated in Hadoop-Hdfs-trunk #1128 (See https://builds.apache.org/job/Hadoop-Hdfs-trunk/1128/)
        MAPREDUCE-4494. TestFifoScheduler failing with Metrics source QueueMetrics,q0=default already exists. (ahmed.radwan via tucu) (Revision 1370118)

        Result = SUCCESS
        tucu : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1370118
        Files :

        • /hadoop/common/trunk/hadoop-mapreduce-project/CHANGES.txt
        • /hadoop/common/trunk/hadoop-mapreduce-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-resourcemanager/src/test/java/org/apache/hadoop/yarn/server/resourcemanager/TestFifoScheduler.java
        Hudson added a comment -

        Integrated in Hadoop-Mapreduce-trunk-Commit #2577 (See https://builds.apache.org/job/Hadoop-Mapreduce-trunk-Commit/2577/)
        MAPREDUCE-4494. TestFifoScheduler failing with Metrics source QueueMetrics,q0=default already exists. (ahmed.radwan via tucu) (Revision 1370118)

        Result = FAILURE
        tucu : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1370118
        Files :

        • /hadoop/common/trunk/hadoop-mapreduce-project/CHANGES.txt
        • /hadoop/common/trunk/hadoop-mapreduce-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-resourcemanager/src/test/java/org/apache/hadoop/yarn/server/resourcemanager/TestFifoScheduler.java
        Hudson added a comment -

        Integrated in Hadoop-Common-trunk-Commit #2558 (See https://builds.apache.org/job/Hadoop-Common-trunk-Commit/2558/)
        MAPREDUCE-4494. TestFifoScheduler failing with Metrics source QueueMetrics,q0=default already exists. (ahmed.radwan via tucu) (Revision 1370118)

        Result = SUCCESS
        tucu : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1370118
        Files :

        • /hadoop/common/trunk/hadoop-mapreduce-project/CHANGES.txt
        • /hadoop/common/trunk/hadoop-mapreduce-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-resourcemanager/src/test/java/org/apache/hadoop/yarn/server/resourcemanager/TestFifoScheduler.java
        Hudson added a comment -

        Integrated in Hadoop-Hdfs-trunk-Commit #2623 (See https://builds.apache.org/job/Hadoop-Hdfs-trunk-Commit/2623/)
        MAPREDUCE-4494. TestFifoScheduler failing with Metrics source QueueMetrics,q0=default already exists. (ahmed.radwan via tucu) (Revision 1370118)

        Result = SUCCESS
        tucu : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1370118
        Files :

        • /hadoop/common/trunk/hadoop-mapreduce-project/CHANGES.txt
        • /hadoop/common/trunk/hadoop-mapreduce-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-resourcemanager/src/test/java/org/apache/hadoop/yarn/server/resourcemanager/TestFifoScheduler.java
        Alejandro Abdelnur made changes -
        Status Patch Available [ 10002 ] Resolved [ 5 ]
        Hadoop Flags Reviewed [ 10343 ]
        Fix Version/s 2.2.0-alpha [ 12322471 ]
        Resolution Fixed [ 1 ]
        Alejandro Abdelnur added a comment -

        Thanks Ahmed. Committed to trunk and branch-2.

        Alejandro Abdelnur added a comment -

        findbugs are unrelated to this patch.

        Alejandro Abdelnur added a comment -

        +1

        Hadoop QA added a comment -

        -1 overall. Here are the results of testing the latest attachment
        http://issues.apache.org/jira/secure/attachment/12538255/MAPREDUCE-4494.patch
        against trunk revision .

        +1 @author. The patch does not contain any @author tags.

        +1 tests included. The patch appears to include 1 new or modified test files.

        +1 javac. The applied patch does not increase the total number of javac compiler warnings.

        +1 javadoc. The javadoc tool did not generate any warning messages.

        +1 eclipse:eclipse. The patch built with eclipse:eclipse.

        -1 findbugs. The patch appears to introduce 4 new Findbugs (version 1.3.9) warnings.

        +1 release audit. The applied patch does not increase the total number of release audit warnings.

        +1 core tests. The patch passed unit tests in hadoop-mapreduce-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-resourcemanager.

        +1 contrib tests. The patch passed contrib unit tests.

        Test results: https://builds.apache.org/job/PreCommit-MAPREDUCE-Build/2673//testReport/
        Findbugs warnings: https://builds.apache.org/job/PreCommit-MAPREDUCE-Build/2673//artifact/trunk/patchprocess/newPatchFindbugsWarningshadoop-yarn-server-resourcemanager.html
        Console output: https://builds.apache.org/job/PreCommit-MAPREDUCE-Build/2673//console

        This message is automatically generated.

        Ahmed Radwan made changes -
        Status Open [ 1 ] Patch Available [ 10002 ]
        Ahmed Radwan made changes -
        Field Original Value New Value
        Attachment MAPREDUCE-4494.patch [ 12538255 ]
        Ahmed Radwan added a comment -

        The problem seems to be that rm is not stopped at the end of testHeadroom(). Here is a patch, I have confirmed that the test now successfully runs.

        Ahmed Radwan created issue -

          People

          • Assignee:
            Ahmed Radwan
            Reporter:
            Ahmed Radwan
          • Votes:
            0 Vote for this issue
            Watchers:
            5 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development