Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Critical Critical
    • Resolution: Fixed
    • Affects Version/s: 2.0.0-alpha, 3.0.0
    • Fix Version/s: 3.0.0, 2.0.2-alpha
    • Component/s: client, mrv2
    • Labels:
      None

      Description

      There are number of tests running under hadoop-mapreduce-client-jobclient that fail if Clover is enabled. Whenever a job is launched, AM doesn't start because it can't locate the clover jar file.

      I thought MAPREDUCE-4253 had something to do with this, but I can reproduce the issue on an older revision. Although unrelated, MAPREDUCE-4253 does have a problem and it has been reported to the jira.

      1. mapreduce-4416.patch.txt
        7 kB
        Kihwal Lee
      2. mapreduce-4416.patch.txt
        2 kB
        Kihwal Lee

        Activity

        Kihwal Lee added a comment -

        There are actually two different TestJobConf. One in o.a.h.conf and another one in o.a.h.mapred. It's confusing, but not really a problem.

        I had 37 failures/errors in jobclient when Clover is enabled.

        Failed tests:   testChild(org.apache.hadoop.mapreduce.TestChild)
          testDefaultCleanupAndAbort(org.apache.hadoop.mapreduce.lib.output.TestJobOutputCommitter): Job failed!
          testCustomAbort(org.apache.hadoop.mapreduce.lib.output.TestJobOutputCommitter): Job failed!
          testCustomCleanup(org.apache.hadoop.mapreduce.lib.output.TestJobOutputCommitter): Job failed!
          testValidProxyUser(org.apache.hadoop.mapreduce.v2.TestMiniMRProxyUser)
          testJobSucceed(org.apache.hadoop.mapreduce.v2.TestMROldApiJobs): Job expected to succeed failed
          testJobFail(org.apache.hadoop.mapreduce.v2.TestMROldApiJobs)
          testSleepJob(org.apache.hadoop.mapreduce.v2.TestMRJobs)
          testRandomWriter(org.apache.hadoop.mapreduce.v2.TestMRJobs)
          testDistributedCache(org.apache.hadoop.mapreduce.v2.TestMRJobs)
          testSleepJob(org.apache.hadoop.mapreduce.v2.TestUberAM)
          testRandomWriter(org.apache.hadoop.mapreduce.v2.TestUberAM)
          testFailingMapper(org.apache.hadoop.mapreduce.v2.TestUberAM): expected:<false> but was:<true>
          testSpeculativeExecution(org.apache.hadoop.mapreduce.v2.TestSpeculativeExecution)
          testLazyOutput(org.apache.hadoop.mapreduce.TestMapReduceLazyOutput)
          testHeapUsageCounter(org.apache.hadoop.mapred.TestJobCounters): Job job_1341837408279_0001 failed!
          testDefaultCleanupAndAbort(org.apache.hadoop.mapred.TestJobCleanup): Done file "/home/y/var/builds/thread2/workspace/Cloud-Hadoop-All-2.0-Component/hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-jobclient/target/test-dir/test-job-cleanup/output-0/_SUCCESS" missing for job job_1341837505379_0001
          testCustomAbort(org.apache.hadoop.mapred.TestJobCleanup): Done file "/home/y/var/builds/thread2/workspace/Cloud-Hadoop-All-2.0-Component/hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-jobclient/target/test-dir/test-job-cleanup/output-1/_SUCCESS" missing for job job_1341837505379_0002
          testCustomCleanup(org.apache.hadoop.mapred.TestJobCleanup): Done file "/home/y/var/builds/thread2/workspace/Cloud-Hadoop-All-2.0-Component/hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-jobclient/target/test-dir/test-job-cleanup/output-2/_custom_cleanup" missing for job job_1341837505379_0003
          testTaskTempDir(org.apache.hadoop.mapred.TestMiniMRChildTask)
          testTaskEnv(org.apache.hadoop.mapred.TestMiniMRChildTask): The environment checker job failed.
          testTaskOldEnv(org.apache.hadoop.mapred.TestMiniMRChildTask): The environment checker job failed.
          testJob(org.apache.hadoop.mapred.TestMiniMRClientCluster)
        
        Tests in error: 
          testFailingMapper(org.apache.hadoop.mapreduce.v2.TestMRJobs): 0
          testMR(org.apache.hadoop.mapred.TestClusterMRNotification): Job failed!
          testComplexName(org.apache.hadoop.mapred.TestJobName): Job failed!
          testComplexNameWithRegex(org.apache.hadoop.mapred.TestJobName): Job failed!
          testReduceFromPartialMem(org.apache.hadoop.mapred.TestReduceFetchFromPartialMem): Job failed!
          testClassPath(org.apache.hadoop.mapred.TestMiniMRClasspath): Job failed!
          testExternalWritable(org.apache.hadoop.mapred.TestMiniMRClasspath): Job failed!
          testWithDFS(org.apache.hadoop.mapred.TestJobSysDirWithDFS): Job failed!
          testReduceFromPartialMem(org.apache.hadoop.mapred.TestReduceFetchFromPartialMem): Job failed!
          testLazyOutput(org.apache.hadoop.mapred.TestLazyOutput): Job failed!
          testDistinctUsers(org.apache.hadoop.mapred.TestMiniMRWithDFSWithDistinctUsers): Job failed!
          testMultipleSpills(org.apache.hadoop.mapred.TestMiniMRWithDFSWithDistinctUsers): Job failed!
          testMapReduce(org.apache.hadoop.mapred.TestClusterMapReduceTestCase): Job failed!
          testMapReduceRestarting(org.apache.hadoop.mapred.TestClusterMapReduceTestCase): Job failed!
        
        Tests run: 381, Failures: 23, Errors: 14, Skipped: 14
        

        For the failing test cases, the container's stderr files contain the following:

        [CLOVER] FATAL ERROR: Clover could not be initialised. Are you sure you have
        Clover in the runtime classpath? (class
        java.lang.NoClassDefFoundError:com_cenqua_clover/CloverVersionInfo)
        
        Kihwal Lee added a comment -

        The failing tests are using MiniMRCluster and submit jobs. Jobs fail because containers' classpath does not contain the clover jar. If I make the leaf project to pick up non-clovered mr-client-app, at least AM works. But custom mapper, reducers, etc. defined in mr-client-jobclient will be instrumented and be part of the code running inside containers, so the containers should be able to locate the clover jar.

        We have a record of these tests working with clover at least on June 24. So I went back and tried the old revision but it didn't work this time... I wonder how it ever worked.

        Before MAPREDUCE-4082, it seems the classpath in mr-client-app contained the clover jar. The jira comments also shows clover being in the generated classpath. The now problematic clovered tests might have worked okay back then. Some tests were also being ignored.

        There is MAPREDUCE-4141 that removed the hard dependency on clover. If these tests accidentally worked before, this might have stopped it.

        Maybe running clovered test code in yarn containers does not make sense. They are separate processes launched by something other than the test framework. The clover instrumentation doesn't seem to be designed to naturally cover them. We could exclude some of test helper classes from instrumentation.

        Kihwal Lee added a comment -

        AM as well as mapper/reudcer fails, if run tests (e.g. TestChild) normally with -Pclover.

        [CLOVER] FATAL ERROR: Clover could not be initialised. Are you sure you have Clover in the runtime classpath? (class java.lang.NoClassDefFoundError:com_cenqua_clover/CloverVersionInfo)
        Exception in thread "main" java.lang.NoClassDefFoundError: com_cenqua_clover/CoverageRecorder
                at org.apache.hadoop.mapreduce.v2.app.MRAppMaster.main(MRAppMaster.java:1017)
        
        Patrick Hunt added a comment -

        I don't believe 4141 is the issue, as that was a build change, not something that should effect containers.

        I might be way off here but have you looked at "yarn.application.classpath" ? I ran into a similar sounding issue the other day with MAPREDUCE-4250. Ensure that clover jars are on the application classpath.

        Kihwal Lee added a comment -

        Patrick, thanks for the comment. That might work, but the fact that it's not really an app-level dependency bothers me. So I ended up adding the dependency inside the clover profile in hadoop-project/pom.xml. This causes each module to have clover jar as a dependency when -Pclover is specified. All mrapp-generated-classpath files will include the path to the clover jar. The package build will copy and include the clover jar, but we can't really use instrumented packages anyway.

        As an alternative to globally adding the dependency, we can do it per module whenever necessary. At least the following two needs the dependency specified.

        • hadoop-yarn-applications
        • hadoop-mapreduce-client-jobclient
        Hadoop QA added a comment -

        +1 overall. Here are the results of testing the latest attachment
        http://issues.apache.org/jira/secure/attachment/12536228/mapreduce-4416.patch.txt
        against trunk revision .

        +1 @author. The patch does not contain any @author tags.

        +1 tests included. The patch appears to include 1 new or modified test files.

        +1 javac. The applied patch does not increase the total number of javac compiler warnings.

        +1 javadoc. The javadoc tool did not generate any warning messages.

        +1 eclipse:eclipse. The patch built with eclipse:eclipse.

        +1 findbugs. The patch does not introduce any new Findbugs (version 1.3.9) warnings.

        +1 release audit. The applied patch does not increase the total number of release audit warnings.

        +1 core tests. The patch passed unit tests in hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-core hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-jobclient.

        +1 contrib tests. The patch passed contrib unit tests.

        Test results: https://builds.apache.org/job/PreCommit-MAPREDUCE-Build/2579//testReport/
        Console output: https://builds.apache.org/job/PreCommit-MAPREDUCE-Build/2579//console

        This message is automatically generated.

        Robert Joseph Evans added a comment -

        +1 the patch looks good, the tests pass, and clover now works. I verified this manually.

        Robert Joseph Evans added a comment -

        Thanks Kihwal,

        I put this into trunk, and branch-2

        Hudson added a comment -

        Integrated in Hadoop-Hdfs-trunk-Commit #2522 (See https://builds.apache.org/job/Hadoop-Hdfs-trunk-Commit/2522/)
        MAPREDUCE-4416. Some tests fail if Clover is enabled (Kihwal Lee via bobby) (Revision 1360735)

        Result = SUCCESS
        bobby : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1360735
        Files :

        • /hadoop/common/trunk/hadoop-mapreduce-project/CHANGES.txt
        • /hadoop/common/trunk/hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-core/src/test/java/org/apache/hadoop/mapred/TestIndexCache.java
        • /hadoop/common/trunk/hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-jobclient/pom.xml
        • /hadoop/common/trunk/hadoop-mapreduce-project/hadoop-yarn/hadoop-yarn-applications/pom.xml
        • /hadoop/common/trunk/hadoop-project/pom.xml
        Hudson added a comment -

        Integrated in Hadoop-Common-trunk-Commit #2456 (See https://builds.apache.org/job/Hadoop-Common-trunk-Commit/2456/)
        MAPREDUCE-4416. Some tests fail if Clover is enabled (Kihwal Lee via bobby) (Revision 1360735)

        Result = SUCCESS
        bobby : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1360735
        Files :

        • /hadoop/common/trunk/hadoop-mapreduce-project/CHANGES.txt
        • /hadoop/common/trunk/hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-core/src/test/java/org/apache/hadoop/mapred/TestIndexCache.java
        • /hadoop/common/trunk/hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-jobclient/pom.xml
        • /hadoop/common/trunk/hadoop-mapreduce-project/hadoop-yarn/hadoop-yarn-applications/pom.xml
        • /hadoop/common/trunk/hadoop-project/pom.xml
        Hudson added a comment -

        Integrated in Hadoop-Mapreduce-trunk-Commit #2475 (See https://builds.apache.org/job/Hadoop-Mapreduce-trunk-Commit/2475/)
        MAPREDUCE-4416. Some tests fail if Clover is enabled (Kihwal Lee via bobby) (Revision 1360735)

        Result = FAILURE
        bobby : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1360735
        Files :

        • /hadoop/common/trunk/hadoop-mapreduce-project/CHANGES.txt
        • /hadoop/common/trunk/hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-core/src/test/java/org/apache/hadoop/mapred/TestIndexCache.java
        • /hadoop/common/trunk/hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-jobclient/pom.xml
        • /hadoop/common/trunk/hadoop-mapreduce-project/hadoop-yarn/hadoop-yarn-applications/pom.xml
        • /hadoop/common/trunk/hadoop-project/pom.xml
        Hudson added a comment -

        Integrated in Hadoop-Hdfs-trunk #1102 (See https://builds.apache.org/job/Hadoop-Hdfs-trunk/1102/)
        MAPREDUCE-4416. Some tests fail if Clover is enabled (Kihwal Lee via bobby) (Revision 1360735)

        Result = FAILURE
        bobby : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1360735
        Files :

        • /hadoop/common/trunk/hadoop-mapreduce-project/CHANGES.txt
        • /hadoop/common/trunk/hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-core/src/test/java/org/apache/hadoop/mapred/TestIndexCache.java
        • /hadoop/common/trunk/hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-jobclient/pom.xml
        • /hadoop/common/trunk/hadoop-mapreduce-project/hadoop-yarn/hadoop-yarn-applications/pom.xml
        • /hadoop/common/trunk/hadoop-project/pom.xml
        Hudson added a comment -

        Integrated in Hadoop-Mapreduce-trunk #1135 (See https://builds.apache.org/job/Hadoop-Mapreduce-trunk/1135/)
        MAPREDUCE-4416. Some tests fail if Clover is enabled (Kihwal Lee via bobby) (Revision 1360735)

        Result = SUCCESS
        bobby : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1360735
        Files :

        • /hadoop/common/trunk/hadoop-mapreduce-project/CHANGES.txt
        • /hadoop/common/trunk/hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-core/src/test/java/org/apache/hadoop/mapred/TestIndexCache.java
        • /hadoop/common/trunk/hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-jobclient/pom.xml
        • /hadoop/common/trunk/hadoop-mapreduce-project/hadoop-yarn/hadoop-yarn-applications/pom.xml
        • /hadoop/common/trunk/hadoop-project/pom.xml

          People

          • Assignee:
            Kihwal Lee
            Reporter:
            Kihwal Lee
          • Votes:
            0 Vote for this issue
            Watchers:
            7 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development