Hadoop Map/Reduce
  1. Hadoop Map/Reduce
  2. MAPREDUCE-4306

Problem running Distributed Shell applications as a user other than the one started the daemons

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 2.0.0-alpha
    • Fix Version/s: 2.0.2-alpha
    • Component/s: mrv2
    • Labels:
      None
    • Target Version/s:
    • Hadoop Flags:
      Reviewed

      Description

      Using the tarball, if you start the yarn daemons using one user and then switch to a different user. You can successfully run MR jobs, but DS jobs fail to run. Only able to run DS jobs using the user who started the daemons.

      1. MAPREDUCE-4306_rev3.patch
        6 kB
        Ahmed Radwan
      2. MAPREDUCE-4306_rev2.patch
        5 kB
        Ahmed Radwan
      3. MAPREDUCE-4306.patch
        5 kB
        Ahmed Radwan

        Activity

        Ahmed Radwan added a comment -

        To reproduce this issue using the tarball on a single node cluster:

        1- Start all the daemons using user1.
        2- Switch to user2 and try to submit a distributed shell job:

        bin/hadoop jar ./share/hadoop/mapreduce/hadoop-yarn-applications-distributedshell-3.0.0-SNAPSHOT.jar org.apache.hadoop.yarn.applications.distributedshell.Client --jar ./share/hadoop/mapreduce/hadoop-yarn-applications-distributedshell-3.0.0-SNAPSHOT.jar --shell_command ls --num_containers 1 --debug
        

        I'll be uploading a patch momentarily.

        Ahmed Radwan added a comment -

        Here is the patch. I have manually tested it using a single-node cluster. Where I started the daemons using one user and then confirmed that a different user and the user started the daemons can both successfully run distributed shell jobs.

        Hadoop QA added a comment -

        -1 overall. Here are the results of testing the latest attachment
        http://issues.apache.org/jira/secure/attachment/12531308/MAPREDUCE-4306.patch
        against trunk revision .

        +1 @author. The patch does not contain any @author tags.

        -1 tests included. The patch doesn't appear to include any new or modified tests.
        Please justify why no new tests are needed for this patch.
        Also please list what manual steps were performed to verify this patch.

        +1 javac. The applied patch does not increase the total number of javac compiler warnings.

        +1 javadoc. The javadoc tool did not generate any warning messages.

        +1 eclipse:eclipse. The patch built with eclipse:eclipse.

        +1 findbugs. The patch does not introduce any new Findbugs (version 1.3.9) warnings.

        +1 release audit. The applied patch does not increase the total number of release audit warnings.

        +1 core tests. The patch passed unit tests in hadoop-mapreduce-project/hadoop-yarn/hadoop-yarn-applications/hadoop-yarn-applications-distributedshell.

        +1 contrib tests. The patch passed contrib unit tests.

        Test results: https://builds.apache.org/job/PreCommit-MAPREDUCE-Build/2445//testReport/
        Console output: https://builds.apache.org/job/PreCommit-MAPREDUCE-Build/2445//console

        This message is automatically generated.

        Ahmed Radwan added a comment -

        As I mentioned earlier, I have manually tested this issue and confirmed the corrected behavior with the patch.

        Tom White added a comment -
        +    try {
        +      amUser = cliParser.getOptionValue("user", UserGroupInformation
        +          .getCurrentUser().getShortUserName());
        +    } catch (IOException e) {
        +      LOG.info("Getting current user info failed" + e.getMessage());
        +    }
        

        If a user has been specified on the command line then there is no need to find the current user. In fact, if the current user can't be found then amUser won't be set. (Also, there's a space missing in the info line.)

        It's probably worth going through where user values are null or the empty string to check they are correct (e.g. on ContainerLaunchContext#setUser).

        Ahmed Radwan added a comment -

        Thanks Tom for the review!

        I have updated the patch to handle the case you highlighted (when the current user cannot be found and it is also not specified on the command line).

        For the case of empty or null user, this will still be invalid, since the user name (picked from ContainerLaunchContext#setUser) is used by DefaultContainerExecutor.launchContainer(..) to construct the container directory. Basically the FileNotFoundException that was preventing the application from running was originating from line 126: lfs.mkdir(containerDir, null, false) because the parent directory was not correct, as it was using the wrong user in constructing the path.

        Hadoop QA added a comment -

        -1 overall. Here are the results of testing the latest attachment
        http://issues.apache.org/jira/secure/attachment/12531919/MAPREDUCE-4306_rev2.patch
        against trunk revision .

        +1 @author. The patch does not contain any @author tags.

        -1 tests included. The patch doesn't appear to include any new or modified tests.
        Please justify why no new tests are needed for this patch.
        Also please list what manual steps were performed to verify this patch.

        +1 javac. The applied patch does not increase the total number of javac compiler warnings.

        +1 javadoc. The javadoc tool did not generate any warning messages.

        +1 eclipse:eclipse. The patch built with eclipse:eclipse.

        +1 findbugs. The patch does not introduce any new Findbugs (version 1.3.9) warnings.

        +1 release audit. The applied patch does not increase the total number of release audit warnings.

        +1 core tests. The patch passed unit tests in hadoop-mapreduce-project/hadoop-yarn/hadoop-yarn-applications/hadoop-yarn-applications-distributedshell.

        +1 contrib tests. The patch passed contrib unit tests.

        Test results: https://builds.apache.org/job/PreCommit-MAPREDUCE-Build/2461//testReport/
        Console output: https://builds.apache.org/job/PreCommit-MAPREDUCE-Build/2461//console

        This message is automatically generated.

        Siddharth Seth added a comment -

        The "-user" option in general seems to be broken. Even after this patch, the AM will be localized as the original user - since the RM picks up the username from ugi.

        Maybe we should remove the "-user" option completely? and use ApplicationConstants.Environment.USER in the AM - which is anyway set by the RM, based on the logged in user.

        Ahmed Radwan added a comment -

        Thanks Siddharth for the review!

        I agree, I think it is better to completely remove the "-user" option. I originally thought of just keeping it in case it can be used for testing or other purposes. But leaving it now may lead to confusion, and also setting it to something other than the original user will lead to failure as described above.

        Also reading ApplicationConstants.Environment.USER is simpler than reevaluating the username from ugi (which will give the same result after all). I have updated the patch accordingly. Thanks!

        Hadoop QA added a comment -

        -1 overall. Here are the results of testing the latest attachment
        http://issues.apache.org/jira/secure/attachment/12532455/MAPREDUCE-4306_rev3.patch
        against trunk revision .

        +1 @author. The patch does not contain any @author tags.

        -1 tests included. The patch doesn't appear to include any new or modified tests.
        Please justify why no new tests are needed for this patch.
        Also please list what manual steps were performed to verify this patch.

        +1 javac. The applied patch does not increase the total number of javac compiler warnings.

        +1 javadoc. The javadoc tool did not generate any warning messages.

        +1 eclipse:eclipse. The patch built with eclipse:eclipse.

        +1 findbugs. The patch does not introduce any new Findbugs (version 1.3.9) warnings.

        +1 release audit. The applied patch does not increase the total number of release audit warnings.

        +1 core tests. The patch passed unit tests in hadoop-mapreduce-project/hadoop-yarn/hadoop-yarn-applications/hadoop-yarn-applications-distributedshell.

        +1 contrib tests. The patch passed contrib unit tests.

        Test results: https://builds.apache.org/job/PreCommit-MAPREDUCE-Build/2471//testReport/
        Console output: https://builds.apache.org/job/PreCommit-MAPREDUCE-Build/2471//console

        This message is automatically generated.

        Siddharth Seth added a comment -

        Thanks Ahmed. This patch looks good, assuming you tried this out as well ?

        Ahmed Radwan added a comment -

        Yes, I did. Thanks Siddarth!

        Siddharth Seth added a comment -

        +1. Committing this. Thanks Ahmed.

        Siddharth Seth added a comment -

        Committed to trunk and branch-2.

        Hudson added a comment -

        Integrated in Hadoop-Common-trunk-Commit #2373 (See https://builds.apache.org/job/Hadoop-Common-trunk-Commit/2373/)
        MAPREDUCE-4306. Fix distributed shell to work with users other than the one running the daemons. (Contributed by Ahmed Radwan) (Revision 1351876)

        Result = SUCCESS
        sseth : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1351876
        Files :

        • /hadoop/common/trunk/hadoop-mapreduce-project/CHANGES.txt
        • /hadoop/common/trunk/hadoop-mapreduce-project/hadoop-yarn/hadoop-yarn-applications/hadoop-yarn-applications-distributedshell/src/main/java/org/apache/hadoop/yarn/applications/distributedshell/ApplicationMaster.java
        • /hadoop/common/trunk/hadoop-mapreduce-project/hadoop-yarn/hadoop-yarn-applications/hadoop-yarn-applications-distributedshell/src/main/java/org/apache/hadoop/yarn/applications/distributedshell/Client.java
        Hudson added a comment -

        Integrated in Hadoop-Hdfs-trunk-Commit #2443 (See https://builds.apache.org/job/Hadoop-Hdfs-trunk-Commit/2443/)
        MAPREDUCE-4306. Fix distributed shell to work with users other than the one running the daemons. (Contributed by Ahmed Radwan) (Revision 1351876)

        Result = SUCCESS
        sseth : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1351876
        Files :

        • /hadoop/common/trunk/hadoop-mapreduce-project/CHANGES.txt
        • /hadoop/common/trunk/hadoop-mapreduce-project/hadoop-yarn/hadoop-yarn-applications/hadoop-yarn-applications-distributedshell/src/main/java/org/apache/hadoop/yarn/applications/distributedshell/ApplicationMaster.java
        • /hadoop/common/trunk/hadoop-mapreduce-project/hadoop-yarn/hadoop-yarn-applications/hadoop-yarn-applications-distributedshell/src/main/java/org/apache/hadoop/yarn/applications/distributedshell/Client.java
        Hudson added a comment -

        Integrated in Hadoop-Mapreduce-trunk-Commit #2392 (See https://builds.apache.org/job/Hadoop-Mapreduce-trunk-Commit/2392/)
        MAPREDUCE-4306. Fix distributed shell to work with users other than the one running the daemons. (Contributed by Ahmed Radwan) (Revision 1351876)

        Result = FAILURE
        sseth : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1351876
        Files :

        • /hadoop/common/trunk/hadoop-mapreduce-project/CHANGES.txt
        • /hadoop/common/trunk/hadoop-mapreduce-project/hadoop-yarn/hadoop-yarn-applications/hadoop-yarn-applications-distributedshell/src/main/java/org/apache/hadoop/yarn/applications/distributedshell/ApplicationMaster.java
        • /hadoop/common/trunk/hadoop-mapreduce-project/hadoop-yarn/hadoop-yarn-applications/hadoop-yarn-applications-distributedshell/src/main/java/org/apache/hadoop/yarn/applications/distributedshell/Client.java
        Hudson added a comment -

        Integrated in Hadoop-Hdfs-trunk #1082 (See https://builds.apache.org/job/Hadoop-Hdfs-trunk/1082/)
        MAPREDUCE-4306. Fix distributed shell to work with users other than the one running the daemons. (Contributed by Ahmed Radwan) (Revision 1351876)

        Result = FAILURE
        sseth : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1351876
        Files :

        • /hadoop/common/trunk/hadoop-mapreduce-project/CHANGES.txt
        • /hadoop/common/trunk/hadoop-mapreduce-project/hadoop-yarn/hadoop-yarn-applications/hadoop-yarn-applications-distributedshell/src/main/java/org/apache/hadoop/yarn/applications/distributedshell/ApplicationMaster.java
        • /hadoop/common/trunk/hadoop-mapreduce-project/hadoop-yarn/hadoop-yarn-applications/hadoop-yarn-applications-distributedshell/src/main/java/org/apache/hadoop/yarn/applications/distributedshell/Client.java
        Hudson added a comment -

        Integrated in Hadoop-Mapreduce-trunk #1115 (See https://builds.apache.org/job/Hadoop-Mapreduce-trunk/1115/)
        MAPREDUCE-4306. Fix distributed shell to work with users other than the one running the daemons. (Contributed by Ahmed Radwan) (Revision 1351876)

        Result = FAILURE
        sseth : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1351876
        Files :

        • /hadoop/common/trunk/hadoop-mapreduce-project/CHANGES.txt
        • /hadoop/common/trunk/hadoop-mapreduce-project/hadoop-yarn/hadoop-yarn-applications/hadoop-yarn-applications-distributedshell/src/main/java/org/apache/hadoop/yarn/applications/distributedshell/ApplicationMaster.java
        • /hadoop/common/trunk/hadoop-mapreduce-project/hadoop-yarn/hadoop-yarn-applications/hadoop-yarn-applications-distributedshell/src/main/java/org/apache/hadoop/yarn/applications/distributedshell/Client.java

          People

          • Assignee:
            Ahmed Radwan
            Reporter:
            Ahmed Radwan
          • Votes:
            0 Vote for this issue
            Watchers:
            8 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development