Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Minor Minor
    • Resolution: Duplicate
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None

      Description

      The org.apache.hadoop.mapred.JobConf class needs better javadoc comments.

      In general terms, these guidelines should be followed:

      • http://java.sun.com/j2se/javadoc/writingdoccomments/#styleguide
      • document the unchecked exceptions that the caller might reasonably want to catch
      • use <code> font appropriately (detailed in link above)
      • document default values and appropriate configuration file properties
      • comments, tags, links, etc used consistently across API

      In particular, the javadoc for this class should at least answer these questions:

      • all constructors: what happens if the supplied class, file path, or configuration doesn't exist or is null?
      • JobConf() constructor: where are default values loaded from?
      • JobConf(Configuration) constructor: indicate that this is effectively a copy constructor
      • JobConf(String) constructor: are there any format requirements on the string? local and dfs paths allowed?
      • setter methods that take a path: what happens if the path doesn't exist?
      • getter methods returning objects: if value has not been set, is null returned or something else?
      • are JobConf objects immutable? If not, why not?
      • setNum*Tasks: is this per TaskTracker? or something else?
      • methods that take a Path: what if the path is relative?
      • setWorkingDirectory: is this deleted at the end of a job? should it be local or dfs?
      • *KeepFailedTaskFiles: if they are kept, where can they be found?
      • *KeepTaskFilesPattern: what does "the files" mean? if they are kept, where can they be found?
      • deleteLocalFiles: undoubtedly a risky operation. Need a good spec. Is it a recursive delete?
      • which configuration entries are mandatory (i.e. must be set before submitting the job)?

        Issue Links

          Activity

          Transition Time In Source Status Execution Times Last Executer Last Execution Date
          Open Open Resolved Resolved
          1881d 11h 35m 1 Harsh J 16/Jan/12 10:18
          Harsh J made changes -
          Status Open [ 1 ] Resolved [ 5 ]
          Resolution Duplicate [ 3 ]
          Harsh J added a comment -

          Dupe of HADOOP-2046

          Owen O'Malley made changes -
          Project Hadoop Common [ 12310240 ] Hadoop Map/Reduce [ 12310941 ]
          Key HADOOP-742 MAPREDUCE-412
          Affects Version/s 0.8.0 [ 12312098 ]
          Component/s mapred [ 12310690 ]
          Nigel Daley made changes -
          Assignee Nigel Daley [ nidaley ]
          Nigel Daley made changes -
          Assignee Owen O'Malley [ owen.omalley ] Nigel Daley [ nidaley ]
          Owen O'Malley added a comment -

          Nigel,
          Are you willing to close this after Arun's documentation patch?

          Nigel Daley made changes -
          Link This issue relates to HADOOP-2046 [ HADOOP-2046 ]
          Doug Cutting made changes -
          Assignee Owen O'Malley [ owen.omalley ]
          Doug Cutting made changes -
          Field Original Value New Value
          Component/s mapred [ 12310690 ]
          Nigel Daley created issue -

            People

            • Assignee:
              Unassigned
              Reporter:
              Nigel Daley
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development