Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 0.23.2
    • Fix Version/s: 0.23.2
    • Component/s: mrv2
    • Labels:
      None

      Description

      The following stack trace is being generated
      ========
      org.apache.hadoop.metrics2.MetricsException: Metrics source JvmMetrics already exists!
      at org.apache.hadoop.metrics2.lib.DefaultMetricsSystem.newSourceName(DefaultMetricsSystem.java:126)
      at org.apache.hadoop.metrics2.lib.DefaultMetricsSystem.sourceName(DefaultMetricsSystem.java:107)
      at org.apache.hadoop.metrics2.impl.MetricsSystemImpl.register(MetricsSystemImpl.java:216)
      at org.apache.hadoop.metrics2.source.JvmMetrics.create(JvmMetrics.java:80)
      at org.apache.hadoop.mapreduce.v2.app.metrics.MRAppMetrics.create(MRAppMetrics.java:58)
      at org.apache.hadoop.mapreduce.v2.app.metrics.MRAppMetrics.create(MRAppMetrics.java:54)
      at org.apache.hadoop.mapreduce.v2.app.MRAppMaster.<init>(MRAppMaster.java:186)
      at org.apache.hadoop.mapreduce.v2.app.MRAppMaster.<init>(MRAppMaster.java:170)
      at org.apache.hadoop.mapreduce.v2.app.MRApp.<init>(MRApp.java:160)
      at org.apache.hadoop.mapreduce.v2.app.TestRMContainerAllocator$1.<init>(TestRMContainerAllocator.java:372)
      at org.apache.hadoop.mapreduce.v2.app.TestRMContainerAllocator.testReportedAppProgress(TestRMContainerAllocator.java:371)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:597)
      at org.junit.runners.model.FrameworkMethod$1.runReflectiveCall(FrameworkMethod.java:44)
      ========

      This test fails when git trunk is reset to - commit 6689d99b38c7c562e8cae484207ad30ad7b56eb5
      but passes when git trunk is reset to - commit f429fdaf78a02211c4faee54b1ee92822edc5741

        Activity

        Arun C Murthy added a comment -

        Jason - can you please take a look at this asap? Thanks.

        Jason Lowe added a comment -

        Patch to call JvmMetrics.initSingleton() instead of JvmMetrics.create() to prevent multiple instantiations. No additional unit tests since this is fixing existing tests.

        Jason Lowe added a comment -

        I manually ran the TestRMContainerAllocator tests, and they pass after applying the patch. I also re-ran the metrics tests to verify the ResourceManager is still reporting JVM metrics.

        Not sure why Jenkins didn't catch this failure back on MAPREDUCE-3964. Apparently it doesn't run these tests?

        Robert Joseph Evans added a comment -

        The patch looks good to me. I am rerunning all of the MR tests now, because for some reason Jenkins missed this test failure.

        Hadoop QA added a comment -

        -1 overall. Here are the results of testing the latest attachment
        http://issues.apache.org/jira/secure/attachment/12517246/MAPREDUCE-3976.patch
        against trunk revision .

        +1 @author. The patch does not contain any @author tags.

        -1 tests included. The patch doesn't appear to include any new or modified tests.
        Please justify why no new tests are needed for this patch.
        Also please list what manual steps were performed to verify this patch.

        +1 javadoc. The javadoc tool did not generate any warning messages.

        +1 javac. The applied patch does not increase the total number of javac compiler warnings.

        +1 eclipse:eclipse. The patch built with eclipse:eclipse.

        +1 findbugs. The patch does not introduce any new Findbugs (version 1.3.9) warnings.

        +1 release audit. The applied patch does not increase the total number of release audit warnings.

        -1 core tests. The patch failed these unit tests:
        org.apache.hadoop.mapred.TestJobClientGetJob
        org.apache.hadoop.mapred.TestMRWithDistributedCache
        org.apache.hadoop.mapred.TestLocalModeWithNewApis

        +1 contrib tests. The patch passed contrib unit tests.

        Test results: https://builds.apache.org/job/PreCommit-MAPREDUCE-Build/2011//testReport/
        Console output: https://builds.apache.org/job/PreCommit-MAPREDUCE-Build/2011//console

        This message is automatically generated.

        Jason Lowe added a comment -

        Test failures appear to be another occurrence of MAPREDUCE-3729 rather than a result of this patch. I was unable to reproduce the problem locally. All of the test failures are of the form:

        chmod: cannot access `/tmp/hadoop-jenkins/mapred/staging/jenkins-1903973876/.staging/job_local_0001': No such file or directory
        
        Robert Joseph Evans added a comment -

        All of the mapreduce tests passed when I ran them manually +1

        Robert Joseph Evans added a comment -

        Thanks Arun for finding this bug. Thaks Jason for the quick turn around on the patch. I just put this into trunk branch-0.23 and branch-0.23.2

        Hudson added a comment -

        Integrated in Hadoop-Hdfs-0.23-Commit #635 (See https://builds.apache.org/job/Hadoop-Hdfs-0.23-Commit/635/)
        svn merge -c 1297557 from trunk to branch-0.23 FIXES: MAPREDUCE-3976. TestRMContainerAllocator failing (Jason Lowe via bobby) (Revision 1297558)

        Result = SUCCESS
        bobby : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1297558
        Files :

        • /hadoop/common/branches/branch-0.23/hadoop-mapreduce-project/CHANGES.txt
        • /hadoop/common/branches/branch-0.23/hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-app/src/main/java/org/apache/hadoop/mapreduce/v2/app/metrics/MRAppMetrics.java
        • /hadoop/common/branches/branch-0.23/hadoop-mapreduce-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-resourcemanager/src/main/java/org/apache/hadoop/yarn/server/resourcemanager/ResourceManager.java
        Hudson added a comment -

        Integrated in Hadoop-Common-trunk-Commit #1841 (See https://builds.apache.org/job/Hadoop-Common-trunk-Commit/1841/)
        MAPREDUCE-3976. TestRMContainerAllocator failing (Jason Lowe via bobby) (Revision 1297557)

        Result = SUCCESS
        bobby : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1297557
        Files :

        • /hadoop/common/trunk/hadoop-mapreduce-project/CHANGES.txt
        • /hadoop/common/trunk/hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-app/src/main/java/org/apache/hadoop/mapreduce/v2/app/metrics/MRAppMetrics.java
        • /hadoop/common/trunk/hadoop-mapreduce-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-resourcemanager/src/main/java/org/apache/hadoop/yarn/server/resourcemanager/ResourceManager.java
        Hudson added a comment -

        Integrated in Hadoop-Common-0.23-Commit #645 (See https://builds.apache.org/job/Hadoop-Common-0.23-Commit/645/)
        svn merge -c 1297557 from trunk to branch-0.23 FIXES: MAPREDUCE-3976. TestRMContainerAllocator failing (Jason Lowe via bobby) (Revision 1297558)

        Result = SUCCESS
        bobby : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1297558
        Files :

        • /hadoop/common/branches/branch-0.23/hadoop-mapreduce-project/CHANGES.txt
        • /hadoop/common/branches/branch-0.23/hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-app/src/main/java/org/apache/hadoop/mapreduce/v2/app/metrics/MRAppMetrics.java
        • /hadoop/common/branches/branch-0.23/hadoop-mapreduce-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-resourcemanager/src/main/java/org/apache/hadoop/yarn/server/resourcemanager/ResourceManager.java
        Hudson added a comment -

        Integrated in Hadoop-Hdfs-trunk-Commit #1915 (See https://builds.apache.org/job/Hadoop-Hdfs-trunk-Commit/1915/)
        MAPREDUCE-3976. TestRMContainerAllocator failing (Jason Lowe via bobby) (Revision 1297557)

        Result = SUCCESS
        bobby : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1297557
        Files :

        • /hadoop/common/trunk/hadoop-mapreduce-project/CHANGES.txt
        • /hadoop/common/trunk/hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-app/src/main/java/org/apache/hadoop/mapreduce/v2/app/metrics/MRAppMetrics.java
        • /hadoop/common/trunk/hadoop-mapreduce-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-resourcemanager/src/main/java/org/apache/hadoop/yarn/server/resourcemanager/ResourceManager.java
        Hudson added a comment -

        Integrated in Hadoop-Mapreduce-0.23-Commit #646 (See https://builds.apache.org/job/Hadoop-Mapreduce-0.23-Commit/646/)
        svn merge -c 1297557 from trunk to branch-0.23 FIXES: MAPREDUCE-3976. TestRMContainerAllocator failing (Jason Lowe via bobby) (Revision 1297558)

        Result = FAILURE
        bobby : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1297558
        Files :

        • /hadoop/common/branches/branch-0.23/hadoop-mapreduce-project/CHANGES.txt
        • /hadoop/common/branches/branch-0.23/hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-app/src/main/java/org/apache/hadoop/mapreduce/v2/app/metrics/MRAppMetrics.java
        • /hadoop/common/branches/branch-0.23/hadoop-mapreduce-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-resourcemanager/src/main/java/org/apache/hadoop/yarn/server/resourcemanager/ResourceManager.java
        Hudson added a comment -

        Integrated in Hadoop-Mapreduce-trunk-Commit #1848 (See https://builds.apache.org/job/Hadoop-Mapreduce-trunk-Commit/1848/)
        MAPREDUCE-3976. TestRMContainerAllocator failing (Jason Lowe via bobby) (Revision 1297557)

        Result = ABORTED
        bobby : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1297557
        Files :

        • /hadoop/common/trunk/hadoop-mapreduce-project/CHANGES.txt
        • /hadoop/common/trunk/hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-app/src/main/java/org/apache/hadoop/mapreduce/v2/app/metrics/MRAppMetrics.java
        • /hadoop/common/trunk/hadoop-mapreduce-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-resourcemanager/src/main/java/org/apache/hadoop/yarn/server/resourcemanager/ResourceManager.java
        Hudson added a comment -

        Integrated in Hadoop-Hdfs-0.23-Build #190 (See https://builds.apache.org/job/Hadoop-Hdfs-0.23-Build/190/)
        svn merge -c 1297557 from trunk to branch-0.23 FIXES: MAPREDUCE-3976. TestRMContainerAllocator failing (Jason Lowe via bobby) (Revision 1297558)

        Result = SUCCESS
        bobby : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1297558
        Files :

        • /hadoop/common/branches/branch-0.23/hadoop-mapreduce-project/CHANGES.txt
        • /hadoop/common/branches/branch-0.23/hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-app/src/main/java/org/apache/hadoop/mapreduce/v2/app/metrics/MRAppMetrics.java
        • /hadoop/common/branches/branch-0.23/hadoop-mapreduce-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-resourcemanager/src/main/java/org/apache/hadoop/yarn/server/resourcemanager/ResourceManager.java
        Hudson added a comment -

        Integrated in Hadoop-Hdfs-trunk #977 (See https://builds.apache.org/job/Hadoop-Hdfs-trunk/977/)
        MAPREDUCE-3976. TestRMContainerAllocator failing (Jason Lowe via bobby) (Revision 1297557)

        Result = FAILURE
        bobby : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1297557
        Files :

        • /hadoop/common/trunk/hadoop-mapreduce-project/CHANGES.txt
        • /hadoop/common/trunk/hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-app/src/main/java/org/apache/hadoop/mapreduce/v2/app/metrics/MRAppMetrics.java
        • /hadoop/common/trunk/hadoop-mapreduce-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-resourcemanager/src/main/java/org/apache/hadoop/yarn/server/resourcemanager/ResourceManager.java
        Hudson added a comment -

        Integrated in Hadoop-Mapreduce-0.23-Build #218 (See https://builds.apache.org/job/Hadoop-Mapreduce-0.23-Build/218/)
        svn merge -c 1297557 from trunk to branch-0.23 FIXES: MAPREDUCE-3976. TestRMContainerAllocator failing (Jason Lowe via bobby) (Revision 1297558)

        Result = FAILURE
        bobby : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1297558
        Files :

        • /hadoop/common/branches/branch-0.23/hadoop-mapreduce-project/CHANGES.txt
        • /hadoop/common/branches/branch-0.23/hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-app/src/main/java/org/apache/hadoop/mapreduce/v2/app/metrics/MRAppMetrics.java
        • /hadoop/common/branches/branch-0.23/hadoop-mapreduce-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-resourcemanager/src/main/java/org/apache/hadoop/yarn/server/resourcemanager/ResourceManager.java
        Hudson added a comment -

        Integrated in Hadoop-Mapreduce-trunk #1012 (See https://builds.apache.org/job/Hadoop-Mapreduce-trunk/1012/)
        MAPREDUCE-3976. TestRMContainerAllocator failing (Jason Lowe via bobby) (Revision 1297557)

        Result = FAILURE
        bobby : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1297557
        Files :

        • /hadoop/common/trunk/hadoop-mapreduce-project/CHANGES.txt
        • /hadoop/common/trunk/hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-app/src/main/java/org/apache/hadoop/mapreduce/v2/app/metrics/MRAppMetrics.java
        • /hadoop/common/trunk/hadoop-mapreduce-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-resourcemanager/src/main/java/org/apache/hadoop/yarn/server/resourcemanager/ResourceManager.java

          People

          • Assignee:
            Jason Lowe
            Reporter:
            Bikas Saha
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development