Hadoop Map/Reduce
  1. Hadoop Map/Reduce
  2. MAPREDUCE-3706

HTTP Circular redirect error on the job attempts page

    Details

    • Type: Bug Bug
    • Status: Resolved
    • Priority: Critical Critical
    • Resolution: Fixed
    • Affects Version/s: 0.23.0
    • Fix Version/s: 0.23.2
    • Component/s: mrv2
    • Labels:
      None

      Description

      submitted job and tried to go to following url:

      http://rmhost.domain.com:8088/proxy/application_1326992308313_0004/mapreduce/attempts/job_1326992308313_4_4/m/NEW

      This resulted in the following HTTP ERROR:

      HTTP ERROR 500

      Problem accessing /proxy/application_1326992308313_0004/mapreduce/attempts/job_1326992308313_4_4/m/NEW. Reason:

      Circular redirect to 'http://amhost.domain.com:44869/mapreduce/attempts/job_1326992308313_4_4/m/NEW'

      Caused by:

      org.apache.commons.httpclient.CircularRedirectException: Circular redirect to 'http://amhost.domain.com:44869/mapreduce/attempts/job_1326992308313_4_4/m/NEW'
      at org.apache.commons.httpclient.HttpMethodDirector.processRedirectResponse(HttpMethodDirector.java:638)
      at org.apache.commons.httpclient.HttpMethodDirector.executeMethod(HttpMethodDirector.java:179)
      at org.apache.commons.httpclient.HttpClient.executeMethod(HttpClient.java:397)
      at org.apache.commons.httpclient.HttpClient.executeMethod(HttpClient.java:323)
      at org.apache.hadoop.yarn.server.webproxy.WebAppProxyServlet.proxyLink(WebAppProxyServlet.java:148) at org.apache.hadoop.yarn.server.webproxy.WebAppProxyServlet.doGet(WebAppProxyServlet.java:269)
      at javax.servlet.http.HttpServlet.service(HttpServlet.java:707) at javax.servlet.http.HttpServlet.service(HttpServlet.java:820)
      at org.mortbay.jetty.servlet.ServletHolder.handle(ServletHolder.java:511)
      at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1221) at com.google.inject.servlet.FilterChainInvocation.doFilter(FilterChainInvocation.java:66)
      at com.sun.jersey.spi.container.servlet.ServletContainer.doFilter(ServletContainer.java:900) at com.sun.jersey.spi.container.servlet.ServletContainer.doFilter(ServletContainer.java:834)
      at com.sun.jersey.spi.container.servlet.ServletContainer.doFilter(ServletContainer.java:795)

      Note that if you first go to the proxy at: http://rmhost.domain.com:8088/proxy/application_1326992308313_0004/ and then click the links to get here you don't get the error.

      1. MR-3706.txt
        2 kB
        Robert Joseph Evans

        Issue Links

          Activity

          Amol Kekre added a comment -

          Making it critical as it is blocking QE. Not a blocker as this is UI

          Robert Joseph Evans added a comment -

          The only time that this would happen is if the AM thinks that the request is not coming from the proxy, and is then being redirected to go through the proxy again. I will look to see exactly which conditions this happens in. It could be that if the user is null, then this might happen.

          Robert Joseph Evans added a comment -

          Oh, I think I know now. If the application reports its state as finished the proxy will not try to be a proxy for the request, it will instead redirect the request to the URI provided by the AM, but if the AM has reported that it is finished, but has not updated the URI, (just speculating here, I need to check the code to be sure) because the jhist file is not finished being written yet, then the AM will redirect back to the proxy, and the proxy will redirect to the AM again. I need to confirm this and look at what we need to do to really fix this.

          Robert Joseph Evans added a comment -

          I am wrong about the timing issue. It can happen when the application is not close to exiting, and it appears to be the AmIpFilter sending a redirect to itself, instead of through the proxy. I can reproduce the issue, and I will dig into it.

          Robert Joseph Evans added a comment -

          I don't completely know what is happening, but I can reproduce this 100% of the time by going to a page for a reducer that has not been launched yet. We get a null pointer exception

          java.lang.reflect.InvocationTargetException
                  at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
                  at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
                  at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
                  at java.lang.reflect.Method.invoke(Method.java:597)
                  at org.apache.hadoop.yarn.webapp.Dispatcher.service(Dispatcher.java:150)
                  at javax.servlet.http.HttpServlet.service(HttpServlet.java:820)
                  at com.google.inject.servlet.ServletDefinition.doService(ServletDefinition.java:263)
                  at com.google.inject.servlet.ServletDefinition.service(ServletDefinition.java:178)
                  at com.google.inject.servlet.ManagedServletPipeline.service(ManagedServletPipeline.java:91)
                  at com.google.inject.servlet.FilterChainInvocation.doFilter(FilterChainInvocation.java:62)
                  at com.sun.jersey.spi.container.servlet.ServletContainer.doFilter(ServletContainer.java:900)
                  at com.sun.jersey.spi.container.servlet.ServletContainer.doFilter(ServletContainer.java:834)
                  at com.sun.jersey.spi.container.servlet.ServletContainer.doFilter(ServletContainer.java:795)
                  at com.google.inject.servlet.FilterDefinition.doFilter(FilterDefinition.java:163)
                  at com.google.inject.servlet.FilterChainInvocation.doFilter(FilterChainInvocation.java:58)
                  at com.google.inject.servlet.ManagedFilterPipeline.dispatch(ManagedFilterPipeline.java:118)
                  at com.google.inject.servlet.GuiceFilter.doFilter(GuiceFilter.java:113)
                  at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1212)
                  at org.apache.hadoop.yarn.server.webproxy.amfilter.AmIpFilter.doFilter(AmIpFilter.java:120)
                  at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1212)
                  at org.apache.hadoop.http.HttpServer$QuotingInputFilter.doFilter(HttpServer.java:940)
                  at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1212)
                  at org.mortbay.jetty.servlet.ServletHandler.handle(ServletHandler.java:399)
                  at org.mortbay.jetty.security.SecurityHandler.handle(SecurityHandler.java:216)
                  at org.mortbay.jetty.servlet.SessionHandler.handle(SessionHandler.java:182)
                  at org.mortbay.jetty.handler.ContextHandler.handle(ContextHandler.java:766)
                  at org.mortbay.jetty.webapp.WebAppContext.handle(WebAppContext.java:450)
                  at org.mortbay.jetty.handler.ContextHandlerCollection.handle(ContextHandlerCollection.java:230)
                  at org.mortbay.jetty.handler.HandlerWrapper.handle(HandlerWrapper.java:152)
                  at org.mortbay.jetty.Server.handle(Server.java:322)
                  at org.mortbay.jetty.HttpConnection.handleRequest(HttpConnection.java:542)
                  at org.mortbay.jetty.HttpConnection$RequestHandler.headerComplete(HttpConnection.java:928)
                  at org.mortbay.jetty.HttpParser.parseNext(HttpParser.java:549)
                  at org.mortbay.jetty.HttpParser.parseAvailable(HttpParser.java:212)
                  at org.mortbay.jetty.HttpConnection.handle(HttpConnection.java:404)
                  at org.mortbay.io.nio.SelectChannelEndPoint.run(SelectChannelEndPoint.java:410)
                  at org.mortbay.thread.QueuedThreadPool$PoolThread.run(QueuedThreadPool.java:582)
          Caused by: java.lang.NullPointerException
                  at org.apache.hadoop.yarn.util.ConverterUtils.toString(ConverterUtils.java:145)
                  at org.apache.hadoop.mapreduce.v2.app.webapp.dao.TaskAttemptInfo.<init>(TaskAttemptInfo.java:69)
                  at org.apache.hadoop.mapreduce.v2.app.webapp.dao.TaskAttemptInfo.<init>(TaskAttemptInfo.java:60)
                  at org.apache.hadoop.mapreduce.v2.app.webapp.TaskPage$AttemptsBlock.render(TaskPage.java:76)
                  at org.apache.hadoop.yarn.webapp.view.HtmlBlock.render(HtmlBlock.java:64)
                  at org.apache.hadoop.yarn.webapp.view.HtmlBlock.renderPartial(HtmlBlock.java:74)
                  at org.apache.hadoop.yarn.webapp.View.render(View.java:233)
                  at org.apache.hadoop.yarn.webapp.view.HtmlPage$Page.subView(HtmlPage.java:47)
                  at org.apache.hadoop.yarn.webapp.hamlet.HamletImpl$EImp._v(HamletImpl.java:117)
                  at org.apache.hadoop.yarn.webapp.hamlet.Hamlet$TD._(Hamlet.java:843)
                  at org.apache.hadoop.yarn.webapp.view.TwoColumnLayout.render(TwoColumnLayout.java:54)
                  at org.apache.hadoop.yarn.webapp.view.HtmlPage.render(HtmlPage.java:80)
                  at org.apache.hadoop.yarn.webapp.Controller.render(Controller.java:210)
                  at org.apache.hadoop.mapreduce.v2.app.webapp.AppController.task(AppController.java:250) 
                  ... 37 more
          

          But for some reason this gets turned into a 302 which causes it to redirect.

          2012-02-27 21:40:53,655 DEBUG [9538612@qtp-31361704-2 - /mapreduce/task/task_1330378805203_0001_r_000016] org.mortbay.log: RESPONSE /mapreduce/task/task_1330378805203_0001_r_000016  302
          

          I can probably fix the null pointer exception, but I want to understand why we are doing a redirect too.

          Robert Joseph Evans added a comment -

          OK So now I understand. If org.apache.hadoop.yarn.webapp.Dispatcher.service catches an exception it tries to set a few cookies, and redirect to the same page as before. These cookies tell it to render an error page instead of the regular page, but because the proxy removes all cookies from the requests these are never set, and they are ignored. We might be able to make this work properly if we allows cookies to be set between redirects within the proxy.

          Robert Joseph Evans added a comment -

          I have fixed the circular redirect by changing some setting in the HttpClient, and will upload a patch shortly. I filed MAPREDUCE-3930 to deal with the NPE that triggered the error.

          Robert Joseph Evans added a comment -

          No tests are included because it is difficult to unit test this type of thing. I have manually verified that it fixes the circular redirect issue.

          Hadoop QA added a comment -

          -1 overall. Here are the results of testing the latest attachment
          http://issues.apache.org/jira/secure/attachment/12516227/MR-3706.txt
          against trunk revision .

          +1 @author. The patch does not contain any @author tags.

          -1 tests included. The patch doesn't appear to include any new or modified tests.
          Please justify why no new tests are needed for this patch.
          Also please list what manual steps were performed to verify this patch.

          +1 javadoc. The javadoc tool did not generate any warning messages.

          +1 javac. The applied patch does not increase the total number of javac compiler warnings.

          +1 eclipse:eclipse. The patch built with eclipse:eclipse.

          +1 findbugs. The patch does not introduce any new Findbugs (version 1.3.9) warnings.

          +1 release audit. The applied patch does not increase the total number of release audit warnings.

          +1 core tests. The patch passed unit tests in .

          +1 contrib tests. The patch passed contrib unit tests.

          Test results: https://builds.apache.org/job/PreCommit-MAPREDUCE-Build/1942//testReport/
          Console output: https://builds.apache.org/job/PreCommit-MAPREDUCE-Build/1942//console

          This message is automatically generated.

          Arun C Murthy added a comment -

          I just committed this. Thanks Bobby!

          Hudson added a comment -

          Integrated in Hadoop-Hdfs-trunk-Commit #1889 (See https://builds.apache.org/job/Hadoop-Hdfs-trunk-Commit/1889/)
          MAPREDUCE-3706. Fix circular redirect error in job-attempts page. Contributed by Robert Evans. (Revision 1295314)

          Result = SUCCESS
          acmurthy : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1295314
          Files :

          • /hadoop/common/trunk/hadoop-mapreduce-project/CHANGES.txt
          • /hadoop/common/trunk/hadoop-mapreduce-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-web-proxy/src/main/java/org/apache/hadoop/yarn/server/webproxy/WebAppProxyServlet.java
          Hudson added a comment -

          Integrated in Hadoop-Hdfs-0.23-Commit #613 (See https://builds.apache.org/job/Hadoop-Hdfs-0.23-Commit/613/)
          Merge -c 1295314 from trunk to branch-0.23 to fix MAPREDUCE-3706. Fix circular redirect error in job-attempts page. (Revision 1295315)

          Result = SUCCESS
          acmurthy : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1295315
          Files :

          • /hadoop/common/branches/branch-0.23/hadoop-mapreduce-project/CHANGES.txt
          • /hadoop/common/branches/branch-0.23/hadoop-mapreduce-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-web-proxy/src/main/java/org/apache/hadoop/yarn/server/webproxy/WebAppProxyServlet.java
          Hudson added a comment -

          Integrated in Hadoop-Common-0.23-Commit #624 (See https://builds.apache.org/job/Hadoop-Common-0.23-Commit/624/)
          Merge -c 1295314 from trunk to branch-0.23 to fix MAPREDUCE-3706. Fix circular redirect error in job-attempts page. (Revision 1295315)

          Result = SUCCESS
          acmurthy : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1295315
          Files :

          • /hadoop/common/branches/branch-0.23/hadoop-mapreduce-project/CHANGES.txt
          • /hadoop/common/branches/branch-0.23/hadoop-mapreduce-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-web-proxy/src/main/java/org/apache/hadoop/yarn/server/webproxy/WebAppProxyServlet.java
          Hudson added a comment -

          Integrated in Hadoop-Common-trunk-Commit #1815 (See https://builds.apache.org/job/Hadoop-Common-trunk-Commit/1815/)
          MAPREDUCE-3706. Fix circular redirect error in job-attempts page. Contributed by Robert Evans. (Revision 1295314)

          Result = SUCCESS
          acmurthy : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1295314
          Files :

          • /hadoop/common/trunk/hadoop-mapreduce-project/CHANGES.txt
          • /hadoop/common/trunk/hadoop-mapreduce-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-web-proxy/src/main/java/org/apache/hadoop/yarn/server/webproxy/WebAppProxyServlet.java
          Hudson added a comment -

          Integrated in Hadoop-Mapreduce-0.23-Commit #623 (See https://builds.apache.org/job/Hadoop-Mapreduce-0.23-Commit/623/)
          Merge -c 1295314 from trunk to branch-0.23 to fix MAPREDUCE-3706. Fix circular redirect error in job-attempts page. (Revision 1295315)

          Result = ABORTED
          acmurthy : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1295315
          Files :

          • /hadoop/common/branches/branch-0.23/hadoop-mapreduce-project/CHANGES.txt
          • /hadoop/common/branches/branch-0.23/hadoop-mapreduce-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-web-proxy/src/main/java/org/apache/hadoop/yarn/server/webproxy/WebAppProxyServlet.java
          Hudson added a comment -

          Integrated in Hadoop-Mapreduce-trunk-Commit #1821 (See https://builds.apache.org/job/Hadoop-Mapreduce-trunk-Commit/1821/)
          MAPREDUCE-3706. Fix circular redirect error in job-attempts page. Contributed by Robert Evans. (Revision 1295314)

          Result = ABORTED
          acmurthy : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1295314
          Files :

          • /hadoop/common/trunk/hadoop-mapreduce-project/CHANGES.txt
          • /hadoop/common/trunk/hadoop-mapreduce-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-web-proxy/src/main/java/org/apache/hadoop/yarn/server/webproxy/WebAppProxyServlet.java
          Hudson added a comment -

          Integrated in Hadoop-Hdfs-trunk #971 (See https://builds.apache.org/job/Hadoop-Hdfs-trunk/971/)
          MAPREDUCE-3706. Fix circular redirect error in job-attempts page. Contributed by Robert Evans. (Revision 1295314)

          Result = SUCCESS
          acmurthy : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1295314
          Files :

          • /hadoop/common/trunk/hadoop-mapreduce-project/CHANGES.txt
          • /hadoop/common/trunk/hadoop-mapreduce-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-web-proxy/src/main/java/org/apache/hadoop/yarn/server/webproxy/WebAppProxyServlet.java
          Hudson added a comment -

          Integrated in Hadoop-Mapreduce-trunk #1006 (See https://builds.apache.org/job/Hadoop-Mapreduce-trunk/1006/)
          MAPREDUCE-3706. Fix circular redirect error in job-attempts page. Contributed by Robert Evans. (Revision 1295314)

          Result = SUCCESS
          acmurthy : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1295314
          Files :

          • /hadoop/common/trunk/hadoop-mapreduce-project/CHANGES.txt
          • /hadoop/common/trunk/hadoop-mapreduce-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-web-proxy/src/main/java/org/apache/hadoop/yarn/server/webproxy/WebAppProxyServlet.java

            People

            • Assignee:
              Robert Joseph Evans
              Reporter:
              Thomas Graves
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Development