Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Blocker Blocker
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 0.23.0
    • Component/s: mrv2
    • Labels:
      None

      Description

      Most are failing with some kerberos login exception:

      Running org.apache.hadoop.yarn.server.nodemanager.TestLinuxContainerExecutorWithMocks
      Tests run: 3, Failures: 1, Errors: 0, Skipped: 0, Time elapsed: 0.548 sec <<< FAILURE!

      Running org.apache.hadoop.yarn.server.resourcemanager.TestAppManager
      Tests run: 8, Failures: 0, Errors: 6, Skipped: 0, Time elapsed: 0.125 sec <<< FAILURE!
      Running org.apache.hadoop.yarn.server.resourcemanager.TestRMAuditLogger
      Tests run: 3, Failures: 0, Errors: 1, Skipped: 0, Time elapsed: 0.065 sec <<< FAILURE!

      Running org.apache.hadoop.yarn.server.resourcemanager.TestApplicationCleanup
      Tests run: 1, Failures: 0, Errors: 1, Skipped: 0, Time elapsed: 0.033 sec <<< FAILURE!

      Running org.apache.hadoop.yarn.server.resourcemanager.applicationsmanager.TestAMRMRPCResponseId
      Tests run: 1, Failures: 0, Errors: 1, Skipped: 0, Time elapsed: 0.024 sec <<< FAILURE!

      Running org.apache.hadoop.yarn.server.resourcemanager.TestRM
      Tests run: 3, Failures: 0, Errors: 3, Skipped: 0, Time elapsed: 0.072 sec <<< FAILURE!
      Running org.apache.hadoop.yarn.server.resourcemanager.TestApplicationACLs
      Tests run: 1, Failures: 0, Errors: 1, Skipped: 0, Time elapsed: 90.167 sec <<< FAILURE!
      Running org.apache.hadoop.yarn.server.resourcemanager.TestFifoScheduler
      Tests run: 1, Failures: 0, Errors: 1, Skipped: 0, Time elapsed: 0.056 sec <<< FAILURE!

      TestLinuxContainerExecutorWithMocks is tracked via MAPREDUCE-3281

      1. MR3285.txt
        2 kB
        Siddharth Seth

        Activity

        Arun C Murthy added a comment -

        All of them work on trunk, weird - need to investigate.

        Siddharth Seth added a comment -

        This should fix it.

        Trunk has the surefire fork.mode set to 'always' for all tests.
        0.23 MR has this set to once - except for the JobClient module.

        Some service is likely not shutting down in time.

        Hitesh Shah added a comment -

        After applying the patch, failures now seen in AMAuthorization.

        Tests in error:
        testAuthorizedAccess(org.apache.hadoop.yarn.server.resourcemanager.TestAMAuthorization)
        testUnauthorizedAccess(org.apache.hadoop.yarn.server.resourcemanager.TestAMAuthorization): Could not initialize class org.apache.hadoop.yarn.server.resourcemanager.TestAMAuthorization$MockRMWithAMS

        Mahadev konar added a comment -

        Hitesh, can you please open a new jira for that? I went ahead and committed this. Looks like Sid is not seeing these failures.

        Hitesh Shah added a comment -

        Works on linux but seems to fail on a mac. Will file a new jira if Sid can reproduce on his mac.

        Hudson added a comment -

        Integrated in Hadoop-Mapreduce-0.23-Build #66 (See https://builds.apache.org/job/Hadoop-Mapreduce-0.23-Build/66/)
        MAPREDUCE-3285. Tests on branch-0.23 failing (Siddharth Seth via mahadev)

        mahadev : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1190138
        Files :

        • /hadoop/common/branches/branch-0.23/hadoop-mapreduce-project/CHANGES.txt
        • /hadoop/common/branches/branch-0.23/hadoop-mapreduce-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-resourcemanager/pom.xml
        • /hadoop/common/branches/branch-0.23/hadoop-mapreduce-project/hadoop-yarn/pom.xml
        Hudson added a comment -

        Integrated in Hadoop-Mapreduce-0.23-Commit #90 (See https://builds.apache.org/job/Hadoop-Mapreduce-0.23-Commit/90/)
        MAPREDUCE-3285. Tests on branch-0.23 failing (Siddharth Seth via mahadev)

        mahadev : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1190138
        Files :

        • /hadoop/common/branches/branch-0.23/hadoop-mapreduce-project/CHANGES.txt
        • /hadoop/common/branches/branch-0.23/hadoop-mapreduce-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-resourcemanager/pom.xml
        • /hadoop/common/branches/branch-0.23/hadoop-mapreduce-project/hadoop-yarn/pom.xml
        Hudson added a comment -

        Integrated in Hadoop-Hdfs-0.23-Commit #90 (See https://builds.apache.org/job/Hadoop-Hdfs-0.23-Commit/90/)
        MAPREDUCE-3285. Tests on branch-0.23 failing (Siddharth Seth via mahadev)

        mahadev : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1190138
        Files :

        • /hadoop/common/branches/branch-0.23/hadoop-mapreduce-project/CHANGES.txt
        • /hadoop/common/branches/branch-0.23/hadoop-mapreduce-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-resourcemanager/pom.xml
        • /hadoop/common/branches/branch-0.23/hadoop-mapreduce-project/hadoop-yarn/pom.xml
        Hudson added a comment -

        Integrated in Hadoop-Common-0.23-Commit #90 (See https://builds.apache.org/job/Hadoop-Common-0.23-Commit/90/)
        MAPREDUCE-3285. Tests on branch-0.23 failing (Siddharth Seth via mahadev)

        mahadev : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1190138
        Files :

        • /hadoop/common/branches/branch-0.23/hadoop-mapreduce-project/CHANGES.txt
        • /hadoop/common/branches/branch-0.23/hadoop-mapreduce-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-resourcemanager/pom.xml
        • /hadoop/common/branches/branch-0.23/hadoop-mapreduce-project/hadoop-yarn/pom.xml
        Siddharth Seth added a comment -

        Am seing TestAMAuthorization fail on a Mac as well, only on branch 23 and irrespective of the order of tests. Same error - and a bunch of messages related to kerberos.
        testAuthorizedAccess(org.apache.hadoop.yarn.server.resourcemanager.TestAMAuthorization)
        testUnauthorizedAccess(org.apache.hadoop.yarn.server.resourcemanager.TestAMAuthorization): Could not initialize class org.apache.hadoop.yarn.server.resourcemanager.TestAMAuthorization$MockRMWithAMS

        noformat
        testAuthorizedAccess(org.apache.hadoop.yarn.server.resourcemanager.TestAMAuthorization) Time elapsed: 0.71 sec <<< ERROR!
        java.lang.ExceptionInInitializerError
        at org.apache.hadoop.security.UserGroupInformation.initialize(UserGroupInformation.java:197)
        at org.apache.hadoop.security.UserGroupInformation.setConfiguration(UserGroupInformation.java:254)
        at org.apache.hadoop.yarn.server.resourcemanager.TestAMAuthorization$MockRMWithAMS.<clinit>(TestAMAuthorization.java:96)
        at org.apache.hadoop.yarn.server.resourcemanager.TestAMAuthorization.testAuthorizedAccess(TestAMAuthorization.java:119)
        .....
        .....
        Caused by: java.lang.IllegalArgumentException: Can't get Kerberos configuration
        at org.apache.hadoop.security.HadoopKerberosName.<clinit>(HadoopKerberosName.java:46)
        ... 33 more
        Caused by: KrbException: I/O error while reading configuration file.
        at sun.security.krb5.Config.parseStanzaTable(Config.java:593)
        at sun.security.krb5.Config.loadStanzaTable(Config.java:127)
        at sun.security.krb5.Config.<init>(Config.java:176)
        at sun.security.krb5.Config.getInstance(Config.java:79)
        at org.apache.hadoop.security.HadoopKerberosName.<clinit>(HadoopKerberosName.java:43)
        ... 33 more
        testUnauthorizedAccess(org.apache.hadoop.yarn.server.resourcemanager.TestAMAuthorization) Time elapsed: 0 sec <<< ERROR!
        java.lang.NoClassDefFoundError: Could not initialize class org.apache.hadoop.yarn.server.resourcemanager.TestAMAuthorization$MockRMWithAMS
        at org.apache.hadoop.yarn.server.resourcemanager.TestAMAuthorization.testUnauthorizedAccess(TestAMAuthorization.java:175)
        noformat

        Mahadev konar added a comment -

        Sid, can you please open a new jira? Thanks

        Mahadev konar added a comment -

        Created MAPREDUCE-3295.

        Hudson added a comment -

        Integrated in Hadoop-Hdfs-0.23-Build #53 (See https://builds.apache.org/job/Hadoop-Hdfs-0.23-Build/53/)
        MAPREDUCE-3285. Tests on branch-0.23 failing (Siddharth Seth via mahadev)

        mahadev : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1190138
        Files :

        • /hadoop/common/branches/branch-0.23/hadoop-mapreduce-project/CHANGES.txt
        • /hadoop/common/branches/branch-0.23/hadoop-mapreduce-project/hadoop-yarn/hadoop-yarn-server/hadoop-yarn-server-resourcemanager/pom.xml
        • /hadoop/common/branches/branch-0.23/hadoop-mapreduce-project/hadoop-yarn/pom.xml

          People

          • Assignee:
            Siddharth Seth
            Reporter:
            Arun C Murthy
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Development